aboutsummaryrefslogtreecommitdiff
path: root/graphics/npretty
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-11-08 21:25:52 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-11-08 21:25:52 +0000
commit73e3f47683fb4ab1f96a3e15e52eb7669c36264f (patch)
tree32767387605f380a9267354ca2c87e980db53deb /graphics/npretty
parent1fe4323ba11340e8897952c316df1c51b809b8b9 (diff)
downloadports-73e3f47683fb4ab1f96a3e15e52eb7669c36264f.tar.gz
ports-73e3f47683fb4ab1f96a3e15e52eb7669c36264f.zip
Notes
Diffstat (limited to 'graphics/npretty')
-rw-r--r--graphics/npretty/Makefile35
-rw-r--r--graphics/npretty/distinfo3
-rw-r--r--graphics/npretty/pkg-descr4
-rw-r--r--graphics/npretty/pkg-plist5
4 files changed, 47 insertions, 0 deletions
diff --git a/graphics/npretty/Makefile b/graphics/npretty/Makefile
new file mode 100644
index 000000000000..74fa1cf1a293
--- /dev/null
+++ b/graphics/npretty/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: npretty
+# Date created: 11 October 2006
+# Whom: uchman
+#
+# $FreeBSD$
+#
+
+PORTNAME= npretty
+PORTVERSION= 0.9.3
+CATEGORIES= graphics
+MASTER_SITES= http://bbb.pean.org/junk/npretty/
+
+MAINTAINER= peter@pean.org
+COMMENT= A simple web-gallery ganerator written in perl
+
+RUN_DEPENDS= ${SITE_PERL}/Image/ExifTool.pm:${PORTSDIR}/graphics/p5-Image-ExifTool \
+ ${SITE_PERL}/mach/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick \
+ ${SITE_PERL}/mach/forks.pm:${PORTSDIR}/devel/p5-forks
+
+LIB_DEPENDS+= Magick.10:${PORTSDIR}/graphics/ImageMagick
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+post-patch:
+ @ ${REINPLACE_CMD} -e "s|/etc/|${PREFIX}/etc/|" ${WRKSRC}/npretty.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/npretty.pl ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/etc/npretty
+ ${INSTALL_DATA} ${WRKSRC}/novideo.gif ${PREFIX}/etc/npretty
+ ${INSTALL_DATA} ${WRKSRC}/npretty_template.tpl ${PREFIX}/etc/npretty
+ ${INSTALL_DATA} ${WRKSRC}/npretty.conf ${PREFIX}/etc/npretty
+
+.include <bsd.port.mk>
diff --git a/graphics/npretty/distinfo b/graphics/npretty/distinfo
new file mode 100644
index 000000000000..96a635f54dfe
--- /dev/null
+++ b/graphics/npretty/distinfo
@@ -0,0 +1,3 @@
+MD5 (npretty-0.9.3.tar.gz) = 8eb7233666167984a0b8bb3790ab5db9
+SHA256 (npretty-0.9.3.tar.gz) = add3cd00a5dc751c839c33faa1236e30af0c9eb07b45348adb02850541d2e8ee
+SIZE (npretty-0.9.3.tar.gz) = 33164
diff --git a/graphics/npretty/pkg-descr b/graphics/npretty/pkg-descr
new file mode 100644
index 000000000000..34b16dcd2015
--- /dev/null
+++ b/graphics/npretty/pkg-descr
@@ -0,0 +1,4 @@
+A very configureable web-gallery generator written in perl with support for
+templates.
+
+WWW: http://www.pulia.nu/coding.html
diff --git a/graphics/npretty/pkg-plist b/graphics/npretty/pkg-plist
new file mode 100644
index 000000000000..9bf5c7ccba6f
--- /dev/null
+++ b/graphics/npretty/pkg-plist
@@ -0,0 +1,5 @@
+bin/npretty.pl
+etc/npretty/npretty.conf
+etc/npretty/novideo.gif
+etc/npretty/npretty_template.tpl
+@dirrm etc/npretty