aboutsummaryrefslogtreecommitdiff
path: root/graphics/nvidia-texture-tools/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-16 23:47:52 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-10-16 23:47:52 +0000
commitdc70c24d937b636c9c5d9b3c21937e9b13758f79 (patch)
tree0c6e143c190ff64064f506d4fdba140ac2ddd1ad /graphics/nvidia-texture-tools/Makefile
parent79b3f8102bb70c6c1749430bbe336f9aec0575ec (diff)
downloadports-dc70c24d937b636c9c5d9b3c21937e9b13758f79.tar.gz
ports-dc70c24d937b636c9c5d9b3c21937e9b13758f79.zip
Notes
Diffstat (limited to 'graphics/nvidia-texture-tools/Makefile')
-rw-r--r--graphics/nvidia-texture-tools/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/graphics/nvidia-texture-tools/Makefile b/graphics/nvidia-texture-tools/Makefile
index 9dd4a875afcc..2a8008587023 100644
--- a/graphics/nvidia-texture-tools/Makefile
+++ b/graphics/nvidia-texture-tools/Makefile
@@ -11,10 +11,10 @@ MASTER_SITES= GOOGLE_CODE \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Texture Tools with support for DirectX 10 texture formats
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg:${PORTSDIR}/graphics/jpeg \
- tiff:${PORTSDIR}/graphics/tiff \
- IlmImf:${PORTSDIR}/graphics/OpenEXR
+LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libIlmImf.so:${PORTSDIR}/graphics/OpenEXR
USES= cmake
CMAKE_ARGS= -DNVTT_SHARED=TRUE
@@ -27,9 +27,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= NVIDIA_Texture_Tools_README.txt ChangeLog
OPTIONS_DEFINE= COMPRESSUI DOCS
+OPTIONS_DEFAULT=DOCS
+
COMPRESSUI_DESC=Build compressor UI (requires Qt4)
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MCOMPRESSUI}
@@ -40,7 +41,7 @@ PLIST_SUB+= COMPRESSUI=""
PLIST_SUB+= COMPRESSUI="@comment "
.endif
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= does not build
@@ -57,12 +58,10 @@ post-patch:
${WRKSRC}/src/CMakeLists.txt
.endif
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>