aboutsummaryrefslogtreecommitdiff
path: root/graphics/nvidia-texture-tools
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-04-21 11:01:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-04-21 11:01:59 +0000
commit76533f17366cac3d90151aef9f75a5f9db58b05b (patch)
tree18603b9c80ca700f62345978337a99848c9e8e17 /graphics/nvidia-texture-tools
parent4d519d4debc59e0ef9144d673494d6808675864d (diff)
downloadports-76533f17366cac3d90151aef9f75a5f9db58b05b.tar.gz
ports-76533f17366cac3d90151aef9f75a5f9db58b05b.zip
Notes
Diffstat (limited to 'graphics/nvidia-texture-tools')
-rw-r--r--graphics/nvidia-texture-tools/Makefile15
-rw-r--r--graphics/nvidia-texture-tools/distinfo4
-rw-r--r--graphics/nvidia-texture-tools/files/patch-src-nvcore-Debug.cpp6
-rw-r--r--graphics/nvidia-texture-tools/files/patch-src-nvcore-Memory.h8
-rw-r--r--graphics/nvidia-texture-tools/files/patch-src-nvcore-nvcore.h4
-rw-r--r--graphics/nvidia-texture-tools/files/patch-src-nvcore-poshlib-posh.h6
-rw-r--r--graphics/nvidia-texture-tools/files/patch-src-nvimage-ImageIO.cpp2
-rw-r--r--graphics/nvidia-texture-tools/files/patch-src-nvmath-nvmath.h8
-rw-r--r--graphics/nvidia-texture-tools/files/patch-src-nvtt-CMakeLists.txt6
-rw-r--r--graphics/nvidia-texture-tools/pkg-descr2
10 files changed, 32 insertions, 29 deletions
diff --git a/graphics/nvidia-texture-tools/Makefile b/graphics/nvidia-texture-tools/Makefile
index b822771bac5a..ee79bdb057ab 100644
--- a/graphics/nvidia-texture-tools/Makefile
+++ b/graphics/nvidia-texture-tools/Makefile
@@ -2,15 +2,17 @@
# $FreeBSD$
PORTNAME= nvidia-texture-tools
-DISTVERSION= 2.0.8-1
+PORTVERSION= 2.0.8.1 # needed to not bump PORTEPOCH; remove on next update
+DISTVERSION= 2.0.8
PORTREVISION= 7
CATEGORIES= graphics
-MASTER_SITES= GOOGLE_CODE \
- http://mirror.amdmi3.ru/distfiles/
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Texture Tools with support for DirectX 10 texture formats
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/NVIDIA_Texture_Tools_LICENSE.txt
+
LIB_DEPENDS= libpng.so:graphics/png \
libtiff.so:graphics/tiff \
libIlmImf.so:graphics/OpenEXR
@@ -19,14 +21,15 @@ BROKEN_ia64= does not build
BROKEN_powerpc= does not build
BROKEN_sparc64= does not build
+USE_GITHUB= yes
+GH_ACCOUNT= castano
+
USES= alias cmake jpeg
CMAKE_ARGS= -DNVTT_SHARED=TRUE
CFLAGS+= -fPIC
CXXFLAGS+= -fPIC
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
PORTDOCS= NVIDIA_Texture_Tools_README.txt ChangeLog
ONLY_FOR_ARCHS= i386 amd64 powerpc powerpc64 # see src/nvcore/nvcore.h
@@ -46,7 +49,7 @@ post-patch-COMPRESSUI-off:
${WRKSRC}/src/CMakeLists.txt
post-install-DOCS-on:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/graphics/nvidia-texture-tools/distinfo b/graphics/nvidia-texture-tools/distinfo
index 4a974b01bb45..31c543e733cf 100644
--- a/graphics/nvidia-texture-tools/distinfo
+++ b/graphics/nvidia-texture-tools/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nvidia-texture-tools-2.0.8-1.tar.gz) = 6b3c83500b420ee976f61eeae16e5727e2401e133f543baeac76c66c381eed2e
-SIZE (nvidia-texture-tools-2.0.8-1.tar.gz) = 935227
+SHA256 (castano-nvidia-texture-tools-2.0.8_GH0.tar.gz) = d188d0b28d61985c06dbc151278f8daa3edd680e910977d1261ba9fa4a151629
+SIZE (castano-nvidia-texture-tools-2.0.8_GH0.tar.gz) = 939218
diff --git a/graphics/nvidia-texture-tools/files/patch-src-nvcore-Debug.cpp b/graphics/nvidia-texture-tools/files/patch-src-nvcore-Debug.cpp
index ee6d6c863f7b..71f75cc9b6f6 100644
--- a/graphics/nvidia-texture-tools/files/patch-src-nvcore-Debug.cpp
+++ b/graphics/nvidia-texture-tools/files/patch-src-nvcore-Debug.cpp
@@ -1,5 +1,5 @@
---- src/nvcore/Debug.cpp.orig 2008-12-01 11:04:27.000000000 +0300
-+++ src/nvcore/Debug.cpp 2009-03-06 22:45:48.000000000 +0300
+--- src/nvcore/Debug.cpp.orig 2010-05-15 09:12:05 UTC
++++ src/nvcore/Debug.cpp
@@ -34,7 +34,7 @@
# endif
#endif
@@ -9,7 +9,7 @@
# include <unistd.h> // getpid
# include <sys/types.h>
# include <sys/sysctl.h> // sysctl
-@@ -195,6 +195,14 @@
+@@ -199,6 +199,14 @@ namespace
return (void *) ucp->uc_mcontext->ss.eip;
# endif
# endif
diff --git a/graphics/nvidia-texture-tools/files/patch-src-nvcore-Memory.h b/graphics/nvidia-texture-tools/files/patch-src-nvcore-Memory.h
index 93de8c198b09..0e75d65d1391 100644
--- a/graphics/nvidia-texture-tools/files/patch-src-nvcore-Memory.h
+++ b/graphics/nvidia-texture-tools/files/patch-src-nvcore-Memory.h
@@ -1,6 +1,6 @@
---- src/nvcore/Memory.h.orig 2010-05-14 21:59:28.000000000 +0400
-+++ src/nvcore/Memory.h 2013-03-13 11:44:40.704932899 +0400
-@@ -28,7 +28,7 @@
+--- src/nvcore/Memory.h.orig 2010-05-15 09:12:05 UTC
++++ src/nvcore/Memory.h
+@@ -28,7 +28,7 @@ namespace nv
// Override new/delete
@@ -9,7 +9,7 @@
{
return nv::mem::malloc(size);
}
-@@ -38,7 +38,7 @@
+@@ -38,7 +38,7 @@ inline void operator delete (void *p) th
nv::mem::free(p);
}
diff --git a/graphics/nvidia-texture-tools/files/patch-src-nvcore-nvcore.h b/graphics/nvidia-texture-tools/files/patch-src-nvcore-nvcore.h
index b77ddcc0d055..7722a0894d52 100644
--- a/graphics/nvidia-texture-tools/files/patch-src-nvcore-nvcore.h
+++ b/graphics/nvidia-texture-tools/files/patch-src-nvcore-nvcore.h
@@ -1,5 +1,5 @@
---- src/nvcore/nvcore.h.orig 2008-12-01 11:04:27.000000000 +0300
-+++ src/nvcore/nvcore.h 2009-03-06 22:45:11.000000000 +0300
+--- src/nvcore/nvcore.h.orig 2010-05-15 09:12:05 UTC
++++ src/nvcore/nvcore.h
@@ -38,6 +38,9 @@
#if defined POSH_OS_LINUX
# define NV_OS_LINUX 1
diff --git a/graphics/nvidia-texture-tools/files/patch-src-nvcore-poshlib-posh.h b/graphics/nvidia-texture-tools/files/patch-src-nvcore-poshlib-posh.h
index 640ebb7f8fdc..3346645b1446 100644
--- a/graphics/nvidia-texture-tools/files/patch-src-nvcore-poshlib-posh.h
+++ b/graphics/nvidia-texture-tools/files/patch-src-nvcore-poshlib-posh.h
@@ -1,6 +1,6 @@
---- src/nvcore/poshlib/posh.h.orig 2008-12-01 11:04:27.000000000 +0300
-+++ src/nvcore/poshlib/posh.h 2009-03-06 22:36:38.000000000 +0300
-@@ -293,6 +293,11 @@
+--- src/nvcore/poshlib/posh.h.orig 2010-05-15 09:12:05 UTC
++++ src/nvcore/poshlib/posh.h
+@@ -293,6 +293,11 @@ Metrowerks:
# define POSH_OS_STRING "Linux"
#endif
diff --git a/graphics/nvidia-texture-tools/files/patch-src-nvimage-ImageIO.cpp b/graphics/nvidia-texture-tools/files/patch-src-nvimage-ImageIO.cpp
index b0cdde632d6a..88eb50da1612 100644
--- a/graphics/nvidia-texture-tools/files/patch-src-nvimage-ImageIO.cpp
+++ b/graphics/nvidia-texture-tools/files/patch-src-nvimage-ImageIO.cpp
@@ -1,4 +1,4 @@
---- src/nvimage/ImageIO.cpp.orig 2010-05-14 17:59:28 UTC
+--- src/nvimage/ImageIO.cpp.orig 2010-05-15 09:12:05 UTC
+++ src/nvimage/ImageIO.cpp
@@ -603,7 +603,7 @@ static void user_read_data(png_structp p
{
diff --git a/graphics/nvidia-texture-tools/files/patch-src-nvmath-nvmath.h b/graphics/nvidia-texture-tools/files/patch-src-nvmath-nvmath.h
index 6230ee1a5c8a..43b5e1b15b1c 100644
--- a/graphics/nvidia-texture-tools/files/patch-src-nvmath-nvmath.h
+++ b/graphics/nvidia-texture-tools/files/patch-src-nvmath-nvmath.h
@@ -1,6 +1,6 @@
---- src/nvmath/nvmath.h.orig 2008-12-01 11:04:28.000000000 +0300
-+++ src/nvmath/nvmath.h 2009-03-06 22:38:28.000000000 +0300
-@@ -97,7 +97,7 @@
+--- src/nvmath/nvmath.h.orig 2010-05-15 09:12:05 UTC
++++ src/nvmath/nvmath.h
+@@ -115,7 +115,7 @@ inline bool isFinite(const float f)
{
#if NV_OS_WIN32
return _finite(f) != 0;
@@ -9,7 +9,7 @@
return isfinite(f);
#elif NV_OS_LINUX
return finitef(f);
-@@ -112,7 +112,7 @@
+@@ -130,7 +130,7 @@ inline bool isNan(const float f)
{
#if NV_OS_WIN32
return _isnan(f) != 0;
diff --git a/graphics/nvidia-texture-tools/files/patch-src-nvtt-CMakeLists.txt b/graphics/nvidia-texture-tools/files/patch-src-nvtt-CMakeLists.txt
index 4b78d2b32e0c..8066228e5985 100644
--- a/graphics/nvidia-texture-tools/files/patch-src-nvtt-CMakeLists.txt
+++ b/graphics/nvidia-texture-tools/files/patch-src-nvtt-CMakeLists.txt
@@ -1,6 +1,6 @@
---- src/nvtt/CMakeLists.txt.orig 2008-12-01 11:04:29.000000000 +0300
-+++ src/nvtt/CMakeLists.txt 2009-03-06 22:58:45.000000000 +0300
-@@ -105,9 +105,11 @@
+--- src/nvtt/CMakeLists.txt.orig 2010-05-15 09:12:05 UTC
++++ src/nvtt/CMakeLists.txt
+@@ -105,9 +105,11 @@ IF(QT4_FOUND AND NOT MSVC)
QT4_WRAP_CPP(MOCS tools/configdialog.h)
#QT4_ADD_RESOURCES(RCCS tools/configdialog.rc)
diff --git a/graphics/nvidia-texture-tools/pkg-descr b/graphics/nvidia-texture-tools/pkg-descr
index 8940d0cc5bc4..33d1455addca 100644
--- a/graphics/nvidia-texture-tools/pkg-descr
+++ b/graphics/nvidia-texture-tools/pkg-descr
@@ -9,4 +9,4 @@ DXT compression is based on Simon Brown's squish library. The library
also contains an alternative GPU-accelerated compressor that uses
CUDA and is one order of magnitude faster.
-WWW: http://code.google.com/p/nvidia-texture-tools/
+WWW: https://github.com/castano/nvidia-texture-tools