aboutsummaryrefslogtreecommitdiff
path: root/graphics/ocaml-images
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/ocaml-images
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
Notes
Diffstat (limited to 'graphics/ocaml-images')
-rw-r--r--graphics/ocaml-images/Makefile5
-rw-r--r--graphics/ocaml-images/files/patch-src_pngread.c38
-rw-r--r--graphics/ocaml-images/files/patch-src_pngwrite.c20
3 files changed, 61 insertions, 2 deletions
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index 00dec9e1bbf9..35cfee7734f1 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -8,7 +8,7 @@
PORTNAME= images
PORTVERSION= 3.0.2
-PORTREVISION= 7
+PORTREVISION= 8
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/cristal/caml-light/bazar-ocaml/ \
@@ -32,6 +32,7 @@ USE_OCAML_WASH= yes
OCAML_PKGDIRS= camlimages
USE_OCAML_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
@@ -48,7 +49,7 @@ OPTIONS= PNG "Enable PNG support" on \
.include <bsd.port.options.mk>
.if !defined(WITHOUT_PNG)
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-png
.else
CONFIGURE_ARGS+= --without-png
diff --git a/graphics/ocaml-images/files/patch-src_pngread.c b/graphics/ocaml-images/files/patch-src_pngread.c
new file mode 100644
index 000000000000..2e5a49bf9c4f
--- /dev/null
+++ b/graphics/ocaml-images/files/patch-src_pngread.c
@@ -0,0 +1,38 @@
+--- src/pngread.c.orig 2009-10-26 13:42:03.000000000 +0100
++++ src/pngread.c 2012-05-05 07:08:53.000000000 +0200
+@@ -69,7 +69,7 @@
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+@@ -134,7 +134,7 @@
+ png_set_rows(png_ptr, info_ptr, row_pointers);
+
+ /* Later, we can return something */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+@@ -243,7 +243,7 @@
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+@@ -302,7 +302,7 @@
+ png_set_rows(png_ptr, info_ptr, row_pointers);
+
+ /* Later, we can return something */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
diff --git a/graphics/ocaml-images/files/patch-src_pngwrite.c b/graphics/ocaml-images/files/patch-src_pngwrite.c
new file mode 100644
index 000000000000..dc6872e299d7
--- /dev/null
+++ b/graphics/ocaml-images/files/patch-src_pngwrite.c
@@ -0,0 +1,20 @@
+--- src/pngwrite.c.orig 2009-10-26 13:42:03.000000000 +0100
++++ src/pngwrite.c 2012-05-06 13:01:28.000000000 +0200
+@@ -62,7 +62,7 @@
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);
+@@ -171,7 +171,7 @@
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);