aboutsummaryrefslogtreecommitdiff
path: root/graphics/ocaml-images
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2010-04-09 10:06:44 +0000
committerStanislav Sedov <stas@FreeBSD.org>2010-04-09 10:06:44 +0000
commit5530c271c6249c799db773ee8921695cacdf142c (patch)
tree290baed88de1eeac0c298e6a2a93d0f0f8c22633 /graphics/ocaml-images
parent7d2b5e3b02b55df31957e726f6deccc08a00445c (diff)
Notes
Diffstat (limited to 'graphics/ocaml-images')
-rw-r--r--graphics/ocaml-images/Makefile4
-rw-r--r--graphics/ocaml-images/files/patch-src_gifwrite.c11
2 files changed, 13 insertions, 2 deletions
diff --git a/graphics/ocaml-images/Makefile b/graphics/ocaml-images/Makefile
index 1599bfc0b7d0..d96a2a36a78c 100644
--- a/graphics/ocaml-images/Makefile
+++ b/graphics/ocaml-images/Makefile
@@ -8,7 +8,7 @@
PORTNAME= images
PORTVERSION= 3.0.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.inria.fr/INRIA/Projects/cristal/caml-light/bazar-ocaml/ \
@@ -46,7 +46,7 @@ OPTIONS= PNG "Enable PNG support" on \
.include <bsd.port.options.mk>
.if !defined(WITHOUT_PNG)
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
CONFIGURE_ARGS+= --with-png
.else
CONFIGURE_ARGS+= --without-png
diff --git a/graphics/ocaml-images/files/patch-src_gifwrite.c b/graphics/ocaml-images/files/patch-src_gifwrite.c
new file mode 100644
index 000000000000..301d3821631f
--- /dev/null
+++ b/graphics/ocaml-images/files/patch-src_gifwrite.c
@@ -0,0 +1,11 @@
+--- ./src/gifwrite.c.orig 2010-04-09 03:01:01.000000000 -0700
++++ ./src/gifwrite.c 2010-04-09 03:01:08.000000000 -0700
+@@ -25,7 +25,7 @@
+
+ #include <gif_lib.h>
+
+-int list_length( value list )
++static int list_length( value list )
+ {
+ CAMLparam1(list);
+ CAMLlocal1(l);