aboutsummaryrefslogtreecommitdiff
path: root/graphics/ocaml-lablgl/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-02-06 15:42:16 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-02-06 15:42:16 +0000
commit08d561670ff56d7bd0910b88c4df9477194f8163 (patch)
tree06d0647b8a9c7bc2e5296154b4c8c40ae076c57a /graphics/ocaml-lablgl/Makefile
parent4aaccd87ee974cb18ff920f9a2192f17d5fe46b0 (diff)
downloadports-08d561670ff56d7bd0910b88c4df9477194f8163.tar.gz
ports-08d561670ff56d7bd0910b88c4df9477194f8163.zip
Notes
Diffstat (limited to 'graphics/ocaml-lablgl/Makefile')
-rw-r--r--graphics/ocaml-lablgl/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/graphics/ocaml-lablgl/Makefile b/graphics/ocaml-lablgl/Makefile
index 8745f5998258..d88c42a0eba8 100644
--- a/graphics/ocaml-lablgl/Makefile
+++ b/graphics/ocaml-lablgl/Makefile
@@ -41,7 +41,6 @@ CONFLICTS= ocaml-notk-[0-9]* ocaml-nox11-[0-9]*
USE_TK= 84+
INVALID_TK_VER = 86
.if defined(WITH_THREADS)
-USE_TK_THREADS = yes
THR_CPP= ${PTHREAD_CFLAGS}
THR_LD = ${PTHREAD_LIBS}
.endif
@@ -58,8 +57,8 @@ post-patch:
-e "s,^#\(LIBDIR[ \t]*=\).*,\1${PREFIX}/lib/ocaml,g" \
-e "s,^#\(DLLDIR[ \t]*=\).*,\1${PREFIX}/lib/ocaml/stublibs,g" \
-e "/^TKINCLUDES/s,=.*$$,= -I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}," \
- -e "/^TKLIBS/s,=.*$$,= -L${LOCALBASE}/lib -ltk${TK_VER:S/.//}${_TCL_THREADS_SUFFIX}\
- -ltcl${TCL_VER:S/.//}${_TCL_THREADS_SUFFIX} ${THR_LD}," \
+ -e "/^TKLIBS/s,=.*$$,= -L${LOCALBASE}/lib -ltk${TK_VER:S/.//}\
+ -ltcl${TCL_VER:S/.//} ${THR_LD}," \
${WRKSRC}/Makefile.config
@${REINPLACE_CMD} \