aboutsummaryrefslogtreecommitdiff
path: root/graphics/ogre3d
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2008-06-01 11:27:38 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2008-06-01 11:27:38 +0000
commit71f870f66ab7560547d06f3052368c45de76b3a8 (patch)
tree11d372f1c44f80517dc9d43893f1c671e6366a5b /graphics/ogre3d
parentb922497176cc50324d7aaec6ad6bdabbd201423e (diff)
downloadports-71f870f66ab7560547d06f3052368c45de76b3a8.tar.gz
ports-71f870f66ab7560547d06f3052368c45de76b3a8.zip
Notes
Diffstat (limited to 'graphics/ogre3d')
-rw-r--r--graphics/ogre3d/Makefile17
-rw-r--r--graphics/ogre3d/pkg-plist3
2 files changed, 18 insertions, 2 deletions
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index d29b9679b6d4..c8888604ee51 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -26,16 +26,29 @@ CONFIGURE_ARGS= --disable-cg --program-transform-name= --enable-static \
CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -DNDEBUG" \
ZZIPLIB_CFLAGS="-I${LOCALBASE}/include" \
ZZIPLIB_LIBS="-L${LOCALBASE}/lib -lzzip"
+
+OPTIONS= GTK "Use GTK instead of Xt gui" off
+
GNU_CONFIGURE= YES
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= YES
USE_BZIP2= YES
-#USE_GCC= 3.4
USE_GNOME= gnomehack
USE_GMAKE= YES
USE_SDL= sdl
USE_XORG= xaw
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GTK)
+USE_GNOME+= gtk20
+CONFIGURE_ARGS+=--with-gui=gtk
+PLIST_SUB+= WITH_GTK=""
+.else
+CONFIGURE_ARGS+=--with-gui=Xt
+PLIST_SUB+= WITH_GTK="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '\
s|sdl-config|${SDL_CONFIG}|g; \
@@ -77,4 +90,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/ogre3d/pkg-plist b/graphics/ogre3d/pkg-plist
index 1c5496d38517..cd7b87a4bbeb 100644
--- a/graphics/ogre3d/pkg-plist
+++ b/graphics/ogre3d/pkg-plist
@@ -1,6 +1,8 @@
bin/OgreMaterialUpgrade
bin/OgreMeshUpgrade
bin/OgreXMLConverter
+%%WITH_GTK%%include/OGRE/gtk/OgreConfigDialogImp.h
+%%WITH_GTK%%include/OGRE/gtk/OgreErrorDialogImp.h
include/OGRE/GLX/OgreConfigDialogImp.h
include/OGRE/GLX/OgreErrorDialogImp.h
include/OGRE/GLX/OgreTimerImp.h
@@ -247,6 +249,7 @@ libdata/pkgconfig/OGRE.pc
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README
@dirrm include/OGRE/GLX
+%%WITH_GTK%%@dirrm include/OGRE/gtk
@dirrm include/OGRE
@dirrm lib/OGRE
%%PORTDOCS%%@dirrm %%DOCSDIR%%