aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencv/files
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-07-11 08:28:12 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-07-11 08:28:12 +0000
commita64a157fde451838221107e2bbf7f6238b56d170 (patch)
tree71bf844e2f6b167c8ff6aa72eabe30460990e9d7 /graphics/opencv/files
parentc438d8da78fc86774f3fda0ed189d344b65cbd10 (diff)
downloadports-a64a157fde451838221107e2bbf7f6238b56d170.tar.gz
ports-a64a157fde451838221107e2bbf7f6238b56d170.zip
Notes
Diffstat (limited to 'graphics/opencv/files')
-rw-r--r--graphics/opencv/files/extra-patch-opencv10
-rw-r--r--graphics/opencv/files/extra-patch-opencv-core10
-rw-r--r--graphics/opencv/files/patch-modules-highgui-src-cap_ffmpeg_impl.hpp (renamed from graphics/opencv/files/patch-modules-highgui-src-cap_ffmpeg.c)6
3 files changed, 9 insertions, 17 deletions
diff --git a/graphics/opencv/files/extra-patch-opencv b/graphics/opencv/files/extra-patch-opencv
index 714e3f1bc2db..3d3fe1f8532e 100644
--- a/graphics/opencv/files/extra-patch-opencv
+++ b/graphics/opencv/files/extra-patch-opencv
@@ -1,6 +1,6 @@
---- modules/CMakeLists.txt.orig 2011-06-27 13:43:54.557252854 +0200
-+++ modules/CMakeLists.txt 2011-06-27 13:44:14.656997882 +0200
-@@ -8,29 +8,29 @@
+--- modules/CMakeLists.txt.orig 2011-07-04 06:21:57.000000000 +0200
++++ modules/CMakeLists.txt 2011-07-11 09:33:56.265459094 +0200
+@@ -8,25 +8,25 @@
endif()
add_subdirectory(calib3d)
@@ -10,10 +10,6 @@
-add_subdirectory(flann)
+#add_subdirectory(flann)
- if(MSVC OR MINGW)
- add_subdirectory(ffmpeg)
- endif()
-
if(BUILD_TESTS)
- add_subdirectory(ts)
+# add_subdirectory(ts)
diff --git a/graphics/opencv/files/extra-patch-opencv-core b/graphics/opencv/files/extra-patch-opencv-core
index 639e1c4949b6..5c41cc1f7504 100644
--- a/graphics/opencv/files/extra-patch-opencv-core
+++ b/graphics/opencv/files/extra-patch-opencv-core
@@ -1,6 +1,6 @@
---- modules/CMakeLists.txt.orig 2011-06-21 15:24:05.000000000 +0200
-+++ modules/CMakeLists.txt 2011-06-27 13:29:25.803871762 +0200
-@@ -7,34 +7,34 @@
+--- modules/CMakeLists.txt.orig 2011-07-04 06:21:57.000000000 +0200
++++ modules/CMakeLists.txt 2011-07-11 09:35:33.207215658 +0200
+@@ -7,30 +7,30 @@
add_subdirectory(androidcamera)
endif()
@@ -11,10 +11,6 @@
+#add_subdirectory(features2d)
add_subdirectory(flann)
- if(MSVC OR MINGW)
- add_subdirectory(ffmpeg)
- endif()
-
-if(BUILD_TESTS)
+#if(BUILD_TESTS)
add_subdirectory(ts)
diff --git a/graphics/opencv/files/patch-modules-highgui-src-cap_ffmpeg.c b/graphics/opencv/files/patch-modules-highgui-src-cap_ffmpeg_impl.hpp
index 98f15cd2998c..41a9e9c944c1 100644
--- a/graphics/opencv/files/patch-modules-highgui-src-cap_ffmpeg.c
+++ b/graphics/opencv/files/patch-modules-highgui-src-cap_ffmpeg_impl.hpp
@@ -1,6 +1,6 @@
---- modules/highgui/src/cap_ffmpeg.cpp.orig 2011-06-21 15:24:06.000000000 +0200
-+++ modules/highgui/src/cap_ffmpeg.cpp 2011-06-27 08:36:37.096041264 +0200
-@@ -53,7 +53,8 @@
+--- modules/highgui/src/cap_ffmpeg_impl.hpp.orig 2011-07-11 09:39:11.188904113 +0200
++++ modules/highgui/src/cap_ffmpeg_impl.hpp 2011-07-11 09:39:41.732624055 +0200
+@@ -57,7 +57,8 @@
#define UINT64_C
#define __STDC_CONSTANT_MACROS
// force re-inclusion of stdint.h to get INT64_C macro