aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencv/files
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-29 03:38:28 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-29 03:38:28 +0000
commit1398563371d7e700e5bcdf58892493e201a3d4f4 (patch)
treeea290d5227cf26caa251b029382fe33ea0153e7e /graphics/opencv/files
parent943100b79554d351721105f65f3cde8818f7f4ab (diff)
Notes
Diffstat (limited to 'graphics/opencv/files')
-rw-r--r--graphics/opencv/files/nopatch-aa103
-rw-r--r--graphics/opencv/files/patch-Makefile.in11
-rw-r--r--graphics/opencv/files/patch-apps_haartraining_src_cvboost.cpp11
-rw-r--r--graphics/opencv/files/patch-configure12
-rw-r--r--graphics/opencv/files/patch-cv_src_Makefile.in12
-rw-r--r--graphics/opencv/files/patch-cxcore_src_Makefile.in12
-rw-r--r--graphics/opencv/files/patch-cxcore_src_cxswitcher.cpp14
-rw-r--r--graphics/opencv/files/patch-otherlibs_highgui_Makefile.in20
-rw-r--r--graphics/opencv/files/patch-otherlibs_highgui_grfmts.h11
-rw-r--r--graphics/opencv/files/patch-otherlibs_highgui_loadsave.cpp11
-rw-r--r--graphics/opencv/files/patch-tests_cxcore_src_Makefile.in11
11 files changed, 228 insertions, 0 deletions
diff --git a/graphics/opencv/files/nopatch-aa b/graphics/opencv/files/nopatch-aa
new file mode 100644
index 000000000000..99df5097af74
--- /dev/null
+++ b/graphics/opencv/files/nopatch-aa
@@ -0,0 +1,103 @@
+--- cxcore/src/cxswitcher.cpp Mon Feb 28 16:34:30 2005
++++ cxcore/src/cxswitcher.cpp.freebsd Mon Feb 28 16:34:17 2005
+@@ -593,8 +593,8 @@
+ QueryPerformanceCounter( &counter );
+ return (int64)counter.QuadPart;
+ #else
+- timeval tv;
+- timezone tz;
++ struct timeval tv; // patch for FreeBSD: add "struct"
++ struct timezone tz; // patch for FreeBSD: add "struct"
+ gettimeofday( &tv, &tz );
+ return (int64)tv.tv_sec*1000000 + tv.tv_usec;
+ #endif
+
+--- cxcore/src/Makefile.in.orig Mon Feb 28 16:40:06 2005
++++ cxcore/src/Makefile.in Mon Feb 28 16:40:18 2005
+@@ -137,7 +137,7 @@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+-LIBS = -ldl -lpthread -lm
++LIBS = @LIBS@
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ LTLIBOBJS = @LTLIBOBJS@
+
+--- cv/src/Makefile.in.orig Mon Feb 28 16:41:54 2005
++++ cv/src/Makefile.in Mon Feb 28 16:42:14 2005
+@@ -177,7 +177,7 @@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+-LIBS = -ldl -lpthread -lm
++LIBS = @LIBS@
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ LTLIBOBJS = @LTLIBOBJS@
+
+--- otherlibs/highgui/Makefile.in.orig Mon Feb 28 18:02:19 2005
++++ otherlibs/highgui/Makefile.in Mon Feb 28 18:02:40 2005
+@@ -54,7 +54,7 @@
+ libhighgui_la_DEPENDENCIES =
+ am_libhighgui_la_OBJECTS = bitstrm.lo cvcap.lo cvcap_dc1394.lo \
+ cvcap_v4l.lo grfmt_base.lo grfmt_bmp.lo grfmt_jpeg.lo \
+- grfmt_png.lo grfmt_pxm.lo grfmt_sunras.lo grfmt_tiff.lo \
++ grfmt_png.lo grfmt_pxm.lo grfmt_sunras.lo \
+ image.lo loadsave.lo precomp.lo utils.lo window_lnx.lo \
+ window_w32.lo
+ libhighgui_la_OBJECTS = $(am_libhighgui_la_OBJECTS)
+@@ -201,7 +201,7 @@
+ lib_LTLIBRARIES = libhighgui.la
+ libhighgui_la_SOURCES = bitstrm.cpp cvcap.cpp cvcap_dc1394.cpp \
+ cvcap_v4l.cpp grfmt_base.cpp grfmt_bmp.cpp grfmt_jpeg.cpp \
+- grfmt_png.cpp grfmt_pxm.cpp grfmt_sunras.cpp grfmt_tiff.cpp \
++ grfmt_png.cpp grfmt_pxm.cpp grfmt_sunras.cpp \
+ image.cpp loadsave.cpp precomp.cpp utils.cpp window_lnx.cpp \
+ window_w32.cpp
+
+--- otherlibs/highgui/grfmts.h.orig Mon Feb 28 17:10:41 2005
++++ otherlibs/highgui/grfmts.h Mon Feb 28 17:10:45 2005
+@@ -47,7 +47,6 @@
+ #include "grfmt_sunras.h"
+ #include "grfmt_jpeg.h"
+ #include "grfmt_pxm.h"
+-#include "grfmt_tiff.h"
+ #include "grfmt_png.h"
+
+ #endif/*_GRFMTS_H_*/
+
+--- otherlibs/highgui/loadsave.cpp.orig Mon Feb 28 17:12:05 2005
++++ otherlibs/highgui/loadsave.cpp Mon Feb 28 17:12:09 2005
+@@ -299,7 +299,6 @@
+ m_factories->AddFactory( new GrFmtJpeg() );
+ m_factories->AddFactory( new GrFmtSunRaster() );
+ m_factories->AddFactory( new GrFmtPxM() );
+- m_factories->AddFactory( new GrFmtTiff() );
+ #ifdef HAVE_PNG
+ m_factories->AddFactory( new GrFmtPng() );
+ #endif
+
+--- configure.orig Thu Aug 19 03:46:49 2004
++++ configure Mon Feb 28 17:16:51 2005
+@@ -21218,7 +21218,7 @@
+
+
+ have_v4l=no
+-if test x$os_name=xLinux; then
++if test x$os_name = xLinux; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_CAMV4L
+
+--- tests/cxcore/src/Makefile.in.orig Mon Feb 28 17:32:29 2005
++++ tests/cxcore/src/Makefile.in Mon Feb 28 17:32:57 2005
+@@ -189,6 +189,7 @@
+ EXTRA_DIST = precomp.cpp cxcoretest.dsp cxcoretest.vcproj
+ INCLUDES = -I. -I../../../cxcore/include -I../../cxts -I../../..
+ cxcoretest_LDADD = -L../../../cxcore/src -lcxcore -L../../cxts -lcxts
++cxcoretest_LDFLAGS = -pthread
+ all: all-am
+
+ .SUFFIXES:
+
diff --git a/graphics/opencv/files/patch-Makefile.in b/graphics/opencv/files/patch-Makefile.in
new file mode 100644
index 000000000000..620e44755eb0
--- /dev/null
+++ b/graphics/opencv/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Thu Dec 29 14:20:44 2005
++++ Makefile.in Thu Dec 29 14:21:13 2005
+@@ -194,7 +194,7 @@
+
+ # All the rest of the distributed files
+ EXTRA_DIST = THANKS COPYING INSTALL README NEWS ChangeLog opencv.spec opencv.spec.in opencv.pc.in opencv.pc autogen.sh _make utils
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(libdir)data/pkgconfig
+ pkgconfig_DATA = opencv.pc
+ all: cvconfig.h
+ $(MAKE) $(AM_MAKEFLAGS) all-recursive
diff --git a/graphics/opencv/files/patch-apps_haartraining_src_cvboost.cpp b/graphics/opencv/files/patch-apps_haartraining_src_cvboost.cpp
new file mode 100644
index 000000000000..e4cfdf54cb48
--- /dev/null
+++ b/graphics/opencv/files/patch-apps_haartraining_src_cvboost.cpp
@@ -0,0 +1,11 @@
+--- apps/haartraining/src/cvboost.cpp.orig Thu Dec 29 13:52:01 2005
++++ apps/haartraining/src/cvboost.cpp Thu Dec 29 13:52:08 2005
+@@ -40,7 +40,7 @@
+ //M*/
+
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <memory.h>
+ #include <float.h>
+ #include <math.h>
diff --git a/graphics/opencv/files/patch-configure b/graphics/opencv/files/patch-configure
new file mode 100644
index 000000000000..19813ec7a53a
--- /dev/null
+++ b/graphics/opencv/files/patch-configure
@@ -0,0 +1,12 @@
+--- configure.orig Thu Aug 19 03:46:49 2004
++++ configure Mon Feb 28 17:16:51 2005
+@@ -21218,7 +21218,7 @@
+
+
+ have_v4l=no
+-if test x$os_name=xLinux; then
++if test x$os_name = xLinux; then
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_CAMV4L
+
diff --git a/graphics/opencv/files/patch-cv_src_Makefile.in b/graphics/opencv/files/patch-cv_src_Makefile.in
new file mode 100644
index 000000000000..f68fc107dbad
--- /dev/null
+++ b/graphics/opencv/files/patch-cv_src_Makefile.in
@@ -0,0 +1,12 @@
+--- cv/src/Makefile.in.orig Mon Feb 28 16:41:54 2005
++++ cv/src/Makefile.in Mon Feb 28 16:42:14 2005
+@@ -177,7 +177,7 @@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+-LIBS = -ldl -lpthread -lm
++LIBS = @LIBS@
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ LTLIBOBJS = @LTLIBOBJS@
+
diff --git a/graphics/opencv/files/patch-cxcore_src_Makefile.in b/graphics/opencv/files/patch-cxcore_src_Makefile.in
new file mode 100644
index 000000000000..cdc0918921ad
--- /dev/null
+++ b/graphics/opencv/files/patch-cxcore_src_Makefile.in
@@ -0,0 +1,12 @@
+--- cxcore/src/Makefile.in.orig Mon Feb 28 16:40:06 2005
++++ cxcore/src/Makefile.in Mon Feb 28 16:40:18 2005
+@@ -137,7 +137,7 @@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ LDFLAGS = @LDFLAGS@
+ LIBOBJS = @LIBOBJS@
+-LIBS = -ldl -lpthread -lm
++LIBS = @LIBS@
+ LIBTOOL = @LIBTOOL@
+ LN_S = @LN_S@
+ LTLIBOBJS = @LTLIBOBJS@
+
diff --git a/graphics/opencv/files/patch-cxcore_src_cxswitcher.cpp b/graphics/opencv/files/patch-cxcore_src_cxswitcher.cpp
new file mode 100644
index 000000000000..62e88d5e6963
--- /dev/null
+++ b/graphics/opencv/files/patch-cxcore_src_cxswitcher.cpp
@@ -0,0 +1,14 @@
+--- cxcore/src/cxswitcher.cpp Mon Feb 28 16:34:30 2005
++++ cxcore/src/cxswitcher.cpp.freebsd Mon Feb 28 16:34:17 2005
+@@ -593,8 +593,8 @@
+ QueryPerformanceCounter( &counter );
+ return (int64)counter.QuadPart;
+ #else
+- timeval tv;
+- timezone tz;
++ struct timeval tv; // patch for FreeBSD: add "struct"
++ struct timezone tz; // patch for FreeBSD: add "struct"
+ gettimeofday( &tv, &tz );
+ return (int64)tv.tv_sec*1000000 + tv.tv_usec;
+ #endif
+
diff --git a/graphics/opencv/files/patch-otherlibs_highgui_Makefile.in b/graphics/opencv/files/patch-otherlibs_highgui_Makefile.in
new file mode 100644
index 000000000000..bb7e6184e6a3
--- /dev/null
+++ b/graphics/opencv/files/patch-otherlibs_highgui_Makefile.in
@@ -0,0 +1,20 @@
+--- otherlibs/highgui/Makefile.in.orig Thu Aug 19 20:46:43 2004
++++ otherlibs/highgui/Makefile.in Thu Dec 29 13:44:02 2005
+@@ -54,7 +54,7 @@
+ libhighgui_la_DEPENDENCIES =
+ am_libhighgui_la_OBJECTS = bitstrm.lo cvcap.lo cvcap_dc1394.lo \
+ cvcap_v4l.lo grfmt_base.lo grfmt_bmp.lo grfmt_jpeg.lo \
+- grfmt_png.lo grfmt_pxm.lo grfmt_sunras.lo grfmt_tiff.lo \
++ grfmt_png.lo grfmt_pxm.lo grfmt_sunras.lo \
+ image.lo loadsave.lo precomp.lo utils.lo window_lnx.lo \
+ window_w32.lo
+ libhighgui_la_OBJECTS = $(am_libhighgui_la_OBJECTS)
+@@ -201,7 +201,7 @@
+ lib_LTLIBRARIES = libhighgui.la
+ libhighgui_la_SOURCES = bitstrm.cpp cvcap.cpp cvcap_dc1394.cpp \
+ cvcap_v4l.cpp grfmt_base.cpp grfmt_bmp.cpp grfmt_jpeg.cpp \
+- grfmt_png.cpp grfmt_pxm.cpp grfmt_sunras.cpp grfmt_tiff.cpp \
++ grfmt_png.cpp grfmt_pxm.cpp grfmt_sunras.cpp \
+ image.cpp loadsave.cpp precomp.cpp utils.cpp window_lnx.cpp \
+ window_w32.cpp
+
diff --git a/graphics/opencv/files/patch-otherlibs_highgui_grfmts.h b/graphics/opencv/files/patch-otherlibs_highgui_grfmts.h
new file mode 100644
index 000000000000..1c92a4aa2774
--- /dev/null
+++ b/graphics/opencv/files/patch-otherlibs_highgui_grfmts.h
@@ -0,0 +1,11 @@
+--- otherlibs/highgui/grfmts.h.orig Mon Feb 28 17:10:41 2005
++++ otherlibs/highgui/grfmts.h Mon Feb 28 17:10:45 2005
+@@ -47,7 +47,6 @@
+ #include "grfmt_sunras.h"
+ #include "grfmt_jpeg.h"
+ #include "grfmt_pxm.h"
+-#include "grfmt_tiff.h"
+ #include "grfmt_png.h"
+
+ #endif/*_GRFMTS_H_*/
+
diff --git a/graphics/opencv/files/patch-otherlibs_highgui_loadsave.cpp b/graphics/opencv/files/patch-otherlibs_highgui_loadsave.cpp
new file mode 100644
index 000000000000..e3c26d2c95f0
--- /dev/null
+++ b/graphics/opencv/files/patch-otherlibs_highgui_loadsave.cpp
@@ -0,0 +1,11 @@
+--- otherlibs/highgui/loadsave.cpp.orig Mon Feb 28 17:12:05 2005
++++ otherlibs/highgui/loadsave.cpp Mon Feb 28 17:12:09 2005
+@@ -299,7 +299,6 @@
+ m_factories->AddFactory( new GrFmtJpeg() );
+ m_factories->AddFactory( new GrFmtSunRaster() );
+ m_factories->AddFactory( new GrFmtPxM() );
+- m_factories->AddFactory( new GrFmtTiff() );
+ #ifdef HAVE_PNG
+ m_factories->AddFactory( new GrFmtPng() );
+ #endif
+
diff --git a/graphics/opencv/files/patch-tests_cxcore_src_Makefile.in b/graphics/opencv/files/patch-tests_cxcore_src_Makefile.in
new file mode 100644
index 000000000000..d3649b9a027d
--- /dev/null
+++ b/graphics/opencv/files/patch-tests_cxcore_src_Makefile.in
@@ -0,0 +1,11 @@
+--- tests/cxcore/src/Makefile.in.orig Mon Feb 28 17:32:29 2005
++++ tests/cxcore/src/Makefile.in Mon Feb 28 17:32:57 2005
+@@ -189,6 +189,7 @@
+ EXTRA_DIST = precomp.cpp cxcoretest.dsp cxcoretest.vcproj
+ INCLUDES = -I. -I../../../cxcore/include -I../../cxts -I../../..
+ cxcoretest_LDADD = -L../../../cxcore/src -lcxcore -L../../cxts -lcxts
++cxcoretest_LDFLAGS = -pthread
+ all: all-am
+
+ .SUFFIXES:
+