aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencv
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2011-12-17 11:42:05 +0000
committerMartin Matuska <mm@FreeBSD.org>2011-12-17 11:42:05 +0000
commiteed66ea71aca213d90365afc703b7304b4a32e82 (patch)
tree1e4a4ffa73ff03d756f906746bce3518a3101d1b /graphics/opencv
parent0d427a39aa8bdb6d79f180290087fec83526e4e9 (diff)
downloadports-eed66ea71aca213d90365afc703b7304b4a32e82.tar.gz
ports-eed66ea71aca213d90365afc703b7304b4a32e82.zip
Notes
Diffstat (limited to 'graphics/opencv')
-rw-r--r--graphics/opencv/Makefile3
-rw-r--r--graphics/opencv/files/patch-modules-flann-include-opencv2-flann-any.h17
-rw-r--r--graphics/opencv/files/patch-modules-flann-include-opencv2-flann-lsh_index.h13
3 files changed, 32 insertions, 1 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 13ff91506828..2d300b978817 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= opencv
PORTVERSION= 2.3.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}library/${PORTNAME}-unix/${PORTVERSION}
DISTNAME= OpenCV-${DISTVERSION}a
@@ -223,6 +223,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|${PORTNAME}/samples|examples/${PORTNAME}|g' \
${WRKSRC}/samples/*/CMakeLists.txt \
${WRKSRC}/samples/*/*/CMakeLists.txt
+ @${FIND} ${WRKSRC} -name '*.orig' -exec rm {} \;
.if defined(_BUILDING_OPENCV_CORE) && !defined(_BUILDING_OPENCV_PYTHON)
@${REINPLACE_CMD} -e '/add_subdirectory(data)/ d' \
diff --git a/graphics/opencv/files/patch-modules-flann-include-opencv2-flann-any.h b/graphics/opencv/files/patch-modules-flann-include-opencv2-flann-any.h
new file mode 100644
index 000000000000..02e70e5a59dc
--- /dev/null
+++ b/graphics/opencv/files/patch-modules-flann-include-opencv2-flann-any.h
@@ -0,0 +1,17 @@
+Index: modules/flann/include/opencv2/flann/any.h
+===================================================================
+--- modules/flann/include/opencv2/flann/any.h (revision 6880)
++++ modules/flann/include/opencv2/flann/any.h (revision 6881)
+@@ -30,6 +30,12 @@
+ {
+ };
+
++inline std::ostream& operator <<(std::ostream& out, const empty_any&)
++{
++ out << "[empty_any]";
++ return out;
++}
++
+ struct base_any_policy
+ {
+ virtual void static_delete(void** x) = 0;
diff --git a/graphics/opencv/files/patch-modules-flann-include-opencv2-flann-lsh_index.h b/graphics/opencv/files/patch-modules-flann-include-opencv2-flann-lsh_index.h
new file mode 100644
index 000000000000..fa7a76110192
--- /dev/null
+++ b/graphics/opencv/files/patch-modules-flann-include-opencv2-flann-lsh_index.h
@@ -0,0 +1,13 @@
+Index: modules/flann/include/opencv2/flann/lsh_index.h
+===================================================================
+--- modules/flann/include/opencv2/flann/lsh_index.h (revision 6880)
++++ modules/flann/include/opencv2/flann/lsh_index.h (revision 6881)
+@@ -56,7 +56,7 @@
+
+ struct LshIndexParams : public IndexParams
+ {
+- LshIndexParams(unsigned int table_number, unsigned int key_size, unsigned int multi_probe_level)
++ LshIndexParams(unsigned int table_number = 12, unsigned int key_size = 20, unsigned int multi_probe_level = 2)
+ {
+ (* this)["algorithm"] = FLANN_INDEX_LSH;
+ // The number of hash tables to use