aboutsummaryrefslogtreecommitdiff
path: root/graphics/opencv
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2007-12-22 15:16:31 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2007-12-22 15:16:31 +0000
commit4c939e003c17a8ed859dfaccef693adc8754ab75 (patch)
treeb239c859b475fe50ccc9c6c6f0cd328379734b78 /graphics/opencv
parent2b998f1a611043553e9dffdaa172058dc0700af3 (diff)
downloadports-4c939e003c17a8ed859dfaccef693adc8754ab75.tar.gz
ports-4c939e003c17a8ed859dfaccef693adc8754ab75.zip
Notes
Diffstat (limited to 'graphics/opencv')
-rw-r--r--graphics/opencv/Makefile6
-rw-r--r--graphics/opencv/files/patch-otherlibs-highgui-cvcap_v4l.cpp10
2 files changed, 14 insertions, 2 deletions
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 0da00ec76c2c..eaede051b127 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -8,7 +8,7 @@
PORTNAME= opencv
PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= opencvlibrary
@@ -16,6 +16,8 @@ MASTER_SITE_SUBDIR= opencvlibrary
MAINTAINER= msabramo@yahoo.com
COMMENT= Open Source Computer Vision Library from Intel
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat
+
CFLAGS+= -I${LOCALBASE}/include/OpenEXR
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/OpenEXR
LDFLAGS+= -L${LOCALBASE}/lib
@@ -24,7 +26,7 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --without-v4l --without-quicktime --without-carbon \
+CONFIGURE_ARGS= --with-v4l --without-quicktime --without-carbon \
--without-1394libs \
--without-swig # I don't know anything about swig ...
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/graphics/opencv/files/patch-otherlibs-highgui-cvcap_v4l.cpp b/graphics/opencv/files/patch-otherlibs-highgui-cvcap_v4l.cpp
new file mode 100644
index 000000000000..21e6f22d1a3c
--- /dev/null
+++ b/graphics/opencv/files/patch-otherlibs-highgui-cvcap_v4l.cpp
@@ -0,0 +1,10 @@
+--- otherlibs/highgui/cvcap_v4l.cpp.orig 2006-09-27 10:40:03.000000000 +0900
++++ otherlibs/highgui/cvcap_v4l.cpp 2007-12-15 14:44:37.000000000 +0900
+@@ -209,7 +209,6 @@
+
+ #include <string.h>
+ #include <stdlib.h>
+-#include <asm/types.h> /* for videodev2.h */
+ #include <assert.h>
+ #include <sys/stat.h>
+ #include <sys/ioctl.h>