aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendis
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>2002-01-14 21:49:24 +0000
committerJim Mock <jim@FreeBSD.org>2002-01-14 21:49:24 +0000
commita267c1efa96d7b25734c730a3be4f4bacd0f056f (patch)
tree323815c757f36520610312ad35b0e465f17a7587 /graphics/opendis
parente331adf0e851ce4e356e51fa97474908871c5166 (diff)
Fix MASTER_SITES, respect CFLAGS, remove unnecessary USE_AUTOCONF.
PR: 33883 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=53075
Diffstat (limited to 'graphics/opendis')
-rw-r--r--graphics/opendis/Makefile21
-rw-r--r--graphics/opendis/files/patch-configure.in11
2 files changed, 11 insertions, 21 deletions
diff --git a/graphics/opendis/Makefile b/graphics/opendis/Makefile
index 1496eb90e9f5..6d3251ef6c6b 100644
--- a/graphics/opendis/Makefile
+++ b/graphics/opendis/Makefile
@@ -7,24 +7,25 @@
PORTNAME= opendis
PORTVERSION= 0.0.3
+PORTREVISION= 1
CATEGORIES= graphics
-MASTER_SITES= http://ods.sourceforge.net/dl/ \
- ftp://ftp.nuug.no/pub/anders/distfiles/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://ods.sourceforge.net/dl/
+MASTER_SITE_SUBDIR= ods
MAINTAINER= ports@FreeBSD.org
-USE_AUTOCONF= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
-DOCS= NEWS AUTHORS doc/ERRATA doc/PHILOSOPHY doc/THUMB
+post-patch:
+ @${PERL} -pi -e 's|-pedantic -W|-pedantic|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's| -g| \@CFLAGS\@|g' ${WRKSRC}/src/Makefile.in
-.if !defined(NOPORTDOCS)
post-install:
- @${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/doc/${PORTNAME}
-.for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in NEWS AUTHORS doc/ERRATA doc/PHILOSOPHY doc/THUMB
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
diff --git a/graphics/opendis/files/patch-configure.in b/graphics/opendis/files/patch-configure.in
deleted file mode 100644
index a7a70acf8414..000000000000
--- a/graphics/opendis/files/patch-configure.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in.old Tue May 22 13:16:35 2001
-+++ configure.in Tue May 22 13:16:58 2001
-@@ -10,7 +10,7 @@
-
- if test "$GCC" = yes; then
- dnl Add some extra flags when compiling with gcc.
-- gcc_extra_cflags="-D_GNU_SOURCE -Wall -ansi -pedantic -W"
-+ gcc_extra_cflags="-D_GNU_SOURCE -ansi -pedantic"
- AC_SUBST(gcc_extra_cflags)
- fi
-