aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendx/files
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2001-07-05 11:11:40 +0000
committerThomas Gellekum <tg@FreeBSD.org>2001-07-05 11:11:40 +0000
commit6ff84648d304debc0bedce7f6242fc2c69e4fbfc (patch)
tree02d4f8484d9c0e7263c12ff17e3440d46a559ce9 /graphics/opendx/files
parent4b512074587ec7d37ac518450957ffa397947be9 (diff)
downloadports-6ff84648d304debc0bedce7f6242fc2c69e4fbfc.tar.gz
ports-6ff84648d304debc0bedce7f6242fc2c69e4fbfc.zip
Notes
Diffstat (limited to 'graphics/opendx/files')
-rw-r--r--graphics/opendx/files/patch-ab19
-rw-r--r--graphics/opendx/files/patch-ac11
-rw-r--r--graphics/opendx/files/patch-acconfig.h10
-rw-r--r--graphics/opendx/files/patch-acinclude.m422
-rw-r--r--graphics/opendx/files/patch-ad12
-rw-r--r--graphics/opendx/files/patch-ah43
-rw-r--r--graphics/opendx/files/patch-configure.in11
-rw-r--r--graphics/opendx/files/patch-src:exec:mklib11
-rw-r--r--graphics/opendx/files/patch-src:uipp:dxui:MacroDefinition.C59
-rw-r--r--graphics/opendx/files/patch-src:uipp:prompter:Browser.C107
10 files changed, 43 insertions, 262 deletions
diff --git a/graphics/opendx/files/patch-ab b/graphics/opendx/files/patch-ab
deleted file mode 100644
index ae1d50333be4..000000000000
--- a/graphics/opendx/files/patch-ab
+++ /dev/null
@@ -1,19 +0,0 @@
---- include/dx/arch.h.orig Wed May 26 01:14:59 1999
-+++ include/dx/arch.h Thu May 27 09:49:29 1999
-@@ -785,6 +785,16 @@
-
- #endif /* alphax */
-
-+/*
-+ * FreeBSD (and probably NetBSD and OpenBSD)
-+ */
-+#ifdef __FreeBSD__
-+
-+#undef F_CHAR_READY
-+#define F_CHAR_READY(fp) ((fp)->_r > 0 || (fp)->_ub._base)
-+
-+#endif /* __FreeBSD__ */
-+
-
-
- /* if standard IEEE floating point, these are the constants. the
diff --git a/graphics/opendx/files/patch-ac b/graphics/opendx/files/patch-ac
deleted file mode 100644
index 0373bee989bd..000000000000
--- a/graphics/opendx/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/exec/dpexec/loader.c.orig Wed May 26 01:51:54 1999
-+++ src/exec/dpexec/loader.c Thu May 27 10:13:59 1999
-@@ -852,7 +852,7 @@
- return ERROR;
- }
-
--Error DXUnloadObjFile(char *fname)
-+Error DXUnloadObjFile(char *fname, char *envvar)
- {
- /* the unload routine needs the entry point address, which we
- * wouldn't need to save unless this is an important function.
diff --git a/graphics/opendx/files/patch-acconfig.h b/graphics/opendx/files/patch-acconfig.h
deleted file mode 100644
index 00ce1c34d99b..000000000000
--- a/graphics/opendx/files/patch-acconfig.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- acconfig.h.orig Fri Dec 3 17:23:57 1999
-+++ acconfig.h Tue Mar 20 17:32:42 2001
-@@ -196,6 +196,7 @@
- #undef HAVE_OS2_H
- #undef HAVE_PROCESS_H
- #undef HAVE_PWD_H
-+#undef HAVE_REGEX_H
- #undef HAVE_REGEXP_H
- #undef HAVE_SETJMP_H
- #undef HAVE_SIGNAL_H
diff --git a/graphics/opendx/files/patch-acinclude.m4 b/graphics/opendx/files/patch-acinclude.m4
deleted file mode 100644
index 353168abb0ac..000000000000
--- a/graphics/opendx/files/patch-acinclude.m4
+++ /dev/null
@@ -1,22 +0,0 @@
---- acinclude.m4.orig Fri Mar 17 16:32:15 2000
-+++ acinclude.m4 Fri Mar 16 17:28:37 2001
-@@ -414,6 +414,10 @@
- DXEXEC_EXP='-Wl,-export-dynamic'
- AC_DEFINE_UNQUOTED(DXEXEC_EXP, $DXEXEC_EXP)
- ;;
-+ freebsd)
-+ DXEXEC_EXP='-Wl,-export-dynamic'
-+ AC_DEFINE_UNQUOTED(DXEXEC_EXP, $DXEXEC_EXP)
-+ ;;
- esac
- AC_MSG_RESULT(done)
- ])
-@@ -705,7 +709,7 @@
- AC_CACHE_VAL(ac_cv_type_$1,
- [AC_EGREP_CPP(dnl
- changequote(<<,>>)dnl
--<<$1[^a-zA-Z_0-9]>>dnl
-+<<typedef.*[^a-zA-Z_0-9]$1[\\t ]*;>>dnl
- changequote([,]), [#include <sys/types.h>
- #if STDC_HEADERS
- #include <stdlib.h>
diff --git a/graphics/opendx/files/patch-ad b/graphics/opendx/files/patch-ad
deleted file mode 100644
index 19266772041a..000000000000
--- a/graphics/opendx/files/patch-ad
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/exec/dxmods/_compoper1.c.orig Wed May 26 01:52:52 1999
-+++ src/exec/dxmods/_compoper1.c Thu May 27 10:21:45 1999
-@@ -477,6 +477,9 @@
- # define rint(x) ((float)((int)((x) + 0.5)))
- # define trunc(x) ((float)((int)(x)))
- #endif
-+#ifdef __FreeBSD__
-+# define trunc(x) ((float)((int)(x)))
-+#endif
- #define SIGN(x) ((x) >= 0? (1): (-1))
-
-
diff --git a/graphics/opendx/files/patch-ah b/graphics/opendx/files/patch-ah
index 4f8e6029f656..f355ff9dde40 100644
--- a/graphics/opendx/files/patch-ah
+++ b/graphics/opendx/files/patch-ah
@@ -1,20 +1,41 @@
---- bin/dxworker.in.orig Mon Mar 13 23:48:28 2000
-+++ bin/dxworker.in Fri Mar 16 18:53:29 2001
-@@ -25,7 +25,7 @@
- set exarch=freebsd
- set uiarch=freebsd
+--- bin/ORIG/dxworker.in Tue May 8 11:01:28 2001
++++ bin/dxworker.in Wed Jun 20 20:11:39 2001
+@@ -15,7 +15,7 @@
+ set thismach=`uname -m`
+ set thishost=`hostname | sed -e 's/\..*$//'`
+ set thisver=`uname -r`
+-set remote=/usr/bin/rsh
++set remote=/usr/bin/ssh
+ set showversion=0
-- set remote=/usr/bin/rsh
-+ set remote=/usr/bin/ssh
- breaksw
+@@ -155,9 +155,9 @@
+
+ setenv DXARCH $exarch
-@@ -140,7 +140,7 @@
-
- # default to running locally, from /usr/lpp/dx
+-# default to running locally, from /usr/lpp/dx
++# default to running locally, from @prefix@/dx
set exhost=$thishost
-set dxroot=/usr/lpp/dx
+set dxroot=@prefix@/dx
set startup=1 # run the startup window by default
+@@ -1137,7 +1137,7 @@
+ if (! $?port) set port=1900 # default socket
+ if (! $?cdto) set cdto=`pwd` # default current dir for exec
+
+-if (! $?dxdata) set dxdata="/usr/lpp/dx/samples/data"
++if (! $?dxdata) set dxdata="@prefix@/dx/samples/data"
+
+
+ #
+@@ -1605,7 +1605,7 @@
+ For example,
+ dx -key 193495946952abed bar.net
+
+- -dxroot dirname dx root directory; defaults to /usr/lpp/dx
++ -dxroot dirname dx root directory; defaults to @prefix@/dx
+
+ -macros pathlist directory list to search for UI macros
+ -data pathlist directory list to search for data files
diff --git a/graphics/opendx/files/patch-configure.in b/graphics/opendx/files/patch-configure.in
deleted file mode 100644
index ab7bdd8b93a9..000000000000
--- a/graphics/opendx/files/patch-configure.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in.orig Tue Mar 20 11:52:53 2001
-+++ configure.in Tue Mar 20 11:54:06 2001
-@@ -935,7 +935,7 @@
- get.h gl.h gl/device.h gl/gl.h invent.h io.h iop/afb.h iop/mov.h \
- iop/pfs.h iostream.h license.h limits.h malloc.h math.h memory.h \
- mingw32/dir.h mon.h net/if.h net/if_arp.h net/route.h netcdf.h netdb.h \
-- netinet/in.h os2.h process.h pwd.h regexp.h setjmp.h signal.h \
-+ netinet/in.h os2.h process.h pwd.h regex.h regexp.h setjmp.h signal.h \
- starbase.c.h stdarg.h stddef.h stdio.h stdlib.h stream.h string.h \
- strings.h strstrea.h strstream.h synch.h sys/access.h sys/bsd_types.h \
- sys/file.h sys/filio.h sys/ioctl.h sys/ipc.h sys/ldr.h sys/m88kbcs.h \
diff --git a/graphics/opendx/files/patch-src:exec:mklib b/graphics/opendx/files/patch-src:exec:mklib
new file mode 100644
index 000000000000..35e54f409b0d
--- /dev/null
+++ b/graphics/opendx/files/patch-src:exec:mklib
@@ -0,0 +1,11 @@
+--- src/exec/ORIG/mklib Thu Jan 11 12:08:51 2001
++++ src/exec/mklib Wed Jun 20 20:19:45 2001
+@@ -33,7 +33,7 @@
+ for i in $FMT_LIBS "" ; do
+ if test "$i" != "" ; then
+ lib=""
+- for j in /lib /usr/lib /usr/local/lib -lnsl -ldl -lm -lSM -lICE -lXm -lGL -lm -lXext -lXt -lX11 -lSM -lICE -lpthread ; do
++ for j in /lib /usr/lib /usr/local/lib -lnsl -ldl -lm -lSM -lICE ${MOTIFLIB} -lGL -lm -lXext -lXt -lX11 -lSM -lICE -lpthread ; do
+ k=`echo $j | sed -e "s/-L//"`
+ if test -f $k/$i ; then
+ lib=$k/$i
diff --git a/graphics/opendx/files/patch-src:uipp:dxui:MacroDefinition.C b/graphics/opendx/files/patch-src:uipp:dxui:MacroDefinition.C
deleted file mode 100644
index 51aa0cadf4ba..000000000000
--- a/graphics/opendx/files/patch-src:uipp:dxui:MacroDefinition.C
+++ /dev/null
@@ -1,59 +0,0 @@
---- src/uipp/dxui/MacroDefinition.C.orig Tue Mar 20 18:52:41 2001
-+++ src/uipp/dxui/MacroDefinition.C Tue Mar 20 20:49:26 2001
-@@ -42,7 +42,14 @@
-
- #define OLD_DUMMY_DESCRIPTION_STRING "Generated dummy input"
-
--#if defined(HAVE_RE_COMP)
-+#if HAVE_REGCOMP && HAVE_REGEX_H
-+/* prefer POSIX style regcomp(3) over obsolete versions */
-+extern "C" {
-+#include <regex.h>
-+}
-+#undef HAVE_RE_COMP
-+#undef HAVE_FINDFIRST
-+#elif defined(HAVE_RE_COMP)
- #undef HAVE_REGCMP
- #undef HAVE_REGCOMP
- #undef HAVE_FINDFIRST
-@@ -53,7 +60,7 @@
- #undef HAVE_FINDFIRST
- extern "C" char *regcmp(...);
- extern "C" char *regex(char *, char *, ...);
--#elif HAVE_REGCOMP
-+#elif HAVE_REGCOMP && HAVE_REGEXP_H
- extern "C" {
- #include <regexp.h>
- }
-@@ -594,7 +601,18 @@
- }
- else
- {
--#if defined(HAVE_REGCOMP)
-+#if defined(HAVE_REGCOMP) && defined(HAVE_REGEX_H)
-+
-+ regex_t net_file;
-+ ASSERT(regcomp(&net_file, ".[.]*\\.net$", REG_NOSUB) == 0);
-+
-+ struct dirent *entry;
-+ while (entry = readdir(d))
-+ {
-+ boolean exists = regexec(&net_file, entry->d_name, 0, NULL, 0);
-+ if (exists == 0)
-+
-+#elif defined(HAVE_REGCOMP) && defined(HAVE_REGEXP_H)
-
- char *net_file = (char *)regcomp(".[.]*\\.net$");
- ASSERT(net_file != NULL);
-@@ -691,7 +709,10 @@
- }
- _findclose(handle);
- delete srch_string;
--#elif defined(HAVE_REGCOMP)
-+#elif defined(HAVE_REGCOMP) && defined(HAVE_REGEX_H)
-+ }
-+ }
-+#elif defined(HAVE_REGCOMP) && defined(HAVE_REGEXP_H)
- }
- }
- #elif defined(HAVE_RE_COMP)
diff --git a/graphics/opendx/files/patch-src:uipp:prompter:Browser.C b/graphics/opendx/files/patch-src:uipp:prompter:Browser.C
deleted file mode 100644
index 0d54c51fa19c..000000000000
--- a/graphics/opendx/files/patch-src:uipp:prompter:Browser.C
+++ /dev/null
@@ -1,107 +0,0 @@
---- src/uipp/prompter/Browser.C.orig Tue Mar 20 18:52:42 2001
-+++ src/uipp/prompter/Browser.C Wed Mar 21 07:50:16 2001
-@@ -38,7 +38,13 @@
- #define stat _stat
- #endif
-
--#if defined(HAVE_RE_COMP)
-+#if HAVE_REGCOMP && HAVE_REGEX_H
-+extern "C" {
-+#include <regex.h>
-+}
-+#undef HAVE_RE_COMP
-+#undef HAVE_FINDFIRST
-+#elif defined(HAVE_RE_COMP)
- #undef HAVE_REGCMP
- #undef HAVE_REGCOMP
- #undef HAVE_FINDFIRST
-@@ -49,7 +55,7 @@
- #undef HAVE_FINDFIRST
- extern "C" char *regcmp(...);
- extern "C" char *regex(char *, char *, ...);
--#elif HAVE_REGCOMP
-+#elif HAVE_REGCOMP && HAVE_REGEXP_H
- extern "C" {
- #include <regexp.h>
- }
-@@ -1476,7 +1482,12 @@
-
- theIBMApplication->setBusyCursor(TRUE);
-
--#if defined(HAVE_REGCOMP)
-+#if defined(HAVE_REGCOMP) && defined(HAVE_REGEX_H)
-+
-+ regex_t search_for;
-+ ASSERT(regcomp(&search_for, text, REG_NOSUB) == 0);
-+
-+#elif defined(HAVE_REGCOMP) && defined(HAVE_REGEXP_H)
-
- char *search_for = (char *)regcomp(text);
- ASSERT(search_for != NULL);
-@@ -1533,7 +1544,20 @@
-
- int offset;
-
--#if defined(HAVE_REGCOMP)
-+#if defined(HAVE_REGCOMP) && defined(HAVE_REGEX_H)
-+
-+ int i;
-+ for (i = 0; i < STRLEN(buf); i++)
-+ if (regexec(&search_for, buf + i, 0, NULL, 0) != 0)
-+ break;
-+
-+ if (i)
-+ {
-+ offset = i - 1;
-+ found = 1;
-+ }
-+
-+#elif defined(HAVE_REGCOMP) && defined(HAVE_REGEXP_H)
-
- int i;
- for (i = 0; i < STRLEN(buf); i++)
-@@ -1610,7 +1634,7 @@
- if(!found)
- WarningMessage("Pattern not found");
-
--#if defined(HAVE_RECOMP) || defined(HAVE_REGCMP)
-+#if defined(HAVE_RE_COMP) || defined(HAVE_REGCMP)
- free(search_for);
- #endif
-
-@@ -1633,7 +1657,12 @@
-
- theIBMApplication->setBusyCursor(TRUE);
-
--#if defined(HAVE_REGCOMP)
-+#if defined(HAVE_REGCOMP) && defined(HAVE_REGEX_H)
-+
-+ regex_t search_for;
-+ ASSERT(regcomp(&search_for, text, REG_NOSUB) == 0);
-+
-+#elif defined(HAVE_REGCOMP) && defined(HAVE_REGEXP_H)
-
- char *search_for = (char *)regcomp(text);
- ASSERT(search_for != NULL);
-@@ -1695,7 +1724,20 @@
-
- int offset;
-
--#if defined(HAVE_REGCOMP)
-+#if defined(HAVE_REGCOMP) && defined(HAVE_REGEX_H)
-+
-+ if (regexec(&search_for, buf, 0, NULL, 0) == 0)
-+ {
-+ found = 1;
-+
-+ for (i = STRLEN(buf)-1; i >= 0; i--)
-+ if (regexec(&search_for, buf + i, 0, NULL, 0) != 0)
-+ break;
-+
-+ offset = i + 1;
-+ }
-+
-+#elif defined(HAVE_REGCOMP) && defined(HAVE_REGEXP_H)
-
- if (regexec((regexp *)search_for, buf))
- {