aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendx
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-24 11:01:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-10-24 11:01:48 +0000
commit17eb6fb568c97fb6545215b951e2cef2a088b6bf (patch)
treee8fa5ff1dffec839f06da9825426bc2924de4c26 /graphics/opendx
parentf115346674f2931b6771121ba6ebbaae61a2fde4 (diff)
downloadports-17eb6fb568c97fb6545215b951e2cef2a088b6bf.tar.gz
ports-17eb6fb568c97fb6545215b951e2cef2a088b6bf.zip
Notes
Diffstat (limited to 'graphics/opendx')
-rw-r--r--graphics/opendx/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index eed26c02489a..d06b630ddc76 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -50,13 +50,14 @@ LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
CONFIGURE_ARGS+= --without-netcdf
.endif
-.if !defined(WITHOUT_JAVA)
+.if defined(WITH_JAVA)
USE_JAVA= yes
JAVA_VERSION= 1.3+
BUILD_DEPENDS+= ${JAVALIBDIR}/npcosmop211.jar:${PORTSDIR}/graphics/cosmoplayer
RUN_DEPENDS+= ${JAVALIBDIR}/npcosmop211.jar:${PORTSDIR}/graphics/cosmoplayer
-CONFIGURE_ARGS+= --with-cosmojar-path=${JAVALIBDIR}/npcosmop211.jar \
- --with-java40jar-path=${JAVALIBDIR}/java40.jar
+CONFIGURE_ARGS+= --with-cosmojar-path=${JAVALIBDIR}/npcosmop211.jar \
+ --with-java40jar-path=${JAVALIBDIR}/java40.jar \
+ --with-jni-path=${JAVA_HOME}/include:${JAVA_HOME}/include/freebsd
PLIST_SUB+= JAVA=""
DIR2PRUNE= dx/java/user dx/java/server/nets
.else
@@ -68,6 +69,10 @@ PLIST_SUB+= UNAMEP=${ARCH}
.include <bsd.port.pre.mk>
+.if defined(WITH_JAVA) && ${ARCH} != "i386"
+BROKEN= does not build
+.endif
+
post-patch:
@${RM} -f ${WRKSRC}/include/stamp-h.in
.for dir in doc help html man
@@ -82,7 +87,7 @@ post-patch:
post-install:
@${CP} ${FILESDIR}/pkg-message.in ${PKGMESSAGE}
-.if !defined(WITHOUT_JAVA)
+.if defined(WITH_JAVA)
${CHMOD} 0775 ${PREFIX}/dx/java/server/nets
${TOUCH} ${DIR2PRUNE:S|^|${PREFIX}/|:S|$|/.keepme|}
@${ECHO} "---------------------------------------------------------" \