aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendx
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-01-29 16:13:53 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-01-29 16:13:53 +0000
commite6516a274e2582132a4b85352aa6b9e227388229 (patch)
tree58a496acd042be09cc745e32a0151615b0e2955a /graphics/opendx
parent1136813ee017e6acd68abe0c54d9f5dd38301de4 (diff)
downloadports-e6516a274e2582132a4b85352aa6b9e227388229.tar.gz
ports-e6516a274e2582132a4b85352aa6b9e227388229.zip
Notes
Diffstat (limited to 'graphics/opendx')
-rw-r--r--graphics/opendx/Makefile13
-rw-r--r--graphics/opendx/pkg-plist3
2 files changed, 10 insertions, 6 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index a0210b8881d2..f28ed01b2fa9 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -8,7 +8,7 @@
PORTNAME= opendx
PORTVERSION= 4.3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics math
MASTER_SITES= http://opendx.npaci.edu/source/
DISTNAME= dx-${PORTVERSION}
@@ -24,13 +24,14 @@ OPTIONS= HDF "Build hdf-support (only hdf OR netcdf is supported)" on \
USE_REINPLACE= yes
USE_BISON= yes
-USE_MESA= yes
+USE_GL= yes
USE_MOTIF= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --without-javadx
CFLAGS+= ${PTHREAD_CFLAGS}
-CONFIGURE_ENV= ARCH="freebsd" \
+CONFIGURE_ENV= ARCH="${OPSYS:L}" \
CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
USE_GMAKE= yes
@@ -40,11 +41,13 @@ PLIST_SUB= ARCH=${OPSYS:L}
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 502126
-BROKEN= "Broken pkg-plist"
+PLIST_SUB+= UNAMEP=${ARCH} ARCHDIR=""
+.else
+PLIST_SUB+= UNAMEP=${OPSYS:L} ARCHDIR="@comment "
.endif
.if defined(WITH_HDF)
-LIB_DEPENDS+= df.1:${PORTSDIR}/science/hdf
+LIB_DEPENDS+= mfhdf.2:${PORTSDIR}/science/hdf
.endif
.if defined(WITH_NETCDF)
diff --git a/graphics/opendx/pkg-plist b/graphics/opendx/pkg-plist
index 00dd94ff5850..6c521b4d4e47 100644
--- a/graphics/opendx/pkg-plist
+++ b/graphics/opendx/pkg-plist
@@ -2245,11 +2245,11 @@ dx/lib/dxrc
dx/lib/mdf2c.awk
dx/lib/messages
dx/lib/outboard.c
-dx/lib_%%ARCH%%/arch.mak
dx/lib_%%ARCH%%/libDX.a
dx/lib_%%ARCH%%/libDXL.a
dx/lib_%%ARCH%%/libDXcallm.a
dx/lib_%%ARCH%%/libDXlite.a
+dx/lib_%%UNAMEP%%/arch.mak
dx/man/catl/dx.l
dx/man/manl/dx.l
dx/ui/Basic2D.cfg
@@ -2301,6 +2301,7 @@ dx/ui/viewer.net
@dirrm dx/man/manl
@dirrm dx/man/catl
@dirrm dx/man
+%%ARCHDIR%%@dirrm dx/lib_%%UNAMEP%%
@dirrm dx/lib_%%ARCH%%
@dirrm dx/lib
@dirrm dx/include/dx