aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendx
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-08 07:10:20 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-08 07:10:20 +0000
commitf2f4d9e38598007f2881dbb2f651e2dbf9e2fa54 (patch)
tree1f7887c5368312d3d93b22ce166aae26a306f632 /graphics/opendx
parentc89de17a9c1f3653c0344f56b954e58db1a22cd1 (diff)
downloadports-f2f4d9e38598007f2881dbb2f651e2dbf9e2fa54.tar.gz
ports-f2f4d9e38598007f2881dbb2f651e2dbf9e2fa54.zip
Notes
Diffstat (limited to 'graphics/opendx')
-rw-r--r--graphics/opendx/Makefile34
-rw-r--r--graphics/opendx/distinfo2
-rw-r--r--graphics/opendx/files/patch-GARCommand.C22
-rw-r--r--graphics/opendx/files/patch-NumberInput.h11
-rw-r--r--graphics/opendx/files/patch-ah11
-rw-r--r--graphics/opendx/files/patch-ltmain.sh15
-rw-r--r--graphics/opendx/files/patch-src:exec:dpexec:yuiif.y24
-rw-r--r--graphics/opendx/files/patch-src:exec:mklib11
-rw-r--r--graphics/opendx/pkg-plist620
9 files changed, 340 insertions, 410 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index 2653a2dbd7c8..f048e6403114 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -7,11 +7,10 @@
#
PORTNAME= opendx
-PORTVERSION= 4.2.0
-PORTREVISION= 1
+PORTVERSION= 4.3.2
+PORTREVISION= 0
CATEGORIES= graphics math
-MASTER_SITES= http://www.research.ibm.com/dx/srcDownload/srcArchive/ \
- http://opendx.npaci.edu/source/
+MASTER_SITES= http://opendx.npaci.edu/source/
DISTNAME= dx-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -22,35 +21,26 @@ LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick \
netcdf.1:${PORTSDIR}/math/netcdf \
tiff.4:${PORTSDIR}/graphics/tiff
-USE_AUTOMAKE= yes
+USE_REINPLACE= yes
USE_BISON= yes
-USE_GMAKE= yes
USE_MESA= yes
USE_MOTIF= yes
USE_XLIB= yes
-USE_REINPLACE= yes
-AUTOMAKE_ARGS= -a -i
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --without-javadx
-CONFIGURE_ENV= ARCH="" \
- CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${PREFIX}/include" \
- CPPFLAGS="-I${PREFIX}/include" \
- CXXFLAGS="${CFLAGS} ${PTHREAD_CFLAGS} -I${PREFIX}/include" \
- LDFLAGS="-L${PREFIX}/lib ${LDFLAGS} ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --without-javadx
+CFLAGS+= ${PTHREAD_CFLAGS}
+CONFIGURE_ENV= ARCH="freebsd" \
+ CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+USE_GMAKE= yes
NO_MTREE= yes
PLIST_SUB= ARCH=${OPSYS:L}
post-patch:
@${RM} -f ${WRKSRC}/include/stamp-h.in
-
-post-configure:
- ${REINPLACE_CMD} -e "s;flex ;flex -l ;g" ${WRKSRC}/src/uipp/dxuilib/Makefile
-
-post-install:
- @${ECHO_MSG} "===> Fixing path in the docs (/usr/lpp -> ${PREFIX})"
.for dir in doc help html man
- @${FIND} ${PREFIX}/dx/${dir} -type f | \
- ${XARGS} ${REINPLACE_CMD} -e "s;/usr/lpp;${PREFIX};g"
+ @${FIND} ${WRKSRC}/${dir} -type f | ${XARGS} \
+ ${REINPLACE_CMD} -e "s;/usr/lpp;${PREFIX};g"
.endfor
.include <bsd.port.mk>
diff --git a/graphics/opendx/distinfo b/graphics/opendx/distinfo
index d1ee1bbb100f..fe9e6aa53c65 100644
--- a/graphics/opendx/distinfo
+++ b/graphics/opendx/distinfo
@@ -1 +1 @@
-MD5 (dx-4.2.0.tar.gz) = a57c5ee29457d5cb4745986f696ea19e
+MD5 (dx-4.3.2.tar.gz) = 201afdd86a5ddcfda0dc60fc7b6d3fea
diff --git a/graphics/opendx/files/patch-GARCommand.C b/graphics/opendx/files/patch-GARCommand.C
deleted file mode 100644
index ae978ea280f2..000000000000
--- a/graphics/opendx/files/patch-GARCommand.C
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/uipp/prompter/GARCommand.C.orig Sat Nov 30 02:48:50 2002
-+++ src/uipp/prompter/GARCommand.C Sat Nov 30 02:46:44 2002
-@@ -18,6 +18,7 @@
- #elif defined(HAVE_STRSTREA_H)
- #include <strstrea.h>
- #endif
-+#include <strstream>
-
- #include "NoUndoCommand.h"
- #include "GARApplication.h"
-@@ -50,9 +51,9 @@
- char *fname;
- unsigned long mode;
- int dirty;
-- strstream tmpstr;
-+ std::strstream tmpstr;
- #ifdef aviion
-- strstream tmpstr2;
-+ std::strstream tmpstr2;
- #endif
-
- switch (this->option)
diff --git a/graphics/opendx/files/patch-NumberInput.h b/graphics/opendx/files/patch-NumberInput.h
deleted file mode 100644
index a0b668545e80..000000000000
--- a/graphics/opendx/files/patch-NumberInput.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/uipp/widgets/NumberInput.h.orig Wed Mar 12 22:56:49 2003
-+++ src/uipp/widgets/NumberInput.h Wed Mar 12 23:06:33 2003
-@@ -12,7 +12,7 @@
- #include <stdlib.h> /* strtod() */
- #include <errno.h> /* errno, ERANGE */
- #define XK_MISCELLANY 1
--#include <X11/keysymdef.h>
-+#include <X11/keysym.h>
-
- #if defined(__cplusplus) || defined(c_plusplus)
- extern "C" {
diff --git a/graphics/opendx/files/patch-ah b/graphics/opendx/files/patch-ah
deleted file mode 100644
index 7a5214f28fb5..000000000000
--- a/graphics/opendx/files/patch-ah
+++ /dev/null
@@ -1,11 +0,0 @@
---- bin/ORIG/dxworker.in Tue May 8 11:01:28 2001
-+++ bin/dxworker.in Wed Jun 20 20:11:39 2001
-@@ -15,7 +15,7 @@
- set thismach=`uname -m`
- set thishost=`hostname | sed -e 's/\..*$//'`
- set thisver=`uname -r`
--set remote=/usr/bin/rsh
-+set remote=/usr/bin/ssh
- set showversion=0
-
-
diff --git a/graphics/opendx/files/patch-ltmain.sh b/graphics/opendx/files/patch-ltmain.sh
new file mode 100644
index 000000000000..e501c8fd5cfa
--- /dev/null
+++ b/graphics/opendx/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Thu Jan 8 13:51:00 2004
++++ ltmain.sh Thu Jan 8 13:51:11 2004
+@@ -5425,10 +5425,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/graphics/opendx/files/patch-src:exec:dpexec:yuiif.y b/graphics/opendx/files/patch-src:exec:dpexec:yuiif.y
deleted file mode 100644
index 816f264d2fb7..000000000000
--- a/graphics/opendx/files/patch-src:exec:dpexec:yuiif.y
+++ /dev/null
@@ -1,24 +0,0 @@
---- src/exec/dpexec/yuiif.y-orig Mon Jul 31 10:10:38 2000
-+++ src/exec/dpexec/yuiif.y Tue Nov 26 14:31:53 2002
-@@ -1550,18 +1550,21 @@
- if (! _dxd_exUIPacket)
- yyerrok;
- }
-+ ;
-
- rightparen : T_RPAR
- {
- if (! _dxd_exUIPacket)
- yyerrok;
- }
-+ ;
-
- rightbracket : T_RBRA
- {
- if (! _dxd_exUIPacket)
- yyerrok;
- }
-+ ;
-
- id : T_ID
- {
diff --git a/graphics/opendx/files/patch-src:exec:mklib b/graphics/opendx/files/patch-src:exec:mklib
deleted file mode 100644
index 35e54f409b0d..000000000000
--- a/graphics/opendx/files/patch-src:exec:mklib
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/exec/ORIG/mklib Thu Jan 11 12:08:51 2001
-+++ src/exec/mklib Wed Jun 20 20:19:45 2001
-@@ -33,7 +33,7 @@
- for i in $FMT_LIBS "" ; do
- if test "$i" != "" ; then
- lib=""
-- for j in /lib /usr/lib /usr/local/lib -lnsl -ldl -lm -lSM -lICE -lXm -lGL -lm -lXext -lXt -lX11 -lSM -lICE -lpthread ; do
-+ for j in /lib /usr/lib /usr/local/lib -lnsl -ldl -lm -lSM -lICE ${MOTIFLIB} -lGL -lm -lXext -lXt -lX11 -lSM -lICE -lpthread ; do
- k=`echo $j | sed -e "s/-L//"`
- if test -f $k/$i ; then
- lib=$k/$i
diff --git a/graphics/opendx/pkg-plist b/graphics/opendx/pkg-plist
index df5a2e96f3ec..00dd94ff5850 100644
--- a/graphics/opendx/pkg-plist
+++ b/graphics/opendx/pkg-plist
@@ -1,118 +1,51 @@
bin/dx
-dx/lib_%%ARCH%%/libDXlite.a
-dx/lib_%%ARCH%%/libDX.a
-dx/lib_%%ARCH%%/libDXcallm.a
-dx/lib_%%ARCH%%/libDXL.a
-dx/lib_%%ARCH%%/arch.mak
-dx/lib/dx.mdf
-dx/lib/mdf2c.awk
-dx/lib/messages
-dx/lib/colors.txt
-dx/lib/dxfSaveCurrentImage.net
-dx/lib/dxrc
-dx/lib/dxexec.exp
-dx/lib/outboard.c
+dx/bin/dx
+dx/bin/mdf2c
+dx/bin/url_handler.sh
+dx/bin_%%ARCH%%/builder
dx/bin_%%ARCH%%/dxexec
dx/bin_%%ARCH%%/dxui
dx/bin_%%ARCH%%/prompter
-dx/bin_%%ARCH%%/tutor
-dx/bin_%%ARCH%%/builder
dx/bin_%%ARCH%%/startupui
-dx/ui/icon50.dat
-dx/ui/icon50.xpm
-dx/ui/logo.dat
-dx/ui/logo.xpm
-dx/ui/ui.mdf
-dx/ui/Basic2D.cfg
-dx/ui/Basic2D.net
-dx/ui/Basic3D.cfg
-dx/ui/Basic3D.net
-dx/ui/FacesLoopsEdges.cfg
-dx/ui/FacesLoopsEdges.net
-dx/ui/GARMWName
-dx/ui/Gridded_2D_1var_notseries.cfg
-dx/ui/Gridded_2D_1var_notseries.net
-dx/ui/Gridded_2D_2ormorevar_notseries.cfg
-dx/ui/Gridded_2D_2ormorevar_notseries.net
-dx/ui/Gridded_3D_1var_notseries.cfg
-dx/ui/ReadImage.cfg
-dx/ui/Gridded_3D_1var_notseries.net
-dx/ui/Gridded_3D_2ormorevar_notseries.cfg
-dx/ui/Gridded_3D_2ormorevar_notseries.net
-dx/ui/ImportSpreadsheetMatrix.cfg
-dx/ui/ImportSpreadsheetMatrix.net
-dx/ui/ImportSpreadsheetTable.cfg
-dx/ui/ImportSpreadsheetTable.net
-dx/ui/ReadImage.net
-dx/ui/UnGridded_2D_1var_notseries.cfg
-dx/ui/UnGridded_2D_1var_notseries.net
-dx/ui/UnGridded_2D_2ormorevar_notseries.cfg
-dx/ui/UnGridded_2D_2ormorevar_notseries.net
-dx/ui/UnGridded_3D_1var_notseries.cfg
-dx/ui/UnGridded_3D_1var_notseries.net
-dx/ui/UnGridded_3D_2ormorevar_notseries.cfg
-dx/ui/UnGridded_3D_2ormorevar_notseries.net
-dx/ui/date.fmt
-dx/ui/decision.cfg
-dx/ui/decision.net
-dx/ui/editorWindow
-dx/ui/help.txt
-dx/ui/imageWindow
-dx/ui/support.txt
-dx/ui/syntax.txt
-dx/ui/testimp.net
-dx/ui/testssheet.net
-dx/ui/viewer.net
-dx/include/dx/UserInteractors.h
-dx/include/dx/advanced.h
-dx/include/dx/arch.h
-dx/include/dx/array.h
-dx/include/dx/arrayhandles.h
-dx/include/dx/basic.h
-dx/include/dx/cache.h
-dx/include/dx/camera.h
-dx/include/dx/clipped.h
-dx/include/dx/component.h
-dx/include/dx/dx.h
-dx/include/dx/error.h
-dx/include/dx/extract.h
-dx/include/dx/field.h
-dx/include/dx/geometry.h
-dx/include/dx/group.h
-dx/include/dx/grow.h
-dx/include/dx/hash.h
-dx/include/dx/helper.h
-dx/include/dx/image.h
-dx/include/dx/import.h
-dx/include/dx/invalid.h
-dx/include/dx/lexical.h
-dx/include/dx/light.h
-dx/include/dx/memory.h
-dx/include/dx/modflags.h
-dx/include/dx/object.h
-dx/include/dx/partition.h
-dx/include/dx/pending.h
-dx/include/dx/pick.h
-dx/include/dx/private.h
-dx/include/dx/rel_1_bc.h
-dx/include/dx/render.h
-dx/include/dx/resampling.h
-dx/include/dx/screen.h
-dx/include/dx/seglist.h
-dx/include/dx/string.h
-dx/include/dx/task.h
-dx/include/dx/timing.h
-dx/include/dx/version.h
-dx/include/dx/xform.h
-dx/include/dxl.h
-dx/include/dxconfig.h
-dx/include/dxstereo.h
-dx/bin/dxworker
-dx/bin/mdf2c
-dx/bin/dx
-dx/bin/url_handler.sh
+dx/bin_%%ARCH%%/tutor
+dx/doc/README
+dx/doc/README_SMP
+dx/doc/README_alphax
+dx/doc/README_aviion
+dx/doc/README_hp700
+dx/doc/README_ibm6000
+dx/doc/README_ibmpvs
+dx/doc/README_indigo
+dx/doc/README_intelnt
+dx/doc/README_sgi
+dx/doc/README_sgi4
+dx/doc/README_solaris
+dx/doc/README_sun4
+dx/fonts/README
+dx/fonts/area.dx
+dx/fonts/cyril_d.dx
+dx/fonts/fixed.dx
+dx/fonts/gothiceng_t.dx
+dx/fonts/gothicger_t.dx
+dx/fonts/gothicit_t.dx
+dx/fonts/greek_d.dx
+dx/fonts/greek_s.dx
+dx/fonts/italic_d.dx
+dx/fonts/italic_t.dx
+dx/fonts/pitman.dx
+dx/fonts/roman_d.dx
+dx/fonts/roman_dser.dx
+dx/fonts/roman_ext.dx
+dx/fonts/roman_s.dx
+dx/fonts/roman_sfix.dx
+dx/fonts/roman_tser.dx
+dx/fonts/script_d.dx
+dx/fonts/script_s.dx
+dx/fonts/variable.dx
+dx/help/GarHelpDir
dx/help/HelpDir
dx/help/HelpNotAvailable
+dx/help/MBHelpDir
dx/help/dxall1
dx/help/dxall10
dx/help/dxall100
@@ -235,7 +168,6 @@ dx/help/dxall1104
dx/help/dxall1105
dx/help/dxall1106
dx/help/dxall1107
-dx/help/dxall12
dx/help/dxall1108
dx/help/dxall1109
dx/help/dxall111
@@ -337,6 +269,7 @@ dx/help/dxall1196
dx/help/dxall1197
dx/help/dxall1198
dx/help/dxall1199
+dx/help/dxall12
dx/help/dxall120
dx/help/dxall1200
dx/help/dxall1201
@@ -461,7 +394,6 @@ dx/help/dxall1308
dx/help/dxall1309
dx/help/dxall131
dx/help/dxall1310
-dx/help/dxall15
dx/help/dxall1311
dx/help/dxall1312
dx/help/dxall1313
@@ -577,6 +509,7 @@ dx/help/dxall146
dx/help/dxall147
dx/help/dxall148
dx/help/dxall149
+dx/help/dxall15
dx/help/dxall150
dx/help/dxall151
dx/help/dxall152
@@ -612,13 +545,13 @@ dx/help/dxall180
dx/help/dxall181
dx/help/dxall182
dx/help/dxall183
-dx/help/dxall19
dx/help/dxall184
dx/help/dxall185
dx/help/dxall186
dx/help/dxall187
dx/help/dxall188
dx/help/dxall189
+dx/help/dxall19
dx/help/dxall190
dx/help/dxall191
dx/help/dxall192
@@ -1416,14 +1349,169 @@ dx/help/dxall998
dx/help/dxall999
dx/help/hlpalhtl
dx/help/hlpall
-dx/help/spots
dx/help/mbidx
dx/help/quikidx
-dx/help/ugidx
+dx/help/spots
dx/help/svsmstrh
+dx/help/ugidx
dx/help/usrefidx
-dx/help/GarHelpDir
-dx/help/MBHelpDir
+dx/html/Help.idx
+dx/html/README.htm
+dx/html/README_SMP.htm
+dx/html/README_alphax.htm
+dx/html/README_hp700.htm
+dx/html/README_ibm6000.htm
+dx/html/README_intelnt.htm
+dx/html/README_sgi.htm
+dx/html/README_solaris.htm
+dx/html/allguide.htm
+dx/html/images/3dcurs.gif
+dx/html/images/adctlpt.gif
+dx/html/images/arch.gif
+dx/html/images/autoax.gif
+dx/html/images/autoexp.gif
+dx/html/images/brwswin.gif
+dx/html/images/camera.gif
+dx/html/images/cmaped.gif
+dx/html/images/cmputcfg.gif
+dx/html/images/colomap1.gif
+dx/html/images/colormap.gif
+dx/html/images/confgdb.gif
+dx/html/images/ctpanacc.gif
+dx/html/images/ctpangrp.gif
+dx/html/images/ctrlpan.gif
+dx/html/images/dataorg.gif
+dx/html/images/datapr1.gif
+dx/html/images/datdpnd.gif
+dx/html/images/dialint.gif
+dx/html/images/dinhd.gif
+dx/html/images/dxdawn.gif
+dx/html/images/dxicon8.gif
+dx/html/images/example1.gif
+dx/html/images/excutgrp.gif
+dx/html/images/exticon.gif
+dx/html/images/filesel.gif
+dx/html/images/findtool.gif
+dx/html/images/flcgh_01.gif
+dx/html/images/flcgh_02.gif
+dx/html/images/flcgh_02d.gif
+dx/html/images/flcgh_03.gif
+dx/html/images/flcgh_03d.gif
+dx/html/images/flcgh_04.gif
+dx/html/images/flcgh_04d.gif
+dx/html/images/flcgh_05.gif
+dx/html/images/flcgh_05d.gif
+dx/html/images/flcgh_06.gif
+dx/html/images/flcgh_07.gif
+dx/html/images/flcgh_08.gif
+dx/html/images/flcgh_09.gif
+dx/html/images/flcgh_10.gif
+dx/html/images/flcgh_11.gif
+dx/html/images/fldobj.gif
+dx/html/images/flehole.gif
+dx/html/images/flesurf.gif
+dx/html/images/flexmp.gif
+dx/html/images/flseldb.gif
+dx/html/images/flselint.gif
+dx/html/images/foot-fc.gif
+dx/html/images/foot-qs.gif
+dx/html/images/foot-ug.gif
+dx/html/images/foot-ur.gif
+dx/html/images/fragment.gif
+dx/html/images/framctrl.gif
+dx/html/images/fulldp.gif
+dx/html/images/genwave.gif
+dx/html/images/griddb.gif
+dx/html/images/gridtype.gif
+dx/html/images/grparts.gif
+dx/html/images/hand.gif
+dx/html/images/hdrdat.gif
+dx/html/images/hello1.gif
+dx/html/images/hello2.gif
+dx/html/images/helpwin.gif
+dx/html/images/htswork.gif
+dx/html/images/imagwin.gif
+dx/html/images/impconf.gif
+dx/html/images/inputcfg.gif
+dx/html/images/intlabl.gif
+dx/html/images/irggrid.gif
+dx/html/images/javatls.gif
+dx/html/images/macrname.gif
+dx/html/images/majcomp.gif
+dx/html/images/map.gif
+dx/html/images/map2plan.gif
+dx/html/images/mapdform.gif
+dx/html/images/matpa1.gif
+dx/html/images/matpa2.gif
+dx/html/images/matpa3.gif
+dx/html/images/matpa4.gif
+dx/html/images/modbuild.gif
+dx/html/images/navigate.gif
+dx/html/images/opacintg.gif
+dx/html/images/opendb.gif
+dx/html/images/optbox.gif
+dx/html/images/patrx1.gif
+dx/html/images/patrx2.gif
+dx/html/images/patry1.gif
+dx/html/images/patry2.gif
+dx/html/images/prodarxy.gif
+dx/html/images/prodarz.gif
+dx/html/images/prtimg.gif
+dx/html/images/quikovx.gif
+dx/html/images/reggrid.gif
+dx/html/images/rendopts.gif
+dx/html/images/reorient.gif
+dx/html/images/saveas.gif
+dx/html/images/savimg.gif
+dx/html/images/sealevel.gif
+dx/html/images/selattr.gif
+dx/html/images/selctint.gif
+dx/html/images/seqctrl.gif
+dx/html/images/setattr.gif
+dx/html/images/sgroup.gif
+dx/html/images/shcomps.gif
+dx/html/images/simfdp.gif
+dx/html/images/skwdgrid.gif
+dx/html/images/slidint.gif
+dx/html/images/spacer.gif
+dx/html/images/startup.gif
+dx/html/images/stepint.gif
+dx/html/images/strngint.gif
+dx/html/images/strtsrv.gif
+dx/html/images/strtsrvo.gif
+dx/html/images/textint.gif
+dx/html/images/throtdb.gif
+dx/html/images/transfrm.gif
+dx/html/images/txtmesh.gif
+dx/html/images/usefle.gif
+dx/html/images/veclist.gif
+dx/html/images/vertord.gif
+dx/html/images/vrtordu1.gif
+dx/html/images/vrtordu2.gif
+dx/html/images/vuctrl.gif
+dx/html/images/wrpdgrid.gif
+dx/html/images/xgroup.gif
+dx/html/images/xgrpasgn.gif
+dx/html/images/xirega.gif
+dx/html/images/xmesha.gif
+dx/html/images/xmodf1.gif
+dx/html/images/xmodf10.gif
+dx/html/images/xmodf11.gif
+dx/html/images/xmodf12.gif
+dx/html/images/xmodf13.gif
+dx/html/images/xmodf2.gif
+dx/html/images/xmodf3.gif
+dx/html/images/xmodf4.gif
+dx/html/images/xmodf6.gif
+dx/html/images/xmodf7.gif
+dx/html/images/xmodf8.gif
+dx/html/images/xmodf9.gif
+dx/html/images/xmpmacro.gif
+dx/html/images/xproda.gif
+dx/html/index.htm
+dx/html/index.html
+dx/html/insguide.htm
+dx/html/notfound.htm
dx/html/pages/insgu002.htm
dx/html/pages/insgu003.htm
dx/html/pages/insgu004.htm
@@ -2013,6 +2101,7 @@ dx/html/pages/refgu172.htm
dx/html/pages/refgu173.htm
dx/html/pages/refgu174.htm
dx/html/pages/refgu175.htm
+dx/html/pages/refgu176.htm
dx/html/pages/usrgu002.htm
dx/html/pages/usrgu003.htm
dx/html/pages/usrgu004.htm
@@ -2092,208 +2181,122 @@ dx/html/pages/usrgu077.htm
dx/html/pages/usrgu078.htm
dx/html/pages/usrgu079.htm
dx/html/pages/usrgu080.htm
-dx/html/images/3dcurs.gif
-dx/html/images/adctlpt.gif
-dx/html/images/arch.gif
-dx/html/images/autoax.gif
-dx/html/images/autoexp.gif
-dx/html/images/brwswin.gif
-dx/html/images/camera.gif
-dx/html/images/cmaped.gif
-dx/html/images/cmputcfg.gif
-dx/html/images/colomap1.gif
-dx/html/images/colormap.gif
-dx/html/images/confgdb.gif
-dx/html/images/ctpanacc.gif
-dx/html/images/ctpangrp.gif
-dx/html/images/ctrlpan.gif
-dx/html/images/dataorg.gif
-dx/html/images/datapr1.gif
-dx/html/images/datdpnd.gif
-dx/html/images/dialint.gif
-dx/html/images/dinhd.gif
-dx/html/images/dxicon8.gif
-dx/html/images/example1.gif
-dx/html/images/excutgrp.gif
-dx/html/images/exticon.gif
-dx/html/images/filesel.gif
-dx/html/images/findtool.gif
-dx/html/images/fldobj.gif
-dx/html/images/flehole.gif
-dx/html/images/flesurf.gif
-dx/html/images/flexmp.gif
-dx/html/images/flseldb.gif
-dx/html/images/flselint.gif
-dx/html/images/fragment.gif
-dx/html/images/framctrl.gif
-dx/html/images/fulldp.gif
-dx/html/images/genwave.gif
-dx/html/images/griddb.gif
-dx/html/images/gridtype.gif
-dx/html/images/grparts.gif
-dx/html/images/hand.gif
-dx/html/images/hdrdat.gif
-dx/html/images/hello1.gif
-dx/html/images/hello2.gif
-dx/html/images/helpwin.gif
-dx/html/images/htswork.gif
-dx/html/images/imagwin.gif
-dx/html/images/impconf.gif
-dx/html/images/inputcfg.gif
-dx/html/images/intlabl.gif
-dx/html/images/irggrid.gif
-dx/html/images/javatls.gif
-dx/html/images/macrname.gif
-dx/html/images/majcomp.gif
-dx/html/images/map.gif
-dx/html/images/map2plan.gif
-dx/html/images/mapdform.gif
-dx/html/images/matpa1.gif
-dx/html/images/matpa2.gif
-dx/html/images/modbuild.gif
-dx/html/images/navigate.gif
-dx/html/images/opendb.gif
-dx/html/images/optbox.gif
-dx/html/images/patrx1.gif
-dx/html/images/patrx2.gif
-dx/html/images/patry1.gif
-dx/html/images/patry2.gif
-dx/html/images/prodarxy.gif
-dx/html/images/prodarz.gif
-dx/html/images/prtimg.gif
-dx/html/images/quikovx.gif
-dx/html/images/reggrid.gif
-dx/html/images/rendopts.gif
-dx/html/images/reorient.gif
-dx/html/images/saveas.gif
-dx/html/images/savimg.gif
-dx/html/images/sealevel.gif
-dx/html/images/selattr.gif
-dx/html/images/selctint.gif
-dx/html/images/seqctrl.gif
-dx/html/images/setattr.gif
-dx/html/images/sgroup.gif
-dx/html/images/shcomps.gif
-dx/html/images/simfdp.gif
-dx/html/images/skwdgrid.gif
-dx/html/images/slidint.gif
-dx/html/images/startup.gif
-dx/html/images/stepint.gif
-dx/html/images/strngint.gif
-dx/html/images/strtsrv.gif
-dx/html/images/strtsrvo.gif
-dx/html/images/textint.gif
-dx/html/images/throtdb.gif
-dx/html/images/transfrm.gif
-dx/html/images/txtmesh.gif
-dx/html/images/usefle.gif
-dx/html/images/veclist.gif
-dx/html/images/vertord.gif
-dx/html/images/vrtordu1.gif
-dx/html/images/vrtordu2.gif
-dx/html/images/vuctrl.gif
-dx/html/images/wrpdgrid.gif
-dx/html/images/xgroup.gif
-dx/html/images/xgrpasgn.gif
-dx/html/images/xirega.gif
-dx/html/images/xmesha.gif
-dx/html/images/xmodf1.gif
-dx/html/images/xmodf10.gif
-dx/html/images/xmodf11.gif
-dx/html/images/xmodf12.gif
-dx/html/images/xmodf13.gif
-dx/html/images/xmodf2.gif
-dx/html/images/xmodf3.gif
-dx/html/images/xmodf4.gif
-dx/html/images/xmodf6.gif
-dx/html/images/xmodf7.gif
-dx/html/images/xmodf8.gif
-dx/html/images/xmodf9.gif
-dx/html/images/xmpmacro.gif
-dx/html/images/xproda.gif
-dx/html/images/foot-fc.gif
-dx/html/images/foot-ug.gif
-dx/html/images/foot-qs.gif
-dx/html/images/foot-ur.gif
-dx/html/images/flcgh_07.gif
-dx/html/images/flcgh_05.gif
-dx/html/images/dxdawn.gif
-dx/html/images/flcgh_09.gif
-dx/html/images/spacer.gif
-dx/html/images/flcgh_03d.gif
-dx/html/images/flcgh_03.gif
-dx/html/images/flcgh_02d.gif
-dx/html/images/flcgh_02.gif
-dx/html/images/flcgh_04d.gif
-dx/html/images/flcgh_10.gif
-dx/html/images/flcgh_04.gif
-dx/html/images/flcgh_01.gif
-dx/html/images/flcgh_08.gif
-dx/html/images/flcgh_06.gif
-dx/html/images/flcgh_11.gif
-dx/html/images/flcgh_05d.gif
-dx/html/images/matpa3.gif
-dx/html/images/matpa4.gif
-dx/html/images/opacintg.gif
-dx/html/README.htm
-dx/html/README_SMP.htm
-dx/html/README_alphax.htm
-dx/html/README_hp700.htm
-dx/html/README_ibm6000.htm
-dx/html/README_intelnt.htm
-dx/html/README_sgi.htm
-dx/html/README_solaris.htm
-dx/html/allguide.htm
-dx/html/insguide.htm
dx/html/proguide.htm
dx/html/qikguide.htm
dx/html/refguide.htm
-dx/html/usrguide.htm
dx/html/search.js
dx/html/srchhelp.htm
dx/html/srchidx.js
dx/html/srchindx.htm
dx/html/srchnav.htm
-dx/html/Help.idx
-dx/html/notfound.htm
-dx/html/index.htm
-dx/html/index.html
-dx/man/manl/dx.l
+dx/html/usrguide.htm
+dx/include/dx/UserInteractors.h
+dx/include/dx/advanced.h
+dx/include/dx/arch.h
+dx/include/dx/array.h
+dx/include/dx/arrayhandles.h
+dx/include/dx/basic.h
+dx/include/dx/cache.h
+dx/include/dx/camera.h
+dx/include/dx/clipped.h
+dx/include/dx/component.h
+dx/include/dx/dx.h
+dx/include/dx/error.h
+dx/include/dx/extract.h
+dx/include/dx/field.h
+dx/include/dx/geometry.h
+dx/include/dx/group.h
+dx/include/dx/grow.h
+dx/include/dx/hash.h
+dx/include/dx/helper.h
+dx/include/dx/image.h
+dx/include/dx/import.h
+dx/include/dx/invalid.h
+dx/include/dx/lexical.h
+dx/include/dx/light.h
+dx/include/dx/memory.h
+dx/include/dx/modflags.h
+dx/include/dx/object.h
+dx/include/dx/partition.h
+dx/include/dx/pending.h
+dx/include/dx/pick.h
+dx/include/dx/private.h
+dx/include/dx/rel_1_bc.h
+dx/include/dx/render.h
+dx/include/dx/resampling.h
+dx/include/dx/screen.h
+dx/include/dx/seglist.h
+dx/include/dx/string.h
+dx/include/dx/task.h
+dx/include/dx/timing.h
+dx/include/dx/version.h
+dx/include/dx/xform.h
+dx/include/dxconfig.h
+dx/include/dxl.h
+dx/include/dxstereo.h
+dx/lib/colors.txt
+dx/lib/dx.mdf
+dx/lib/dxexec.def
+dx/lib/dxexec.exp
+dx/lib/dxexec.ifs
+dx/lib/dxexec.imp
+dx/lib/dxfSaveCurrentImage.net
+dx/lib/dxrc
+dx/lib/mdf2c.awk
+dx/lib/messages
+dx/lib/outboard.c
+dx/lib_%%ARCH%%/arch.mak
+dx/lib_%%ARCH%%/libDX.a
+dx/lib_%%ARCH%%/libDXL.a
+dx/lib_%%ARCH%%/libDXcallm.a
+dx/lib_%%ARCH%%/libDXlite.a
dx/man/catl/dx.l
-dx/fonts/Readme
-dx/fonts/area.dx
-dx/fonts/cyril_d.dx
-dx/fonts/fixed.dx
-dx/fonts/gothiceng_t.dx
-dx/fonts/gothicger_t.dx
-dx/fonts/gothicit_t.dx
-dx/fonts/greek_d.dx
-dx/fonts/greek_s.dx
-dx/fonts/italic_d.dx
-dx/fonts/italic_t.dx
-dx/fonts/pitman.dx
-dx/fonts/roman_d.dx
-dx/fonts/roman_dser.dx
-dx/fonts/roman_ext.dx
-dx/fonts/roman_s.dx
-dx/fonts/roman_sfix.dx
-dx/fonts/roman_tser.dx
-dx/fonts/script_d.dx
-dx/fonts/script_s.dx
-dx/fonts/variable.dx
-dx/doc/README
-dx/doc/README_SMP
-dx/doc/README_alphax
-dx/doc/README_aviion
-dx/doc/README_hp700
-dx/doc/README_ibm6000
-dx/doc/README_ibmpvs
-dx/doc/README_indigo
-dx/doc/README_intelnt
-dx/doc/README_sgi
-dx/doc/README_sgi4
-dx/doc/README_solaris
-dx/doc/README_sun4
+dx/man/manl/dx.l
+dx/ui/Basic2D.cfg
+dx/ui/Basic2D.net
+dx/ui/Basic3D.cfg
+dx/ui/Basic3D.net
+dx/ui/FacesLoopsEdges.cfg
+dx/ui/FacesLoopsEdges.net
+dx/ui/GARMWName
+dx/ui/Gridded_2D_1var_notseries.cfg
+dx/ui/Gridded_2D_1var_notseries.net
+dx/ui/Gridded_2D_2ormorevar_notseries.cfg
+dx/ui/Gridded_2D_2ormorevar_notseries.net
+dx/ui/Gridded_3D_1var_notseries.cfg
+dx/ui/Gridded_3D_1var_notseries.net
+dx/ui/Gridded_3D_2ormorevar_notseries.cfg
+dx/ui/Gridded_3D_2ormorevar_notseries.net
+dx/ui/ImportSpreadsheetMatrix.cfg
+dx/ui/ImportSpreadsheetMatrix.net
+dx/ui/ImportSpreadsheetTable.cfg
+dx/ui/ImportSpreadsheetTable.net
+dx/ui/ReadImage.cfg
+dx/ui/ReadImage.net
+dx/ui/UnGridded_2D_1var_notseries.cfg
+dx/ui/UnGridded_2D_1var_notseries.net
+dx/ui/UnGridded_2D_2ormorevar_notseries.cfg
+dx/ui/UnGridded_2D_2ormorevar_notseries.net
+dx/ui/UnGridded_3D_1var_notseries.cfg
+dx/ui/UnGridded_3D_1var_notseries.net
+dx/ui/UnGridded_3D_2ormorevar_notseries.cfg
+dx/ui/UnGridded_3D_2ormorevar_notseries.net
+dx/ui/date.fmt
+dx/ui/decision.cfg
+dx/ui/decision.net
+dx/ui/editorWindow
+dx/ui/help.txt
+dx/ui/icon50.dat
+dx/ui/icon50.xpm
+dx/ui/imageWindow
+dx/ui/logo.dat
+dx/ui/logo.xpm
+dx/ui/support.txt
+dx/ui/syntax.txt
+dx/ui/testimp.net
+dx/ui/testssheet.net
+dx/ui/ui.mdf
+dx/ui/viewer.net
@dirrm dx/ui
@dirrm dx/man/manl
@dirrm dx/man/catl
@@ -2310,3 +2313,4 @@ dx/doc/README_sun4
@dirrm dx/doc
@dirrm dx/bin_%%ARCH%%
@dirrm dx/bin
+@dirrm dx