aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendx
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2001-03-20 12:10:10 +0000
committerThomas Gellekum <tg@FreeBSD.org>2001-03-20 12:10:10 +0000
commit1bb4cd9c380abf182a11afba45fd737dba1a7009 (patch)
tree93bb4f5b542dc6355c799d33963718d5febf5fee /graphics/opendx
parent0705706341cac86a725fd6d09339bc5dfa30e200 (diff)
downloadports-1bb4cd9c380abf182a11afba45fd737dba1a7009.tar.gz
ports-1bb4cd9c380abf182a11afba45fd737dba1a7009.zip
Notes
Diffstat (limited to 'graphics/opendx')
-rw-r--r--graphics/opendx/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index bd7acdb70c2c..e2bbf5117fbf 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -7,19 +7,23 @@
PORTNAME= opendx
PORTVERSION= 4.1.0
+PORTREVISION= 1
CATEGORIES= graphics math
MASTER_SITES= http://opendx.npaci.edu/source/
DISTNAME= dx-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= df.1:${PORTSDIR}/graphics/hdf \
+ jbig.1:${PORTSDIR}/graphics/jbigkit \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
netcdf.1:${PORTSDIR}/math/netcdf \
png.4:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
ttf.4:${PORTSDIR}/print/freetype
USE_AUTOMAKE= yes
+USE_GMAKE= yes
USE_MESA= yes
USE_MOTIF= yes
USE_NEWGCC= yes
@@ -33,9 +37,12 @@ CONFIGURE_ENV= ARCH="" \
NO_MTREE= yes
PLIST_SUB= ARCH=${OPSYS:L}
+# XXX the -lcompat below is an ugly kludge. opendx's code
+# should be fixed to use the modern POSIX style regcomp(3)
+# instead of the old V8 style one.
post-patch:
@find ${WRKSRC} -name Makefile.am | \
- xargs ${PERL} -pi -e "s;-lXm ;${MOTIFLIB} ;g"
+ xargs ${PERL} -pi -e "s;-lXm ;-lcompat ${MOTIFLIB} ;g"
pre-configure:
@cd ${WRKSRC} && aclocal