aboutsummaryrefslogtreecommitdiff
path: root/graphics/opendx
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
commit4e1b79a0a61f4973df8b4b0864d22086c769e219 (patch)
tree78ceaf1b099c56a40c240ab46278cdf4ae9e7c01 /graphics/opendx
parent7f4572eae4327c4403d9ef714cb6de917650662a (diff)
Notes
Diffstat (limited to 'graphics/opendx')
-rw-r--r--graphics/opendx/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index fa10327c09df..caa84313ec09 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -11,9 +11,9 @@ DISTNAME= dx-${PORTVERSION}
MAINTAINER= stephen@FreeBSD.org
COMMENT= IBM's Open Visualization Data Explorer
-LIB_DEPENDS= libMagickWand-6.so:${PORTSDIR}/graphics/ImageMagick \
- libtiff.so:${PORTSDIR}/graphics/tiff \
- libcdf.so:${PORTSDIR}/science/cdf
+LIB_DEPENDS= libMagickWand-6.so:graphics/ImageMagick \
+ libtiff.so:graphics/tiff \
+ libcdf.so:science/cdf
USE_XORG= xinerama xext xpm xmu sm ice
USES= bison motif gmake libtool
@@ -34,13 +34,13 @@ IGNORE= HDF and NETCDF are conflicting
.endif
.if defined(WITH_HDF)
-LIB_DEPENDS+= libmfhdf.so:${PORTSDIR}/science/hdf
+LIB_DEPENDS+= libmfhdf.so:science/hdf
.else
CONFIGURE_ARGS+= --without-hdf
.endif
.if !defined(WITHOUT_NETCDF)
-LIB_DEPENDS+= libnetcdf.so:${PORTSDIR}/science/netcdf
+LIB_DEPENDS+= libnetcdf.so:science/netcdf
.else
CONFIGURE_ARGS+= --without-netcdf
.endif
@@ -48,8 +48,8 @@ CONFIGURE_ARGS+= --without-netcdf
.if defined(WITH_JAVA)
USE_JAVA= yes
JAVA_VERSION= 1.6+
-BUILD_DEPENDS+= ${JAVALIBDIR}/npcosmop211.jar:${PORTSDIR}/graphics/cosmoplayer
-RUN_DEPENDS+= ${JAVALIBDIR}/npcosmop211.jar:${PORTSDIR}/graphics/cosmoplayer
+BUILD_DEPENDS+= ${JAVALIBDIR}/npcosmop211.jar:graphics/cosmoplayer
+RUN_DEPENDS+= ${JAVALIBDIR}/npcosmop211.jar:graphics/cosmoplayer
CONFIGURE_ARGS+= --with-cosmojar-path=${JAVALIBDIR}/npcosmop211.jar \
--with-java40jar-path=${JAVALIBDIR}/java40.jar \
--with-jni-path=${JAVA_HOME}/include:${JAVA_HOME}/include/freebsd