aboutsummaryrefslogtreecommitdiff
path: root/graphics/openexr
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-03-25 16:27:17 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-03-25 16:27:17 +0000
commit828389ed97cf726eb316adcdcc9d7449a33c0292 (patch)
tree2918ac2700c05115fbf2ca13769210be5acc5a56 /graphics/openexr
parent4ccb16c8aeb0570229e203c1cb9b3ab8b1184891 (diff)
downloadports-828389ed97cf726eb316adcdcc9d7449a33c0292.tar.gz
ports-828389ed97cf726eb316adcdcc9d7449a33c0292.zip
Notes
Diffstat (limited to 'graphics/openexr')
-rw-r--r--graphics/openexr/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/graphics/openexr/Makefile b/graphics/openexr/Makefile
index ed8f6102bbec..e78c789ab403 100644
--- a/graphics/openexr/Makefile
+++ b/graphics/openexr/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openexr
PORTVERSION= 2.4.1
+PORTREVISION= 1
CATEGORIES= graphics devel
MASTER_SITES= LOCAL/mandree/:test
DISTFILES= ${PORTNAME}-2.2.0-comp_dwa-test-images.tar.xz:test
@@ -28,22 +29,19 @@ LDFLAGS+= -lpthread
PORTDOCS= *
PORTEXAMPLES= *
-DOCSRCDIR1= ${WRKSRC}/..
+DOCSRCDIR1= ${WRKSRC:H}/
DOC_FILES1= CHANGES.md CONTRIBUTING.md GOVERNANCE.md LICENSE.md SECURITY.md \
CODE_OF_CONDUCT.md CONTRIBUTORS.md README.md
DOCSRCDIR2= ${WRKSRC}/doc
DOC_FILES2= *.odt *.pdf
-OPTIONS_DEFINE= DOCS EXAMPLES LARGE_STACK
-LARGE_STACK_DESC= Enable sys-dependent large stack optimizations
+OPTIONS_DEFINE= DOCS EXAMPLES
WRKSRC_SUBDIR= OpenEXR
OPTIONS_SUB= yes
-LARGE_STACK_CONFIGURE_ENABLE= large-stack
-
.include <bsd.port.pre.mk>
.if ${ARCH} == powerpc
@@ -79,14 +77,16 @@ post-install-EXAMPLES-on:
post-install-EXAMPLES-off:
${RM} -R ${STAGEDIR}${PREFIX}/share/doc/OpenEXR/examples/
+ @${RMDIR} ${STAGEDIR}${PREFIX}/share/doc/OpenEXR 2>/dev/null || :
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR}
- ${MV} ${STAGEDIR}${DOCSDIR}/../OpenEXR/[a-df-zA-Z]* ${STAGEDIR}${DOCSDIR}
+ ${MV} ${STAGEDIR}${DOCSDIR:H}/OpenEXR/[a-df-zA-Z]* ${STAGEDIR}${DOCSDIR}
post-install-DOCS-off:
+ ${RM} ${STAGEDIR}${DOCSDIR:H}/OpenEXR/*.pdf
@${RMDIR} ${STAGEDIR}${PREFIX}/share/doc/${PORTNAME} 2>/dev/null || :
regression-test check test: