aboutsummaryrefslogtreecommitdiff
path: root/graphics/openexr
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-05-18 17:04:00 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-05-18 17:15:52 +0000
commit9a948c5d3e5de7d486abbf36c63c73a24ac35dac (patch)
treedc707e535b37cd1eb253853979d7d16bbece7c93 /graphics/openexr
parent5ff95b962e88c8cdfd37855f9fc9d20229227d45 (diff)
downloadports-9a948c5d3e5de7d486abbf36c63c73a24ac35dac.tar.gz
ports-9a948c5d3e5de7d486abbf36c63c73a24ac35dac.zip
Diffstat (limited to 'graphics/openexr')
-rw-r--r--graphics/openexr/Makefile7
-rw-r--r--graphics/openexr/distinfo6
-rw-r--r--graphics/openexr/files/patch-549a0835deb46
-rw-r--r--graphics/openexr/files/patch-61d209bfd8d35
-rw-r--r--graphics/openexr/files/patch-f60b55b1b17
-rw-r--r--graphics/openexr/pkg-plist16
6 files changed, 31 insertions, 96 deletions
diff --git a/graphics/openexr/Makefile b/graphics/openexr/Makefile
index 0114528d230d..4e277e13c208 100644
--- a/graphics/openexr/Makefile
+++ b/graphics/openexr/Makefile
@@ -1,8 +1,7 @@
# Created by: nork@FreeBSD.org
PORTNAME= openexr
-PORTVERSION= 3.0.1
-PORTREVISION= 1
+PORTVERSION= 3.0.2
CATEGORIES= graphics devel
MASTER_SITES= LOCAL/mandree/:test
DISTFILES= ${PORTNAME}-2.2.0-comp_dwa-test-images.tar.xz:test
@@ -13,7 +12,7 @@ COMMENT= High dynamic-range (HDR) image file format
LICENSE= BSD3CLAUSE
# exact version required to avoid hard-to-debug issues
-LIB_DEPENDS= libImath-3_0.so.27:math/Imath
+LIB_DEPENDS= libImath-3_0.so.28:math/Imath
USES= cmake compiler:c++14-lang pathfix pkgconfig
@@ -29,7 +28,7 @@ LDFLAGS+= -lpthread
PATCH_STRIP= -p1
_MAJORVER= 3_0
-_VER= 27
+_VER= 28
_MINVER= 0
_PLVER= 0
diff --git a/graphics/openexr/distinfo b/graphics/openexr/distinfo
index f680826815ae..cfc0d2520714 100644
--- a/graphics/openexr/distinfo
+++ b/graphics/openexr/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1618048202
+TIMESTAMP = 1621335023
SHA256 (openexr-2.2.0-comp_dwa-test-images.tar.xz) = bbb8ff547e9b68f0dfb1e8804a7ad984978c2b15897988399cc68176e99dd63a
SIZE (openexr-2.2.0-comp_dwa-test-images.tar.xz) = 653768
-SHA256 (AcademySoftwareFoundation-openexr-3.0.1-v3.0.1_GH0.tar.gz) = 6d14a8df938bbbd55dd6e55b24c527fe9323fe6a45f704e56967dfbf477cecc1
-SIZE (AcademySoftwareFoundation-openexr-3.0.1-v3.0.1_GH0.tar.gz) = 25059445
+SHA256 (AcademySoftwareFoundation-openexr-3.0.2-v3.0.2_GH0.tar.gz) = afcfaaba700d0bc86a54e9c2e51b22b9dd458527571046f02951ef75ddc7c8e2
+SIZE (AcademySoftwareFoundation-openexr-3.0.2-v3.0.2_GH0.tar.gz) = 25060066
diff --git a/graphics/openexr/files/patch-549a0835deb b/graphics/openexr/files/patch-549a0835deb
deleted file mode 100644
index bc34fdaf3bfe..000000000000
--- a/graphics/openexr/files/patch-549a0835deb
+++ /dev/null
@@ -1,46 +0,0 @@
-From 549a0835deb257f5caf5e54880c2be968e690b83 Mon Sep 17 00:00:00 2001
-From: Larry Gritz <lg@larrygritz.com>
-Date: Thu, 8 Apr 2021 15:33:40 -0700
-Subject: [PATCH] Don't impose C++14 on downstream projects (#995)
-
-We were setting
-
- target_compile_features(${objlib} PUBLIC cxx_std_${OPENEXR_CXX_STANDARD})
-
-The `PUBLIC` forced downstream projects that consume the
-`OpenEXRConfig*.cmake` exports to use C++ standard at least as recent
-as what OpenEXR used to build (which defaults to 14).
-
-But this is unnecessary. There's nothing in OpenEXR's headers that
-requires anything beyond C++11. So this patch uses a more fine-grained
-setting of target properties to express this more correctly. Now it will
-be fine for a C++11 project to consume OpenEXR (via its exported configs)
-even if that OpenEXR happened to be built with C++14.
-
-Signed-off-by: Larry Gritz <lg@larrygritz.com>
----
- cmake/LibraryDefine.cmake | 11 ++++++++++-
- 1 file changed, 10 insertions(+), 1 deletion(-)
-
-diff --git a/cmake/LibraryDefine.cmake b/cmake/LibraryDefine.cmake
-index 640974291..7ed74da9d 100644
---- a/cmake/LibraryDefine.cmake
-+++ b/cmake/LibraryDefine.cmake
-@@ -17,7 +17,16 @@ function(OPENEXR_DEFINE_LIBRARY libname)
- ${OPENEXR_CURLIB_HEADERS}
- ${OPENEXR_CURLIB_SOURCES})
-
-- target_compile_features(${objlib} PUBLIC cxx_std_${OPENEXR_CXX_STANDARD})
-+ # Use ${OPENEXR_CXX_STANDARD} to determine the standard we use to compile
-+ # OpenEXR itself. But the headers only require C++11 features, so that's
-+ # all we need to pass on as interface reqirements to downstream projects.
-+ # For example, it's fine for an OpenEXR built with C++14 to be called from
-+ # an app that is compiled with C++11; OpenEXR needn't force the app to
-+ # also use C++14.
-+ target_compile_features(${objlib}
-+ PRIVATE cxx_std_${OPENEXR_CXX_STANDARD}
-+ INTERFACE cxx_std_11 )
-+
- if(OPENEXR_CURLIB_PRIV_EXPORT AND BUILD_SHARED_LIBS)
- target_compile_definitions(${objlib} PRIVATE ${OPENEXR_CURLIB_PRIV_EXPORT})
- if(WIN32)
diff --git a/graphics/openexr/files/patch-61d209bfd8d b/graphics/openexr/files/patch-61d209bfd8d
deleted file mode 100644
index 6800a1ce3c56..000000000000
--- a/graphics/openexr/files/patch-61d209bfd8d
+++ /dev/null
@@ -1,35 +0,0 @@
-From 61d209bfd8daefc758735cd20ccff977f98b49a0 Mon Sep 17 00:00:00 2001
-From: peterhillman <peterh@wetafx.co.nz>
-Date: Sat, 8 May 2021 12:02:38 +1200
-Subject: [PATCH] Prevent overflow in getScanlineChunkOffsetTableSize (#1003)
-
-Signed-off-by: Peter Hillman <peterh@wetafx.co.nz>
----
- src/lib/OpenEXR/ImfMisc.cpp | 11 ++++++++---
- 1 file changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/src/lib/OpenEXR/ImfMisc.cpp b/src/lib/OpenEXR/ImfMisc.cpp
-index a65e2a3f4..80c8ce8d2 100644
---- a/src/lib/OpenEXR/ImfMisc.cpp
-+++ b/src/lib/OpenEXR/ImfMisc.cpp
-@@ -1828,12 +1828,17 @@ getScanlineChunkOffsetTableSize(const Header& header)
- {
- const Box2i &dataWindow = header.dataWindow();
-
-- int linesInBuffer = numLinesInBuffer ( header.compression() );
-
-- int lineOffsetSize = (dataWindow.max.y - dataWindow.min.y +
-+ //
-+ // use int64_t types to prevent overflow in lineOffsetSize for images with
-+ // extremely high dataWindows
-+ //
-+ int64_t linesInBuffer = numLinesInBuffer ( header.compression() );
-+
-+ int64_t lineOffsetSize = (static_cast <int64_t>(dataWindow.max.y) - static_cast <int64_t>(dataWindow.min.y) +
- linesInBuffer) / linesInBuffer;
-
-- return lineOffsetSize;
-+ return static_cast <int>(lineOffsetSize);
- }
-
- //
diff --git a/graphics/openexr/files/patch-f60b55b1b b/graphics/openexr/files/patch-f60b55b1b
new file mode 100644
index 000000000000..cdb937bf0e23
--- /dev/null
+++ b/graphics/openexr/files/patch-f60b55b1b
@@ -0,0 +1,17 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index c68ed6414..980f0f1d0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -40,6 +40,12 @@ set(OPENEXR_VERSION_API "${OPENEXR_VERSION_MAJOR}_${OPENEXR_VERSION_MINOR}")
+
+ message(STATUS "Configure OpenEXR Version: ${OPENEXR_VERSION} Lib API: ${OPENEXR_LIB_VERSION}")
+
++option(OPENEXR_INSTALL "Install OpenEXR libraries" ON)
++option(OPENEXR_INSTALL_TOOLS "Install OpenEXR tools" ON)
++if(OPENEXR_INSTALL_TOOLS AND NOT OPENEXR_INSTALL)
++ message(SEND_ERROR "OPENEXR_INSTALL_TOOLS requires OPENEXR_INSTALL")
++endif()
++
+ include(cmake/LibraryDefine.cmake)
+ include(cmake/OpenEXRSetup.cmake)
+ add_subdirectory(cmake)
diff --git a/graphics/openexr/pkg-plist b/graphics/openexr/pkg-plist
index 7516d6153c02..a2e3bce5e689 100644
--- a/graphics/openexr/pkg-plist
+++ b/graphics/openexr/pkg-plist
@@ -137,19 +137,19 @@ lib/cmake/OpenEXR/OpenEXRConfigVersion.cmake
lib/cmake/OpenEXR/OpenEXRTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/OpenEXR/OpenEXRTargets.cmake
lib/libIex-%%MAJORVER%%.so
-lib/libIex-%%MAJORVER%%.so.27
-lib/libIex-%%MAJORVER%%.so.27.0.0
+lib/libIex-%%MAJORVER%%.so.%%VER%%
+lib/libIex-%%MAJORVER%%.so.%%VER%%.0.0
lib/libIex.so
lib/libIlmThread-%%MAJORVER%%.so
-lib/libIlmThread-%%MAJORVER%%.so.27
-lib/libIlmThread-%%MAJORVER%%.so.27.0.0
+lib/libIlmThread-%%MAJORVER%%.so.%%VER%%
+lib/libIlmThread-%%MAJORVER%%.so.%%VER%%.0.0
lib/libIlmThread.so
lib/libOpenEXR-%%MAJORVER%%.so
-lib/libOpenEXR-%%MAJORVER%%.so.27
-lib/libOpenEXR-%%MAJORVER%%.so.27.0.0
+lib/libOpenEXR-%%MAJORVER%%.so.%%VER%%
+lib/libOpenEXR-%%MAJORVER%%.so.%%VER%%.0.0
lib/libOpenEXR.so
lib/libOpenEXRUtil-%%MAJORVER%%.so
-lib/libOpenEXRUtil-%%MAJORVER%%.so.27
-lib/libOpenEXRUtil-%%MAJORVER%%.so.27.0.0
+lib/libOpenEXRUtil-%%MAJORVER%%.so.%%VER%%
+lib/libOpenEXRUtil-%%MAJORVER%%.so.%%VER%%.0.0
lib/libOpenEXRUtil.so
libdata/pkgconfig/OpenEXR.pc