aboutsummaryrefslogtreecommitdiff
path: root/graphics/openexr_ctl
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2007-10-08 16:37:46 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2007-10-08 16:37:46 +0000
commit4914453bd26a3e09f5c0e94a7794eefc65bb4662 (patch)
treea261c0d34003a75af329d0be7b8a7cee45663ff1 /graphics/openexr_ctl
parent8a135bfc6b3a42563500100fdd94ea14c4990ac2 (diff)
downloadports-4914453bd26a3e09f5c0e94a7794eefc65bb4662.tar.gz
ports-4914453bd26a3e09f5c0e94a7794eefc65bb4662.zip
Notes
Diffstat (limited to 'graphics/openexr_ctl')
-rw-r--r--graphics/openexr_ctl/Makefile32
-rw-r--r--graphics/openexr_ctl/distinfo3
-rw-r--r--graphics/openexr_ctl/files/patch-Makefile.in11
-rw-r--r--graphics/openexr_ctl/pkg-descr19
-rw-r--r--graphics/openexr_ctl/pkg-plist15
5 files changed, 80 insertions, 0 deletions
diff --git a/graphics/openexr_ctl/Makefile b/graphics/openexr_ctl/Makefile
new file mode 100644
index 000000000000..2da9b25f98aa
--- /dev/null
+++ b/graphics/openexr_ctl/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: openexr_ctl
+# Date created: 2007-10-09
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= openexr_ctl
+PORTVERSION= 1.0.0
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= openexr
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= Simplified OpenEXR interface to CTL
+
+LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
+ IlmCtl.2:${PORTSDIR}/graphics/ampasCTL
+
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+
+test check: build
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
+
+.if defined(PACKAGE_BUILDING)
+pre-install: test
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/openexr_ctl/distinfo b/graphics/openexr_ctl/distinfo
new file mode 100644
index 000000000000..91bca673b389
--- /dev/null
+++ b/graphics/openexr_ctl/distinfo
@@ -0,0 +1,3 @@
+MD5 (openexr_ctl-1.0.0.tar.gz) = 48b0f2d247117a46962a0983da511759
+SHA256 (openexr_ctl-1.0.0.tar.gz) = bfa28d626201f6b29e794b9ab54a01ec4b1153ec99160b492adabf0ae082f304
+SIZE (openexr_ctl-1.0.0.tar.gz) = 367164
diff --git a/graphics/openexr_ctl/files/patch-Makefile.in b/graphics/openexr_ctl/files/patch-Makefile.in
new file mode 100644
index 000000000000..0b18506979a6
--- /dev/null
+++ b/graphics/openexr_ctl/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2007-08-04 09:13:15.000000000 +0900
++++ Makefile.in 2007-10-09 01:15:31.000000000 +0900
+@@ -209,7 +209,7 @@
+ AUTHORS COPYING ChangeLog INSTALL LICENSE NEWS \
+ README README.CVS README.OSX README.win32 bootstrap
+
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = OpenEXR_CTL.pc
+ all: all-recursive
+
diff --git a/graphics/openexr_ctl/pkg-descr b/graphics/openexr_ctl/pkg-descr
new file mode 100644
index 000000000000..4ff94c33905b
--- /dev/null
+++ b/graphics/openexr_ctl/pkg-descr
@@ -0,0 +1,19 @@
+* IlmImfCtl provides a simplified OpenEXR interface to CTL.
+
+* exrdpx is an initial version of a CTL-driven file converter
+ that translates DPX files into OpenEXR files and vice versa.
+ The conversion between the DPX and OpenEXR color spaces is
+ handled by CTL transforms.
+
+* exr_ctl_exr is an initial version of a program that can bake
+ the effect of a series of CTL transforms into the pixels of
+ an OpenEXR file.
+
+WARNING: the exrdpx file converter and the exr_ctl_exr program are
+still under development. They are good enough for experimentation,
+but they are not ready for production use. The programs are slow,
+and the DPX file I/O capabilities of exrdpx are minimal; most DPX
+header fields and most OpenEXR attributes are lost during file
+conversion.
+
+WWW: http://www.openexr.com/
diff --git a/graphics/openexr_ctl/pkg-plist b/graphics/openexr_ctl/pkg-plist
new file mode 100644
index 000000000000..58cb65a77bde
--- /dev/null
+++ b/graphics/openexr_ctl/pkg-plist
@@ -0,0 +1,15 @@
+bin/exr_ctl_exr
+bin/exrdpx
+lib/libIlmImfCtl.a
+lib/libIlmImfCtl.la
+lib/libIlmImfCtl.so
+lib/libIlmImfCtl.so.2
+lib/CTL/change_saturation.ctl
+lib/CTL/transform_DPX_EXR.ctl
+lib/CTL/transform_EXR_DPX.ctl
+lib/CTL/transform_RRT.ctl
+lib/CTL/transform_display_video.ctl
+lib/CTL/utilities.ctl
+libdata/pkgconfig/OpenEXR_CTL.pc
+include/OpenEXR/ImfCtlApplyTransforms.h
+@dirrm lib/CTL