aboutsummaryrefslogtreecommitdiff
path: root/graphics/openfx-misc/Makefile
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2018-05-01 23:51:34 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2018-05-01 23:51:34 +0000
commite03ec2f3ffb6e152a5b5307ff82e93595bd8c9fc (patch)
tree33d439db630ac1a846adb1769cdb39b46c126145 /graphics/openfx-misc/Makefile
parenta0214cc07a781ff4df8ff5f55c54c343985447a8 (diff)
downloadports-e03ec2f3ffb6e152a5b5307ff82e93595bd8c9fc.tar.gz
ports-e03ec2f3ffb6e152a5b5307ff82e93595bd8c9fc.zip
Notes
Diffstat (limited to 'graphics/openfx-misc/Makefile')
-rw-r--r--graphics/openfx-misc/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/graphics/openfx-misc/Makefile b/graphics/openfx-misc/Makefile
new file mode 100644
index 000000000000..3b74a0fbd79f
--- /dev/null
+++ b/graphics/openfx-misc/Makefile
@@ -0,0 +1,42 @@
+# $FreeBSD$
+
+PORTNAME= openfx-misc
+PORTVERSION= 2.3.10
+CATEGORIES= graphics
+
+MAINTAINER= olivier@FreeBSD.org
+COMMENT= Miscellaneous OpenFX Effects plugins
+
+LICENSE= GPLv2
+
+ONLY_FOR_ARCHS= amd64
+
+USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= devernay
+GH_PROJECT= openfx-misc
+GH_TAGNAME= 3ab0531
+GH_TUPLE= devernay:openfx-supportext:2c43fc8:openfx_supportext/SupportExt \
+ devernay:openfx:e98216f:openfx/openfx
+
+MAKE_ENV+= CONFIG=release
+USE_GL= gl
+
+pre-patch:
+ @${RM} ${WRKSRC}/CImg/CImg.h.orig
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/OFX/Plugins|${PREFIX}/OFX/Plugins|g' \
+ ${WRKSRC}/openfx/Examples/Makefile.master \
+ ${WRKSRC}/openfx/Support/Plugins/Makefile.master \
+ ${WRKSRC}/DebugProxy/DebugProxy.cpp \
+ ${WRKSRC}/openfx/HostSupport/src/ofxhPluginCache.cpp
+ @${REINPLACE_CMD} -e 's|/Contents/$$(ARCH)|/Contents/FreeBSD-x86-64/|g' \
+ ${WRKSRC}/openfx/Support/Plugins/Makefile.master
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/OFX/Plugins/CImg.ofx.bundle/Contents/FreeBSD-x86-64/CImg.ofx
+ ${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/OFX/Plugins/Misc.ofx.bundle/Contents/FreeBSD-x86-64/Misc.ofx
+ ${STRIP_CMD} ${STAGEDIR}${LOCALBASE}/OFX/Plugins/Shadertoy.ofx.bundle/Contents/FreeBSD-x86-64/Shadertoy.ofx
+
+.include <bsd.port.mk>