aboutsummaryrefslogtreecommitdiff
path: root/graphics/opengtl
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2013-10-26 13:50:36 +0000
committerAlberto Villa <avilla@FreeBSD.org>2013-10-26 13:50:36 +0000
commitb896c137ee92035c8d698b3e4b9da8e8bcc71362 (patch)
tree22fe22ab036446c56cb1893a22eeb4a5b74934d1 /graphics/opengtl
parent0c509eab14557ed767191ca256ee2694c3e2ddac (diff)
downloadports-b896c137ee92035c8d698b3e4b9da8e8bcc71362.tar.gz
ports-b896c137ee92035c8d698b3e4b9da8e8bcc71362.zip
Notes
Diffstat (limited to 'graphics/opengtl')
-rw-r--r--graphics/opengtl/Makefile21
-rw-r--r--graphics/opengtl/files/patch-cmake__modules__FindLLVM.cmake18
2 files changed, 26 insertions, 13 deletions
diff --git a/graphics/opengtl/Makefile b/graphics/opengtl/Makefile
index db7f2dab367d..679e653687d0 100644
--- a/graphics/opengtl/Makefile
+++ b/graphics/opengtl/Makefile
@@ -2,6 +2,7 @@
PORTNAME= opengtl
PORTVERSION= 0.9.18
+PORTREVISION= 1
CATEGORIES= graphics devel
MASTER_SITES= http://download.${PORTNAME}.org/
DISTNAME= OpenGTL-${PORTVERSION}
@@ -11,27 +12,21 @@ COMMENT= Graphics Transformation Languages
LICENSE= LGPL20
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
-BUILD_DEPENDS= ${LOCALBASE}/lib/libLLVM-3.2.so:${PORTSDIR}/devel/llvm
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libLLVM-3.2.so:${PORTSDIR}/devel/llvm32
-USE_BZIP2= yes
USES= cmake perl5
+USE_BZIP2= yes
USE_LDCONFIG= yes
+CMAKE_ARGS= -DLLVM_CONFIG_EXECUTABLE=${LOCALBASE}/bin/llvm-config32
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= SHIVA
OPTIONS_DEFAULT=SHIVA
SHIVA_DESC= Install filters and generators
-
-PLIST_SUB+= PORTVERSION=${PORTVERSION}
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSHIVA}
-RUN_DEPENDS+= ${LOCALBASE}/share/OpenGTL/shiva/kernels/oilify.shiva:${PORTSDIR}/graphics/shiva-collections
-.endif
+SHIVA_RUN_DEPENDS=${LOCALBASE}/share/OpenGTL/shiva/kernels/oilify.shiva:${PORTSDIR}/graphics/shiva-collections
post-patch:
# Disable latex doc, it's not ready yet.
diff --git a/graphics/opengtl/files/patch-cmake__modules__FindLLVM.cmake b/graphics/opengtl/files/patch-cmake__modules__FindLLVM.cmake
new file mode 100644
index 000000000000..e7c6a5247d8a
--- /dev/null
+++ b/graphics/opengtl/files/patch-cmake__modules__FindLLVM.cmake
@@ -0,0 +1,18 @@
+--- ./cmake/modules/FindLLVM.cmake.orig 2012-12-29 12:27:12.000000000 +0100
++++ ./cmake/modules/FindLLVM.cmake 2013-10-26 15:46:16.168023085 +0200
+@@ -27,11 +27,13 @@
+ set(LLVM_FOUND TRUE)
+ endif(LLVM_INCLUDE_DIR AND LLVM_LIBS_DIR)
+ else (MSVC)
+- find_program(LLVM_CONFIG_EXECUTABLE
++ if(NOT LLVM_CONFIG_EXECUTABLE)
++ find_program(LLVM_CONFIG_EXECUTABLE
+ NAMES llvm-config
+ PATHS
+ /opt/local/bin
+- )
++ )
++ endif()
+
+ exec_program(${LLVM_CONFIG_EXECUTABLE} ARGS --version OUTPUT_VARIABLE LLVM_VERSION )
+