aboutsummaryrefslogtreecommitdiff
path: root/graphics/opengtl
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2010-09-06 22:38:41 +0000
committerAlberto Villa <avilla@FreeBSD.org>2010-09-06 22:38:41 +0000
commit92a1e4fc4aaeb2756279b6a38bde77a2e7522117 (patch)
treeb62ed7206679185d41abaa8fa9949d18705f9355 /graphics/opengtl
parent344b5508a4286b3b605a4a1c5a73fd275ebd9234 (diff)
downloadports-92a1e4fc4aaeb2756279b6a38bde77a2e7522117.tar.gz
ports-92a1e4fc4aaeb2756279b6a38bde77a2e7522117.zip
Notes
Diffstat (limited to 'graphics/opengtl')
-rw-r--r--graphics/opengtl/Makefile10
-rw-r--r--graphics/opengtl/distinfo6
-rw-r--r--graphics/opengtl/pkg-descr2
-rw-r--r--graphics/opengtl/pkg-plist22
4 files changed, 20 insertions, 20 deletions
diff --git a/graphics/opengtl/Makefile b/graphics/opengtl/Makefile
index 013601b67e12..657a09ff9ffd 100644
--- a/graphics/opengtl/Makefile
+++ b/graphics/opengtl/Makefile
@@ -1,20 +1,20 @@
# New ports collection makefile for: opengtl
# Date created: 28 September 2009
# Whom: Alberto Villa <villa.alberto@gmail.com>
+#
# $FreeBSD$
PORTNAME= opengtl
-PORTVERSION= 0.9.12
-PORTREVISION= 1
+PORTVERSION= 0.9.14
CATEGORIES= graphics devel
-MASTER_SITES= http://www.opengtl.org/download/
+MASTER_SITES= http://www.${PORTNAME}.org/download/
DISTNAME= OpenGTL-${PORTVERSION}
MAINTAINER= avilla@FreeBSD.org
COMMENT= Graphics Transformation Languages
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
-BUILD_DEPENDS= llvm>=2.5:${PORTSDIR}/devel/llvm
+BUILD_DEPENDS= llvm>=2.7<2.8.*:${PORTSDIR}/devel/llvm
USE_BZIP2= yes
USE_GCC= 4.2+
@@ -24,8 +24,6 @@ USE_CMAKE= yes
USE_LDCONFIG= yes
CMAKE_USE_PTHREAD= yes
-BROKEN= does not build with LLVM 2.7
-
post-patch:
# disable latex doc, it's not ready yet
${REINPLACE_CMD} -e '/add_subdirectory.*doc/d' \
diff --git a/graphics/opengtl/distinfo b/graphics/opengtl/distinfo
index 2d8359422580..97a1f0d3a619 100644
--- a/graphics/opengtl/distinfo
+++ b/graphics/opengtl/distinfo
@@ -1,3 +1,3 @@
-MD5 (OpenGTL-0.9.12.tar.bz2) = c45fddf10c922ebcf9cb5b7c5df89220
-SHA256 (OpenGTL-0.9.12.tar.bz2) = 07ac111c4041370a0ebda35200d0a04e38f3932ada20225e86c644e6e6260659
-SIZE (OpenGTL-0.9.12.tar.bz2) = 482004
+MD5 (OpenGTL-0.9.14.tar.bz2) = 11a2a63565f4203e09ab8ed3282451d6
+SHA256 (OpenGTL-0.9.14.tar.bz2) = 4dca918a8480f31bd0dcabef97050d6ef416b3ea3adc68cdde512c1b4e269fe8
+SIZE (OpenGTL-0.9.14.tar.bz2) = 497585
diff --git a/graphics/opengtl/pkg-descr b/graphics/opengtl/pkg-descr
index dc62596f782f..e8c896f3fd71 100644
--- a/graphics/opengtl/pkg-descr
+++ b/graphics/opengtl/pkg-descr
@@ -10,7 +10,7 @@ implementations.
- OpenCTL which is a GPL compatible of the Color Transformation Language, this
language is dedicated at transforming the value of a single pixel (for
instance brightness adjustement or desaturate). CTL is designed to be part of
- the Color Management process.
+ the Color Management process.
- OpenShiva is inspired by Adobe's Hydra language from the AIF Toolkit, Shiva
is a language that apply a kernel-like transformations on an image, that means
it works using more than one pixel.
diff --git a/graphics/opengtl/pkg-plist b/graphics/opengtl/pkg-plist
index f2dfa1a8a80e..f74a3f300aac 100644
--- a/graphics/opengtl/pkg-plist
+++ b/graphics/opengtl/pkg-plist
@@ -11,9 +11,10 @@ include/GTLCore/AbstractImage.h
include/GTLCore/Array.h
include/GTLCore/Buffer.h
include/GTLCore/BufferImage.h
-include/GTLCore/CategoriesManager.h
-include/GTLCore/Category.h
-include/GTLCore/ErrorMessage.h
+include/GTLCore/ChannelsFlags.h
+include/GTLCore/Color.h
+include/GTLCore/CompilationMessage.h
+include/GTLCore/CompilationMessages.h
include/GTLCore/Export.h
include/GTLCore/Function.h
include/GTLCore/Image.h
@@ -26,9 +27,10 @@ include/GTLCore/Parameter.h
include/GTLCore/PixelDescription.h
include/GTLCore/ProgressReport.h
include/GTLCore/Region.h
-include/GTLCore/RegionF.h
include/GTLCore/ScopedName.h
+include/GTLCore/StdTypes.h
include/GTLCore/String.h
+include/GTLCore/Transform.h
include/GTLCore/Type.h
include/GTLCore/TypesManager.h
include/GTLCore/Value.h
@@ -54,16 +56,16 @@ lib/GTLImageIO/Extensions/libPngDC.so
lib/GTLImageIO/Extensions/libRawDC.so
lib/libGTLCore.so
lib/libGTLCore.so.0
-lib/libGTLCore.so.0.9.12
+lib/libGTLCore.so.0.9.14
lib/libGTLImageIO.so
lib/libGTLImageIO.so.0
-lib/libGTLImageIO.so.0.9.12
+lib/libGTLImageIO.so.0.9.14
lib/libOpenCTL.so
lib/libOpenCTL.so.0
-lib/libOpenCTL.so.0.9.12
+lib/libOpenCTL.so.0.9.14
lib/libOpenShiva.so
lib/libOpenShiva.so.0
-lib/libOpenShiva.so.0.9.12
+lib/libOpenShiva.so.0.9.14
libdata/pkgconfig/GTLCore.pc
libdata/pkgconfig/GTLImageIO.pc
libdata/pkgconfig/OpenCTL.pc
@@ -71,9 +73,9 @@ libdata/pkgconfig/OpenShiva.pc
share/OpenGTL/ctl/ctlstdlib.ctl
share/OpenGTL/shiva/libraries/shivastdlib.shiva
@dirrm share/OpenGTL/shiva/libraries
-@dirrm share/OpenGTL/shiva
+@dirrmtry share/OpenGTL/shiva
@dirrm share/OpenGTL/ctl
-@dirrm share/OpenGTL
+@dirrmtry share/OpenGTL
@dirrm lib/GTLImageIO/Extensions
@dirrm lib/GTLImageIO
@dirrm include/OpenShiva