aboutsummaryrefslogtreecommitdiff
path: root/graphics/openimageio/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-09-17 05:24:02 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-09-17 05:24:02 +0000
commit7fdcb6654c6ac3bddb85e152fadba5e5826d4ce5 (patch)
treeb386d64dc5a1ab737ca444aedfb626e1a885f0a7 /graphics/openimageio/Makefile
parentd9787e66af546b4d49c30b9fe7c2fe7f8578df4d (diff)
downloadports-7fdcb6654c6ac3bddb85e152fadba5e5826d4ce5.tar.gz
ports-7fdcb6654c6ac3bddb85e152fadba5e5826d4ce5.zip
Notes
Diffstat (limited to 'graphics/openimageio/Makefile')
-rw-r--r--graphics/openimageio/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/graphics/openimageio/Makefile b/graphics/openimageio/Makefile
index e0b677c594af..0447b2f01ce3 100644
--- a/graphics/openimageio/Makefile
+++ b/graphics/openimageio/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openimageio
-PORTVERSION= 1.0.6
+PORTVERSION= 1.0.9
CATEGORIES= graphics multimedia
MASTER_SITES= https://github.com/OpenImageIO/oiio/tarball/
DISTNAME= Release-${PORTVERSION}
@@ -26,6 +26,9 @@ LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
tbb:${PORTSDIR}/devel/tbb \
webp:${PORTSDIR}/graphics/webp
+# fbm also installs bin/idiff
+CONFLICTS= fbm-[0-9]*
+
FETCH_ARGS= -pRr
USE_CMAKE= yes
CMAKE_VERBOSE= yes
@@ -36,17 +39,19 @@ CMAKE_ARGS= -DBUILDSTATIC:BOOL=OFF \
-DUSE_TBB:BOOL=ON
LDFLAGS+= -ltbb
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/OpenImageIO-oiio-f0a566a/src
+WRKSRC= ${WRKDIR}/OpenImageIO-oiio-0d48631/src
MAKE_JOBS_SAFE= yes
-OPTIONS_DEFINE= IMAGEVIEWER THREADS
+OPTIONS_DEFINE= DOCS IMAGEVIEWER THREADS
OPTIONS_DEFAULT= DOCS IMAGEVIEWER THREADS
IMAGEVIEWER_DESC= Build image viewer
.include <bsd.port.options.mk>
-.if empty(PORT_OPTIONS:MDOCS)
+.if ${PORT_OPTIONS:MDOCS}
+CMAKE_ARGS+= -DINSTALL_DOCS:BOOL=ON
+.else
CMAKE_ARGS+= -DINSTALL_DOCS:BOOL=OFF
.endif
@@ -61,7 +66,7 @@ CMAKE_ARGS+= -DUSE_OPENGL:BOOL=OFF -DUSE_QT:BOOL=OFF
PLIST_SUB+= IMAGEVIEWER="@comment "
.endif
-.if empty(PORT_OPTIONS:MTHREADS)
+.if ${PORT_OPTIONS:MTHREADS}
CMAKE_ARGS+= -DNOTHREADS:BOOL=ON
.else
CMAKE_ARGS+= -DNOTHREADS:BOOL=OFF