aboutsummaryrefslogtreecommitdiff
path: root/graphics/openjump
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-11-11 11:08:58 +0000
committerWen Heping <wen@FreeBSD.org>2011-11-11 11:08:58 +0000
commit24a5a04d64118b70eb55964e91718cb696e67d7c (patch)
treefd24cae757b8a6cc1e0309c0c660b1ad58ed948b /graphics/openjump
parentb9fa7aafa99658acc3f3f07280b0de83ab0e77e5 (diff)
downloadports-24a5a04d64118b70eb55964e91718cb696e67d7c.tar.gz
ports-24a5a04d64118b70eb55964e91718cb696e67d7c.zip
Notes
Diffstat (limited to 'graphics/openjump')
-rw-r--r--graphics/openjump/Makefile9
-rw-r--r--graphics/openjump/distinfo4
-rw-r--r--graphics/openjump/files/patch-bin__oj_linux.sh32
-rw-r--r--graphics/openjump/pkg-descr18
-rw-r--r--graphics/openjump/pkg-plist25
5 files changed, 64 insertions, 24 deletions
diff --git a/graphics/openjump/Makefile b/graphics/openjump/Makefile
index cf19a75bf86e..956ec666327c 100644
--- a/graphics/openjump/Makefile
+++ b/graphics/openjump/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= openjump
-PORTVERSION= 1.4.0.3
+PORTVERSION= 1.4.2
CATEGORIES= graphics java geography
MASTER_SITES= SF/jump-pilot/OpenJUMP/${PORTVERSION}
DISTNAME= ${PORTNAME}-bin-${PORTVERSION}
-MAINTAINER= wenheping@gmail.com
+MAINTAINER= rhurlin@gwdg.de
COMMENT= An open source GIS software written in Java
TARGET_DIR= ${PREFIX}/${PORTNAME}
@@ -29,9 +29,11 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/lib/*.jar ${TARGET_DIR}/lib
${MKDIR} ${TARGET_DIR}/lib/ext
@cd ${WRKSRC}/lib/ext && ${COPYTREE_SHARE} . ${TARGET_DIR}/lib/ext
+ @${RM} ${PREFIX}/openjump/lib/ext/*.dll
@${ECHO_MSG} "Installing startup script"
${MKDIR} ${TARGET_DIR}/bin
${INSTALL_SCRIPT} ${WRKSRC}/bin/oj_linux.sh ${TARGET_DIR}/bin/openjump
+ ${LN} -sf ${PREFIX}/openjump/bin/openjump ${PREFIX}/bin/openjump
${INSTALL_DATA} ${WRKSRC}/bin/workbench-properties.xml ${TARGET_DIR}/bin/
${INSTALL_DATA} ${WRKSRC}/bin/default-plugins.xml ${TARGET_DIR}/bin/
${INSTALL_DATA} ${WRKSRC}/bin/log4j.xml ${TARGET_DIR}/bin/
@@ -42,7 +44,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Changes.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/licenses/apache_license.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/licenses/gpl2_license.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/licenses/cpl-1.0.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/licenses/jdom_license.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/licenses/jmath_license.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/licenses/jython_license.txt ${DOCSDIR}
.else
diff --git a/graphics/openjump/distinfo b/graphics/openjump/distinfo
index 5cdc316d808c..d2d9af56b6f4 100644
--- a/graphics/openjump/distinfo
+++ b/graphics/openjump/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openjump-bin-1.4.0.3.zip) = 5dfd394e72cdda128e9d964840cd57a8e9515857b6e073d2156c33aaf85d2437
-SIZE (openjump-bin-1.4.0.3.zip) = 13515561
+SHA256 (openjump-bin-1.4.2.zip) = 46a7b71a743db661ace672af9673842e878806fa5f89382c5f6dab0f57072298
+SIZE (openjump-bin-1.4.2.zip) = 17730191
diff --git a/graphics/openjump/files/patch-bin__oj_linux.sh b/graphics/openjump/files/patch-bin__oj_linux.sh
new file mode 100644
index 000000000000..ebfdce56ab21
--- /dev/null
+++ b/graphics/openjump/files/patch-bin__oj_linux.sh
@@ -0,0 +1,32 @@
+--- bin/oj_linux.sh.orig 2011-09-11 12:55:32.000000000 +0200
++++ bin/oj_linux.sh 2011-10-23 09:46:55.000000000 +0200
+@@ -1,7 +1,7 @@
+ #!/bin/sh
+
+ ## uncomment and put the path to your jre here
+-#JAVA_HOME="/home/ed/jre1.6.0_21"
++JAVA_HOME="/usr/local/"
+
+ ## uncomment and change your memory configuration here
+ ## Xms is initial size, Xmx is maximum size
+@@ -75,13 +75,13 @@
+ echo "The found java binary '$JAVA' is no executable file." && ERROR=1 && end
+
+ # java version check
+-JAVA_VERSION=$("$JAVA" -version 2>&1 | awk -F'"' '/^java version/{print $2}' | awk -F'.' '{print $1"."$2}')
+-JAVA_NEEDED="1.5"
+-if ! awk "BEGIN{if($JAVA_VERSION < $JAVA_NEEDED)exit 1}"; then
+- echo "Your java version '$JAVA_VERSION' is insufficient to run openjump.
+-Please provide an at least version '$JAVA_NEEDED' java runtime."
+- ERROR=1
+-fi
++#JAVA_VERSION=$("$JAVA" -version 2>&1 | awk -F'"' '/^java version/{print $2}' | awk -F'.' '{print $1"."$2}')
++#JAVA_NEEDED="1.5"
++#if ! awk "BEGIN{if($JAVA_VERSION < $JAVA_NEEDED)exit 1}"; then
++# echo "Your java version '$JAVA_VERSION' is insufficient to run openjump.
++#Please provide an at least version '$JAVA_NEEDED' java runtime."
++# ERROR=1
++#fi
+
+ # always print java infos
+ echo "Running -> '${JAVA}'; " $("$JAVA" -version 2>&1|awk 'BEGIN{ORS=""}{print $0"; "}')
diff --git a/graphics/openjump/pkg-descr b/graphics/openjump/pkg-descr
index ecc9ad80b0bf..ce0244f2efab 100644
--- a/graphics/openjump/pkg-descr
+++ b/graphics/openjump/pkg-descr
@@ -1,18 +1,22 @@
OpenJUMP is an open source GIS software written in Java. It is based on
JUMP GIS by Vivid Solutions. It's features include:
+
* It is a Vector GIS that can read rasters as well.
* OpenJUMP is known to work on Windows, Linux and Mac platforms, but
-should work on any operating system that runs Java 1.5 or later.
+ should work on any operating system that runs Java 1.5 or later.
* It is not just another free demo viewer, but you can edit, save,
-analyze etc. with JUMP / OpenJUMP.
+ analyze etc. with JUMP / OpenJUMP.
* It works, even with medium size datasets, and with professional
-touch.
+ touch.
* It provides a GIS API with a flexible plugin structure, so that
-new features are relatively easy to develope around the sound mapping
-platform.
+ new features are relatively easy to develope around the sound
+ mapping platform.
* It utilises standards like GML, WMS and WFS.
* It is already translated in English, Finnish, French, German,
-Italian, Portugese and Spanish. The translation in other languages is in
-progress.
+ Italian, Portugese and Spanish. The translation in other languages
+ is in progress.
+
+Extensions and plugins can be found at
+WWW: http://sourceforge.net/projects/jump-pilot/files/OpenJUMP_plugins/
WWW: http://www.openjump.org/
diff --git a/graphics/openjump/pkg-plist b/graphics/openjump/pkg-plist
index f9745b5267e6..f89f221ba79c 100644
--- a/graphics/openjump/pkg-plist
+++ b/graphics/openjump/pkg-plist
@@ -1,27 +1,26 @@
-openjump/bin/openjump
-openjump/bin/workbench-properties.xml
openjump/bin/default-plugins.xml
openjump/bin/log4j.xml
-openjump/lib/bsh-2.0b4.jar
-openjump/lib/Jama-1.0.1.jar
-openjump/lib/jdom.jar
-openjump/lib/jts-1.11.jar
-openjump/lib/xercesImpl.jar
-openjump/lib/xml-apis.jar
+openjump/bin/openjump
+bin/openjump
+openjump/bin/workbench-properties.xml
openjump/lib/Buoy.jar
+openjump/lib/Jama-1.0.1.jar
openjump/lib/batik-all.jar
+openjump/lib/bsh-2.0b4.jar
openjump/lib/ermapper.jar
openjump/lib/jai_codec.jar
openjump/lib/jai_core.jar
+openjump/lib/jdom.jar
openjump/lib/jmatharray-20070905.jar
openjump/lib/jmathplot-20070905.jar
+openjump/lib/jts-1.12.jar
openjump/lib/jython.jar
openjump/lib/log4j-1.2.16.jar
-openjump/lib/openjump-api-1.4.0.3.jar
-openjump/lib/openjump-workbench-1.4.0.3.jar
-openjump/lib/postgis_1_0_0.jar
+openjump/lib/openjump-1.4.2.jar
openjump/lib/postgresql-9.0-801.jdbc3.jar
+openjump/lib/xercesImpl.jar
openjump/lib/xml-apis-ext.jar
+openjump/lib/xml-apis.jar
openjump/lib/ext/BeanTools/0-Help.bsh
openjump/lib/ext/BeanTools/1-HelloWorld.bsh
openjump/lib/ext/BeanTools/2-NewLayer.bsh
@@ -31,6 +30,7 @@ openjump/lib/ext/BeanTools/5-ChangeAttributeValue.bsh
openjump/lib/ext/BeanTools/6-PushPinPoints.bsh
openjump/lib/ext/BeanTools/7-AddXYAsAttributes.bsh
openjump/lib/ext/BeanTools/8-GetInvalidShapefileRings.bsh
+openjump/lib/ext/BeanTools/9-Display_WMS_URL.bsh
openjump/lib/ext/BeanTools/RefreshScriptsMenu.bsh
openjump/lib/ext/BeanTools/SaveViewAsBeanTool.bsh
openjump/lib/ext/jython/AlignSelected.py
@@ -55,7 +55,8 @@ openjump/lib/ext/readme.txt
%%PORTDOCS%%%%DOCSDIR%%/readme.txt
%%PORTDOCS%%%%DOCSDIR%%/Changes.txt
%%PORTDOCS%%%%DOCSDIR%%/apache_license.txt
-%%PORTDOCS%%%%DOCSDIR%%/gpl2_license.txt
+%%PORTDOCS%%%%DOCSDIR%%/cpl-1.0.txt
+%%PORTDOCS%%%%DOCSDIR%%/jdom_license.txt
%%PORTDOCS%%%%DOCSDIR%%/jmath_license.txt
%%PORTDOCS%%%%DOCSDIR%%/jython_license.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%