aboutsummaryrefslogtreecommitdiff
path: root/graphics/openorienteering-mapper
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /graphics/openorienteering-mapper
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Notes
Diffstat (limited to 'graphics/openorienteering-mapper')
-rw-r--r--graphics/openorienteering-mapper/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/graphics/openorienteering-mapper/Makefile b/graphics/openorienteering-mapper/Makefile
index 16b356924d5d..4933077dc916 100644
--- a/graphics/openorienteering-mapper/Makefile
+++ b/graphics/openorienteering-mapper/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= libpolyclipping.so:graphics/polyclipping \
libproj.so:graphics/proj
USES= cmake:outsource,noninja compiler:c++14-lang \
- desktop-file-utils gmake shared-mime-info
-USE_QT5= buildtools_build help qmake_build core gui \
+ desktop-file-utils gmake qt:5 shared-mime-info
+USE_QT= buildtools_build help qmake_build core gui \
location network printsupport sensors widgets
USE_GITHUB= yes
GH_ACCOUNT= OpenOrienteering
@@ -32,19 +32,22 @@ OPTIONS_DEFAULT= GDAL
OPTIONS_SUB= yes
DOCS_CMAKE_BOOL= Mapper_WITH_DOCS
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
-DOCS_USE= QT5=assistant_run
+DOCS_USES= qt:5
+DOCS_USE= QT=assistant_run
EXAMPLES_CMAKE_BOOL= Mapper_WITH_EXAMPLES
GDAL_DESC= Use the GDAL library
GDAL_CMAKE_BOOL= Mapper_USE_GDAL
GDAL_LIB_DEPENDS= libgdal.so:graphics/gdal
NLS_CMAKE_BOOL= Mapper_WITH_NLS
NLS_BUILD_DEPENDS= gsed:textproc/gsed
-NLS_USE= QT5=linguisttools_build
-NLS_USES= gettext-runtime
+NLS_USE= QT=linguisttools_build
+NLS_USES= gettext-runtime qt:5
TEST_CMAKE_BOOL= Mapper_WITH_TEST
-TEST_USE= QT5=testlib_build
+TEST_USES= qt:5
+TEST_USE= QT=testlib_build
TEST_TEST_TARGET= test
TIFF_DESC= Support for TIFF
-TIFF_USE= QT5=imageformats
+TIFF_USES= qt:5
+TIFF_USE= QT=imageformats
.include <bsd.port.mk>