aboutsummaryrefslogtreecommitdiff
path: root/graphics/openshadinglanguage/Makefile
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2013-11-03 00:23:29 +0000
committerBrooks Davis <brooks@FreeBSD.org>2013-11-03 00:23:29 +0000
commitd395b2ada919e45d693a4bab22033a878034d0f9 (patch)
tree9d2877431846332cbfebc77c5fadbecf2a8ef0f3 /graphics/openshadinglanguage/Makefile
parentac3f26e734cd57afba02dd76cd392e82cb7a1b0b (diff)
downloadports-d395b2ada919e45d693a4bab22033a878034d0f9.tar.gz
ports-d395b2ada919e45d693a4bab22033a878034d0f9.zip
Notes
Diffstat (limited to 'graphics/openshadinglanguage/Makefile')
-rw-r--r--graphics/openshadinglanguage/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/graphics/openshadinglanguage/Makefile b/graphics/openshadinglanguage/Makefile
index 9f22b81497f7..c200581d3297 100644
--- a/graphics/openshadinglanguage/Makefile
+++ b/graphics/openshadinglanguage/Makefile
@@ -11,12 +11,12 @@ COMMENT= Advanced shading language for production GI renderers
LICENSE= BSD
-BUILD_DEPENDS= llvm>=3.1:${PORTSDIR}/devel/llvm \
+BUILD_DEPENDS= llvm-config32:${PORTSDIR}/devel/llvm32 \
flex>=2.5.37:${PORTSDIR}/textproc/flex
LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
IlmImf:${PORTSDIR}/graphics/OpenEXR \
OpenImageIO:${PORTSDIR}/graphics/openimageio
-RUN_DEPENDS= llvm>=3.1:${PORTSDIR}/devel/llvm
+RUN_DEPENDS= llvm-config32:${PORTSDIR}/devel/llvm32
USE_GITHUB= yes
GH_ACCOUNT= imageworks
@@ -27,6 +27,7 @@ GH_COMMIT= 18671dc
WRKSRC= ${WRKDIR}/imageworks-OpenShadingLanguage-${GH_COMMIT}/src
CMAKE_ARGS= -DFLEX_EXECUTABLE:STRING=${LOCALBASE}/bin/flex \
+ -DLLVM_CONFIG:STRING=${LOCALBASE}/bin/llvm-config32 \
-DUSE_TBB:BOOL=OFF
CXXFLAGS+= -I${LOCALBASE}/include/flex
USE_LDCONFIG= yes
@@ -35,9 +36,7 @@ USES= bison cmake:outsource
NO_STAGE= yes
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 900000
-BUILD_DEPENDS+= clang:${PORTSDIR}/lang/clang
-.endif
+BUILD_DEPENDS+= clang32:${PORTSDIR}/lang/clang32
.if ${ARCH} == i386
CFLAGS+= -march=i586