aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg-devel/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-24 05:10:18 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-24 05:10:18 +0000
commit6f7c2f028208d4a0c852145eda3b0dbdf5c39fba (patch)
tree5ee926fb855ac4253be422bfd69f47e8be45b277 /graphics/osg-devel/Makefile
parentb60d2dcc1e9f2cd9eb99b88a0bba61fad85c6b10 (diff)
downloadports-6f7c2f028208d4a0c852145eda3b0dbdf5c39fba.tar.gz
ports-6f7c2f028208d4a0c852145eda3b0dbdf5c39fba.zip
Notes
Diffstat (limited to 'graphics/osg-devel/Makefile')
-rw-r--r--graphics/osg-devel/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index 3befaf61f571..26149e45ac06 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= osg
-PORTVERSION= 0.8.45
+PORTVERSION= 0.9.2
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/download/snapshots/
+DISTNAME= OpenSceneGraph-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -18,8 +19,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
freetype.9:${PORTSDIR}/print/freetype2
-DISTNAME= OpenSceneGraph-${PORTVERSION}
-
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_MESA= yes
INSTALLS_SHLIB= yes
@@ -29,10 +29,16 @@ MAKE_ENV= OSGHOME=${WRKSRC}
# opt = optimized ($OPTF added); debug = debug ($DBGF added); opt is default
ALL_TARGET= opt
+post-patch:
+ @${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|malloc\.h|stdlib.h|"
+
post-install:
- ${LN} -sf ${PREFIX}/share/osg/bin/sgv ${PREFIX}/bin
- ${LN} -sf ${PREFIX}/share/osg/bin/osgconv ${PREFIX}/bin
- @${MKDIR} ${DOCSDIR}
- ${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
+ ${LN} -sf ${DATADIR}/bin/sgv ${PREFIX}/bin
+ ${LN} -sf ${DATADIR}/bin/osgconv ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -r ${WRKSRC}/doc/ ${DOCSDIR}
+.endif
.include <bsd.port.mk>