aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg-devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-22 10:18:31 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-22 10:18:31 +0000
commitd5339139cd1efd444ee39153d92667fd52658275 (patch)
tree181ec08741b1cd9c91f94560c21fa0ba7a427ad6 /graphics/osg-devel
parent0ab404510d1c08375afdb7842ca5a2d635ccd116 (diff)
downloadports-d5339139cd1efd444ee39153d92667fd52658275.tar.gz
ports-d5339139cd1efd444ee39153d92667fd52658275.zip
Notes
Diffstat (limited to 'graphics/osg-devel')
-rw-r--r--graphics/osg-devel/Makefile24
-rw-r--r--graphics/osg-devel/distinfo4
-rw-r--r--graphics/osg-devel/pkg-plist17
3 files changed, 6 insertions, 39 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index a83d5b3a482c..07335801d62f 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= osg
-PORTVERSION= 3.3.5
+PORTVERSION= 3.3.6
CATEGORIES= graphics
MASTER_SITES= http://trac.openscenegraph.org/downloads/developer_releases/ \
http://mirror.amdmi3.ru/distfiles/
@@ -29,15 +29,15 @@ USE_XORG= x11
USE_LDCONFIG= yes
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
- OSG_SHLIBVER=117 \
+ OSG_SHLIBVER=118 \
OPENTHREADS_VERSION=3.3.0 \
OPENTHREADS_SHLIBVER=20
PORTSCOUT= limitw:1,odd
OPTIONS_DEFINE= CURL FFMPEG FREETYPE GDAL GIF GSTREAMER GTA INVENTOR \
- JASPER LIBLAS LUA NVTT OPENEXR PDF PYTHON QT4 SDL \
- SVG V8 VNC XINE XRANDR
+ JASPER LIBLAS LUA NVTT OPENEXR PDF QT4 SDL \
+ SVG VNC XINE XRANDR
OPTIONS_DEFAULT=FREETYPE GIF FFMPEG XRANDR
LIBLAS_DESC= liblas support
@@ -48,8 +48,6 @@ VNC_DESC= LibVNCServer support
SDL_DESC= Use SDL (joystick support in present3d)
NVTT_DESC= Use NVidia texture tools
LUA_DESC= Lua script engine support
-V8_DESC= V8 script engine support
-PYTHON_DESC= Python script engine support
OPTIONS_SUB= yes
@@ -76,8 +74,6 @@ QT4_USE= QT4=corelib,gui,opengl,qmake_build,moc_build,uic_build,rcc_build
QT4_CMAKE_ON= -DOSG_USE_QT=ON
QT4_CMAKE_OFF= -DOSG_USE_QT=OFF
LUA_USES= lua:52
-V8_LIB_DEPENDS= libv8.so:${PORTSDIR}/lang/v8
-PYTHON_USES= python:2
.include <bsd.port.options.mk>
@@ -173,18 +169,6 @@ FORCE_REQUIRE+= Lua51
FORCE_IGNORE+= Lua51
.endif
-.if ${PORT_OPTIONS:MV8}
-FORCE_REQUIRE+= V8
-.else
-FORCE_IGNORE+= V8
-.endif
-
-.if ${PORT_OPTIONS:MPYTHON}
-FORCE_REQUIRE+= PythonLibs
-.else
-FORCE_IGNORE+= PythonLibs
-.endif
-
# options that affect PKG_CHECK_MODULES
.if ${PORT_OPTIONS:MSVG}
FORCE_REQUIRE+= RSVG
diff --git a/graphics/osg-devel/distinfo b/graphics/osg-devel/distinfo
index b4ab6823f8ac..449699575395 100644
--- a/graphics/osg-devel/distinfo
+++ b/graphics/osg-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (OpenSceneGraph-3.3.5.zip) = aa7c3e30149752202c3b6f771e4a5bed80465807d732953813512f3f64045564
-SIZE (OpenSceneGraph-3.3.5.zip) = 8263725
+SHA256 (OpenSceneGraph-3.3.6.zip) = 0399548967328933debce7f5901defe357f3ada4bd13f45dcf56b4aad3a10065
+SIZE (OpenSceneGraph-3.3.6.zip) = 8225268
diff --git a/graphics/osg-devel/pkg-plist b/graphics/osg-devel/pkg-plist
index c28b4efbd297..20494217d776 100644
--- a/graphics/osg-devel/pkg-plist
+++ b/graphics/osg-devel/pkg-plist
@@ -409,30 +409,16 @@ include/osgParticle/SmokeTrailEffect
include/osgParticle/VariableRateCounter
include/osgParticle/Version
include/osgParticle/range
-include/osgPresentation/Action
include/osgPresentation/AnimationMaterial
-include/osgPresentation/Audio
include/osgPresentation/CompileSlideCallback
include/osgPresentation/Cursor
-include/osgPresentation/Element
include/osgPresentation/Export
-include/osgPresentation/Group
-include/osgPresentation/Image
include/osgPresentation/KeyEventHandler
-include/osgPresentation/Layer
-include/osgPresentation/Model
-include/osgPresentation/Movie
include/osgPresentation/PickEventHandler
-include/osgPresentation/Presentation
-include/osgPresentation/PresentationInterface
include/osgPresentation/PropertyManager
-include/osgPresentation/Section
-include/osgPresentation/Slide
include/osgPresentation/SlideEventHandler
include/osgPresentation/SlideShowConstructor
-include/osgPresentation/Text
include/osgPresentation/Timeout
-include/osgPresentation/Volume
%%QT4%%include/osgQt/Export
%%QT4%%include/osgQt/GraphicsWindowQt
%%QT4%%include/osgQt/QFontImplementation
@@ -736,7 +722,6 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_png.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pnm.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pov.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pvr.so
-%%PYTHON%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_python.so
%%QT4%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_qfont.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_revisions.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_rgb.so
@@ -748,7 +733,6 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgfx.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgga.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgmanipulator.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgparticle.so
-lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgpresentation.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgshadow.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgsim.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_serializers_osgterrain.so
@@ -769,7 +753,6 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_trans.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_trk.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_txf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_txp.so
-%%V8%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_v8.so
%%VNC%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_vnc.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_vtf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_x.so