aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg-devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-07 14:59:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-07 14:59:45 +0000
commita658b49ed969e023475f07c7bc9a185375bff161 (patch)
tree4374c2c78cfa969e73fcd2e305143464acee250a /graphics/osg-devel
parenta8d7fea9eb9f5ba43a55c6654cd555b51d32cedd (diff)
downloadports-a658b49ed969e023475f07c7bc9a185375bff161.tar.gz
ports-a658b49ed969e023475f07c7bc9a185375bff161.zip
Notes
Diffstat (limited to 'graphics/osg-devel')
-rw-r--r--graphics/osg-devel/Makefile29
-rw-r--r--graphics/osg-devel/distinfo6
-rw-r--r--graphics/osg-devel/files/patch-CMakeLists.txt20
-rw-r--r--graphics/osg-devel/pkg-plist30
4 files changed, 65 insertions, 20 deletions
diff --git a/graphics/osg-devel/Makefile b/graphics/osg-devel/Makefile
index b530281b7cb1..70f1afb8464d 100644
--- a/graphics/osg-devel/Makefile
+++ b/graphics/osg-devel/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= osg
-PORTVERSION= 2.9.4
+PORTVERSION= 2.9.5
CATEGORIES= graphics
MASTER_SITES= http://www.openscenegraph.org/downloads/developer_releases/ \
- http://mirror.amdmi3.ru/
+ http://mirror.amdmi3.ru/distfiles/
PKGNAMESUFFIX= -devel
DISTNAME= OpenSceneGraph-${PORTVERSION}
@@ -31,7 +31,7 @@ USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
- OSG_SHLIBVER=59 \
+ OSG_SHLIBVER=60 \
OPENTHREADS_VERSION=2.4.0 \
OPENTHREADS_SHLIBVER=11
@@ -50,15 +50,16 @@ OPTIONS= CURL "Support for cURL" off \
FFMPEG "Support for FFmpeg" off \
SVG "Support for SVG through librsvg2" off \
PDF "Support for PDF through poppler" off \
- XRANDR "Use Xrandr" on
+ XRANDR "Use Xrandr" on \
+ SDL "Use SDL (joystick support in present3d)" off
# broken (openvrml from ports is too old)
# OPENVRML "Support for OpenVRML" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# GUI toolkits are only needed for building examples, which are not even installed
-FORCE_IGNORE= FLTK GLUT SDL FOX Qt3 Qt4 wxWidgets OpenAL # only for examples
+FORCE_IGNORE= FLTK GLUT FOX Qt3 Qt4 wxWidgets OpenAL # only for examples
FORCE_IGNORE+= COLLADA Performer OurDCMTK XUL # not in ports
FORCE_REQUIRE= Threads OpenGL X11 JPEG PNG TIFF ZLIB # common & lightweight
FORCE_PC_IGNORE= GTK GTKGL # only for examples
@@ -176,6 +177,13 @@ FORCE_IGNORE+= FFmpeg
PLIST_SUB+= FFMPEG="@comment "
.endif
+.if defined(WITH_SDL)
+FORCE_REQUIRE+= SDL
+USE_SDL= sdl
+.else
+FORCE_IGNORE+= SDL
+.endif
+
# options that affect PKG_CHECK_MODULES
.if defined(WITH_SVG)
FORCE_PC_REQUIRE+=RSVG
@@ -210,6 +218,13 @@ CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=ON
USE_XORG+= xrandr
.endif
+.if defined(WITHOUT_XRANDR)
+CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=OFF
+.else
+CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=ON
+USE_XORG+= xrandr
+.endif
+
post-patch:
@${FIND} ${WRKSRC}/CMakeModules -type f -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g'
@@ -230,4 +245,4 @@ post-patch:
${WRKSRC}/CMakeLists.txt
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/osg-devel/distinfo b/graphics/osg-devel/distinfo
index edc078ebc98a..1270674f6372 100644
--- a/graphics/osg-devel/distinfo
+++ b/graphics/osg-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (OpenSceneGraph-2.9.4.zip) = c26d60be504809ed570d89cacca44650
-SHA256 (OpenSceneGraph-2.9.4.zip) = 801f7fee6b91b7535b5812a1cfe4d9f50f36dc96d02f58b935c6d65d6452af06
-SIZE (OpenSceneGraph-2.9.4.zip) = 6877732
+MD5 (OpenSceneGraph-2.9.5.zip) = c22bb0595071a143c3d68ae7f53e1ffe
+SHA256 (OpenSceneGraph-2.9.5.zip) = 983e8cf2c323660e1049b80784da7c7cf962bab8479e0df40be0437da6d11a68
+SIZE (OpenSceneGraph-2.9.5.zip) = 7202802
diff --git a/graphics/osg-devel/files/patch-CMakeLists.txt b/graphics/osg-devel/files/patch-CMakeLists.txt
index e7dc6a6dce0d..d47608af17b2 100644
--- a/graphics/osg-devel/files/patch-CMakeLists.txt
+++ b/graphics/osg-devel/files/patch-CMakeLists.txt
@@ -1,20 +1,20 @@
---- CMakeLists.txt.orig 2009-01-29 16:29:08.000000000 +0300
-+++ CMakeLists.txt 2009-02-05 17:45:24.000000000 +0300
-@@ -459,7 +459,7 @@
+--- CMakeLists.txt.orig 2009-05-22 12:31:58.000000000 +0400
++++ CMakeLists.txt 2009-06-25 17:51:06.000000000 +0400
+@@ -486,7 +486,7 @@
IF(UNIX AND NOT WIN32 AND NOT APPLE)
IF(CMAKE_SIZEOF_VOID_P MATCHES "8")
- SET(LIB_POSTFIX "64" CACHE STRING "suffix for 32/64 dir placement")
+ SET(LIB_POSTFIX "" CACHE STRING "suffix for 32/64 dir placement")
MARK_AS_ADVANCED(LIB_POSTFIX)
- ENDIF(CMAKE_SIZEOF_VOID_P MATCHES "8")
- ENDIF(UNIX AND NOT WIN32 AND NOT APPLE)
-@@ -766,7 +766,7 @@
+ ENDIF()
+ ENDIF()
+@@ -822,7 +822,7 @@
+ ${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc
@ONLY
)
+- INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc DESTINATION lib${LIB_POSTFIX}/pkgconfig COMPONENT libopenscenegraph-dev)
++ INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc DESTINATION libdata/pkgconfig COMPONENT libopenscenegraph-dev)
+ ENDFOREACH(PKGCONFIG_FILE)
--INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/openscenegraph.pc DESTINATION lib${LIB_POSTFIX}/pkgconfig COMPONENT libopenscenegraph-dev)
-+INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/openscenegraph.pc DESTINATION libdata/pkgconfig COMPONENT libopenscenegraph-dev)
- # Run this as late as possible so users can easier spot the message
- IF (${CMAKE_INSTALL_PREFIX} STREQUAL "/usr/local")
diff --git a/graphics/osg-devel/pkg-plist b/graphics/osg-devel/pkg-plist
index c23269d4d10c..7e8ead352177 100644
--- a/graphics/osg-devel/pkg-plist
+++ b/graphics/osg-devel/pkg-plist
@@ -3,6 +3,7 @@ bin/osgconv
bin/osgfilecache
bin/osgversion
bin/osgviewer
+bin/present3D-osg
include/OpenThreads/Atomic
include/OpenThreads/Barrier
include/OpenThreads/Block
@@ -179,6 +180,9 @@ include/osg/fast_back_stack
include/osg/io_utils
include/osg/observer_ptr
include/osg/ref_ptr
+include/osgAnimation/Action
+include/osgAnimation/ActionCallback
+include/osgAnimation/ActionVisitor
include/osgAnimation/Animation
include/osgAnimation/AnimationManagerBase
include/osgAnimation/Assert
@@ -188,6 +192,7 @@ include/osgAnimation/Channel
include/osgAnimation/CubicBezier
include/osgAnimation/EaseMotion
include/osgAnimation/Export
+include/osgAnimation/FrameAction
include/osgAnimation/Interpolator
include/osgAnimation/Keyframe
include/osgAnimation/LinkVisitor
@@ -196,6 +201,8 @@ include/osgAnimation/RigGeometry
include/osgAnimation/Sampler
include/osgAnimation/Skeleton
include/osgAnimation/Skinning
+include/osgAnimation/StatsHandler
+include/osgAnimation/StatsVisitor
include/osgAnimation/Target
include/osgAnimation/Timeline
include/osgAnimation/TimelineAnimationManager
@@ -204,8 +211,10 @@ include/osgAnimation/Vec3Packed
include/osgAnimation/VertexInfluence
include/osgDB/Archive
include/osgDB/AuthenticationMap
+include/osgDB/Callbacks
include/osgDB/ConvertUTF
include/osgDB/DatabasePager
+include/osgDB/DatabaseRevisions
include/osgDB/DotOsgWrapper
include/osgDB/DynamicLibrary
include/osgDB/Export
@@ -218,6 +227,7 @@ include/osgDB/FileUtils
include/osgDB/ImageOptions
include/osgDB/ImagePager
include/osgDB/Input
+include/osgDB/Options
include/osgDB/Output
include/osgDB/ParameterOutput
include/osgDB/PluginQuery
@@ -228,6 +238,7 @@ include/osgDB/Serializer
include/osgDB/SharedStateManager
include/osgDB/Version
include/osgDB/WriteFile
+include/osgDB/XmlParser
include/osgDB/fstream
include/osgFX/AnisotropicLighting
include/osgFX/BumpMapping
@@ -254,6 +265,7 @@ include/osgGA/GUIEventHandler
include/osgGA/KeySwitchMatrixManipulator
include/osgGA/MatrixManipulator
include/osgGA/NodeTrackerManipulator
+include/osgGA/SphericalManipulator
include/osgGA/StateSetManipulator
include/osgGA/TerrainManipulator
include/osgGA/TrackballManipulator
@@ -567,11 +579,13 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgtgz.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgviewer.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgvolume.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgwidget.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_p3d.so
%%PDF%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_pdf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pic.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_ply.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_png.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pnm.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_revisions.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_rgb.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_rot.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_scale.so
@@ -590,6 +604,22 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_vtf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_x.so
%%XINE%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_xine.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_zip.so
+libdata/pkgconfig/openscenegraph-osg.pc
+libdata/pkgconfig/openscenegraph-osgAnimation.pc
+libdata/pkgconfig/openscenegraph-osgDB.pc
+libdata/pkgconfig/openscenegraph-osgFX.pc
+libdata/pkgconfig/openscenegraph-osgGA.pc
+libdata/pkgconfig/openscenegraph-osgIntrospection.pc
+libdata/pkgconfig/openscenegraph-osgManipulator.pc
+libdata/pkgconfig/openscenegraph-osgParticle.pc
+libdata/pkgconfig/openscenegraph-osgShadow.pc
+libdata/pkgconfig/openscenegraph-osgSim.pc
+libdata/pkgconfig/openscenegraph-osgTerrain.pc
+libdata/pkgconfig/openscenegraph-osgText.pc
+libdata/pkgconfig/openscenegraph-osgUtil.pc
+libdata/pkgconfig/openscenegraph-osgViewer.pc
+libdata/pkgconfig/openscenegraph-osgVolume.pc
+libdata/pkgconfig/openscenegraph-osgWidget.pc
libdata/pkgconfig/openscenegraph.pc
libdata/pkgconfig/openthreads.pc
@dirrm lib/osgPlugins-%%OSG_VERSION%%