aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-01 02:49:36 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-04-01 02:49:36 +0000
commit13d22411793c9d7a16ed25440d278e54868cd231 (patch)
tree66e5f13c7c3af656cffd237357e070ce58929159 /graphics/osg
parentd8b469805f55d02945510c32a1190aed04eef3cf (diff)
downloadports-13d22411793c9d7a16ed25440d278e54868cd231.tar.gz
ports-13d22411793c9d7a16ed25440d278e54868cd231.zip
Notes
Diffstat (limited to 'graphics/osg')
-rw-r--r--graphics/osg/Makefile82
-rw-r--r--graphics/osg/distinfo6
-rw-r--r--graphics/osg/files/patch-CMakeLists.txt20
-rw-r--r--graphics/osg/files/patch-src-OpenThreads-CMakeLists.txt8
-rw-r--r--graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++31
-rw-r--r--graphics/osg/files/patch-src-osgViewer-CMakeLists.txt20
-rw-r--r--graphics/osg/pkg-plist72
7 files changed, 196 insertions, 43 deletions
diff --git a/graphics/osg/Makefile b/graphics/osg/Makefile
index c6c6a76e1ffe..61ff1650be6c 100644
--- a/graphics/osg/Makefile
+++ b/graphics/osg/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= osg
-PORTVERSION= 2.6.1
-PORTREVISION= 3
+PORTVERSION= 2.8.0
CATEGORIES= graphics
-MASTER_SITES= http://www.openscenegraph.org/downloads/developer_releases/ \
+MASTER_SITES= http://www.openscenegraph.org/downloads/stable_releases/OpenSceneGraph-${PORTVERSION:C/\.[0-9]$//}/source/ \
http://mirror.amdmi3.ru/
DISTNAME= OpenSceneGraph-${PORTVERSION}
@@ -20,16 +19,19 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
+CONFLICTS= osg-devel-[0-9]*
+
USE_ZIP= yes
USE_CMAKE= yes
USE_GL= gl glu
USE_GNOME= pkgconfig
USE_XORG= x11
USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
PLIST_SUB= OSG_VERSION=${PORTVERSION} \
- OSG_SHLIBVER=48 \
- OPENTHREADS_VERSION=2.3.0 \
+ OSG_SHLIBVER=55 \
+ OPENTHREADS_VERSION=2.4.0 \
OPENTHREADS_SHLIBVER=11
PORTSCOUT= limitw:1,even
@@ -41,19 +43,23 @@ OPTIONS= CURL "Support for cURL" off \
INVENTOR "Support for SGI OpenInventor" off \
JASPER "Support for JPEG2000" off \
XINE "Support for Xine" off \
+ ITK "Support for InsightToolkit" off \
+ VNC "Support for LibVNCServer" off \
+ OPENEXR "Support for OpenEXR" off \
SVG "Support for SVG through librsvg2" off \
+ PDF "Support for PDF through poppler" off \
XRANDR "Use Xrandr" on
-# broken
-# OPENVRML "Support for OpenVRML" off \
+# broken (openvrml from ports is too old)
+# OPENVRML "Support for OpenVRML" off
.include <bsd.port.pre.mk>
# GUI toolkits are only needed for building examples, which are not even installed
-FORCE_IGNORE= FLTK GLUT SDL FOX Qt3 Qt4 wxWidgets # only needed for examples
-FORCE_IGNORE+= COLLADA Performer # not in ports (yet?)
+FORCE_IGNORE= FLTK GLUT SDL FOX Qt3 Qt4 wxWidgets # only for examples
+FORCE_IGNORE+= COLLADA Performer OurDCMTK XUL # not in ports
FORCE_REQUIRE= Threads OpenGL X11 JPEG PNG TIFF ZLIB # common & lightweight
-FORCE_PC_IGNORE= GTK GTKGL # only needed for examples
+FORCE_PC_IGNORE= GTK GTKGL # only for examples
FORCE_PC_REQUIRE=
# options that affect FIND_PACKAGE
@@ -130,17 +136,61 @@ FORCE_IGNORE+= Xine
PLIST_SUB+= XINE="@comment "
.endif
+.if defined(WITH_ITK)
+FORCE_REQUIRE+= ITK
+BUILD_DEPENDS+= ${LOCALBASE}/lib/InsightToolkit/UseITK.cmake:${PORTSDIR}/science/InsightToolkit
+RUN_DEPENDS+= ${LOCALBASE}/lib/InsightToolkit/UseITK.cmake:${PORTSDIR}/science/InsightToolkit
+PLIST_SUB+= ITK=""
+CXXFLAGS+= -DVCL_CAN_STATIC_CONST_INIT_FLOAT=0
+.else
+FORCE_IGNORE+= ITK
+PLIST_SUB+= ITK="@comment "
+.endif
+
+.if defined(WITH_VNC)
+FORCE_REQUIRE+= LibVNCServer
+LIB_DEPENDS+= vncserver.0:${PORTSDIR}/net/libvncserver
+PLIST_SUB+= VNC=""
+.else
+FORCE_IGNORE+= LibVNCServer
+PLIST_SUB+= VNC="@comment "
+.endif
+
+.if defined(WITH_OPENEXR)
+FORCE_REQUIRE+= OpenEXR
+LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+PLIST_SUB+= OPENEXR=""
+.else
+FORCE_IGNORE+= OpenEXR
+PLIST_SUB+= OPENEXR="@comment "
+.endif
+
# options that affect PKG_CHECK_MODULES
.if defined(WITH_SVG)
-FORCE_PC_REQUIRE+=RSVG CAIRO
-LIB_DEPENDS+= rsvg-2:${PORTSDIR}/graphics/librsvg2 \
- cairo.2:${PORTSDIR}/graphics/cairo
+FORCE_PC_REQUIRE+=RSVG
+LIB_DEPENDS+= rsvg-2:${PORTSDIR}/graphics/librsvg2
PLIST_SUB+= SVG=""
.else
-FORCE_PC_IGNORE+=RSVG CAIRO
+FORCE_PC_IGNORE+=RSVG
PLIST_SUB+= SVG="@comment "
.endif
+.if defined(WITH_PDF)
+FORCE_PC_REQUIRE+=POPPLER
+LIB_DEPENDS+= poppler-glib.3:${PORTSDIR}/graphics/poppler-gtk
+PLIST_SUB+= PDF=""
+.else
+FORCE_PC_IGNORE+=POPPLER
+PLIST_SUB+= PDF="@comment "
+.endif
+
+.if defined(WITH_SVG) || defined(WITH_PDF)
+FORCE_PC_REQUIRE+=CAIRO
+LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
+.else
+FORCE_PC_IGNORE+=CAIRO
+.endif
+
# other options
.if defined(WITHOUT_XRANDR)
CMAKE_ARGS+= -DOSGVIEWER_USE_XRANDR:BOOL=OFF
@@ -150,10 +200,6 @@ USE_XORG+= xrandr
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|"64"|""|' ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e 's|cpu_set_t|cpuset_t|g' \
- ${WRKSRC}/src/OpenThreads/pthreads/CMakeLists.txt \
- ${WRKSRC}/src/OpenThreads/pthreads/PThread.c++
.for p in ${FORCE_REQUIRE}
@${REINPLACE_CMD} -e '/FIND_PACKAGE.*${p}/ s|)$$| REQUIRED&|' \
${WRKSRC}/CMakeLists.txt
diff --git a/graphics/osg/distinfo b/graphics/osg/distinfo
index 67eea1af68e2..2748f590d3b5 100644
--- a/graphics/osg/distinfo
+++ b/graphics/osg/distinfo
@@ -1,3 +1,3 @@
-MD5 (OpenSceneGraph-2.6.1.zip) = 0955d92af64e48d2bdda464103962f92
-SHA256 (OpenSceneGraph-2.6.1.zip) = 4eb0765f168fe136e97539a90e25556b2cdfa52e3309697cf82159c51e43b096
-SIZE (OpenSceneGraph-2.6.1.zip) = 5849143
+MD5 (OpenSceneGraph-2.8.0.zip) = c4c20b97274346701f6d57eab3e78bcd
+SHA256 (OpenSceneGraph-2.8.0.zip) = c776dbaa06510ad395ef075f2a9e08e1ae07dba9543b7c75f6842080335953e6
+SIZE (OpenSceneGraph-2.8.0.zip) = 6456765
diff --git a/graphics/osg/files/patch-CMakeLists.txt b/graphics/osg/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..e7dc6a6dce0d
--- /dev/null
+++ b/graphics/osg/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2009-01-29 16:29:08.000000000 +0300
++++ CMakeLists.txt 2009-02-05 17:45:24.000000000 +0300
+@@ -459,7 +459,7 @@
+
+ IF(UNIX AND NOT WIN32 AND NOT APPLE)
+ IF(CMAKE_SIZEOF_VOID_P MATCHES "8")
+- SET(LIB_POSTFIX "64" CACHE STRING "suffix for 32/64 dir placement")
++ SET(LIB_POSTFIX "" CACHE STRING "suffix for 32/64 dir placement")
+ MARK_AS_ADVANCED(LIB_POSTFIX)
+ ENDIF(CMAKE_SIZEOF_VOID_P MATCHES "8")
+ ENDIF(UNIX AND NOT WIN32 AND NOT APPLE)
+@@ -766,7 +766,7 @@
+ @ONLY
+ )
+
+-INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/openscenegraph.pc DESTINATION lib${LIB_POSTFIX}/pkgconfig COMPONENT libopenscenegraph-dev)
++INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/openscenegraph.pc DESTINATION libdata/pkgconfig COMPONENT libopenscenegraph-dev)
+
+ # Run this as late as possible so users can easier spot the message
+ IF (${CMAKE_INSTALL_PREFIX} STREQUAL "/usr/local")
diff --git a/graphics/osg/files/patch-src-OpenThreads-CMakeLists.txt b/graphics/osg/files/patch-src-OpenThreads-CMakeLists.txt
new file mode 100644
index 000000000000..675ef5a726a0
--- /dev/null
+++ b/graphics/osg/files/patch-src-OpenThreads-CMakeLists.txt
@@ -0,0 +1,8 @@
+--- src/OpenThreads/CMakeLists.txt.orig 2009-01-27 18:34:57.000000000 +0300
++++ src/OpenThreads/CMakeLists.txt 2009-02-05 17:54:57.000000000 +0300
+@@ -94,4 +94,4 @@
+ @ONLY
+ )
+
+-INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/openthreads.pc DESTINATION lib${LIB_POSTFIX}/pkgconfig)
++INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/openthreads.pc DESTINATION libdata/pkgconfig)
diff --git a/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++ b/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++
index 351452e25e7c..d1997c322f3f 100644
--- a/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++
+++ b/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++
@@ -1,5 +1,5 @@
---- src/OpenThreads/pthreads/PThread.c++.orig 2008-09-25 18:28:42.000000000 +0400
-+++ src/OpenThreads/pthreads/PThread.c++ 2008-09-25 18:52:13.000000000 +0400
+--- src/OpenThreads/pthreads/PThread.c++.orig 2008-11-05 13:27:49.000000000 +0300
++++ src/OpenThreads/pthreads/PThread.c++ 2009-02-04 18:06:28.000000000 +0300
@@ -21,6 +21,7 @@
#include <sys/types.h>
#include <unistd.h>
@@ -8,3 +8,30 @@
#if defined __linux || defined __sun || defined __APPLE__
#include <string.h>
+@@ -125,7 +126,7 @@
+ #if defined(__sgi)
+ pthread_setrunon_np( pd->cpunum );
+ #elif defined(HAVE_PTHREAD_SETAFFINITY_NP) || defined(HAVE_THREE_PARAM_SCHED_SETAFFINITY) || defined(HAVE_TWO_PARAM_SCHED_SETAFFINITY)
+- cpu_set_t cpumask;
++ cpuset_t cpumask;
+ CPU_ZERO( &cpumask );
+ CPU_SET( pd->cpunum, &cpumask );
+
+@@ -541,7 +542,7 @@
+
+ if (pd->isRunning && Thread::CurrentThread()==this)
+ {
+- cpu_set_t cpumask;
++ cpuset_t cpumask;
+ CPU_ZERO( &cpumask );
+ CPU_SET( pd->cpunum, &cpumask );
+ #if defined(HAVE_PTHREAD_SETAFFINITY_NP)
+@@ -975,7 +976,7 @@
+ else
+ {
+ #if defined(HAVE_PTHREAD_SETAFFINITY_NP) || defined(HAVE_THREE_PARAM_SCHED_SETAFFINITY) || defined(HAVE_TWO_PARAM_SCHED_SETAFFINITY)
+- cpu_set_t cpumask;
++ cpuset_t cpumask;
+ CPU_ZERO( &cpumask );
+ CPU_SET( cpunum, &cpumask );
+
diff --git a/graphics/osg/files/patch-src-osgViewer-CMakeLists.txt b/graphics/osg/files/patch-src-osgViewer-CMakeLists.txt
deleted file mode 100644
index d42acffd81c7..000000000000
--- a/graphics/osg/files/patch-src-osgViewer-CMakeLists.txt
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/osgViewer/CMakeLists.txt.orig 2008-08-05 19:32:03.000000000 +0400
-+++ src/osgViewer/CMakeLists.txt 2009-02-09 23:35:48.000000000 +0300
-@@ -78,7 +78,6 @@
- SET(LIB_PUBLIC_HEADERS ${LIB_PUBLIC_HEADERS}
- ${HEADER_PATH}/api/X11/GraphicsWindowX11
- ${HEADER_PATH}/api/X11/PixelBufferX11
-- ${XRANDR_INCLUDE_DIRS}
- )
- SET(LIB_COMMON_FILES ${LIB_COMMON_FILES}
- GraphicsWindowX11.cpp
-@@ -89,8 +88,7 @@
- INCLUDE(FindPkgConfig)
- PKG_CHECK_MODULES(XRANDR REQUIRED xrandr)
- ADD_DEFINITIONS(-DOSGVIEWER_USE_XRANDR)
-- SET(LIB_PUBLIC_HEADERS ${LIB_PUBLIC_HEADERS} ${XRANDR_INCLUDE_DIRS})
-- LINK_LIBRARIES(Xrandr)
-+ LINK_LIBRARIES(${XRANDR_LDFLAGS})
- ENDIF(OSGVIEWER_USE_XRANDR)
-
- # X11 on Apple requires X11 library plus OpenGL linking hack on Leopard
diff --git a/graphics/osg/pkg-plist b/graphics/osg/pkg-plist
index 07166d65e7d8..072228684a24 100644
--- a/graphics/osg/pkg-plist
+++ b/graphics/osg/pkg-plist
@@ -76,6 +76,7 @@ include/osg/Hint
include/osg/Image
include/osg/ImageSequence
include/osg/ImageStream
+include/osg/ImageUtils
include/osg/KdTree
include/osg/LOD
include/osg/Light
@@ -177,8 +178,31 @@ include/osg/fast_back_stack
include/osg/io_utils
include/osg/observer_ptr
include/osg/ref_ptr
+include/osgAnimation/Animation
+include/osgAnimation/AnimationManagerBase
+include/osgAnimation/Assert
+include/osgAnimation/BasicAnimationManager
+include/osgAnimation/Bone
+include/osgAnimation/Channel
+include/osgAnimation/CubicBezier
+include/osgAnimation/EaseMotion
+include/osgAnimation/Export
+include/osgAnimation/Interpolator
+include/osgAnimation/Keyframe
+include/osgAnimation/LinkVisitor
+include/osgAnimation/RigGeometry
+include/osgAnimation/Sampler
+include/osgAnimation/Skeleton
+include/osgAnimation/Skinning
+include/osgAnimation/Target
+include/osgAnimation/Timeline
+include/osgAnimation/TimelineAnimationManager
+include/osgAnimation/UpdateCallback
+include/osgAnimation/Vec3Packed
+include/osgAnimation/VertexInfluence
include/osgDB/Archive
include/osgDB/AuthenticationMap
+include/osgDB/ConvertUTF
include/osgDB/DatabasePager
include/osgDB/DotOsgWrapper
include/osgDB/DynamicLibrary
@@ -186,6 +210,7 @@ include/osgDB/Export
include/osgDB/Field
include/osgDB/FieldReader
include/osgDB/FieldReaderIterator
+include/osgDB/FileCache
include/osgDB/FileNameUtils
include/osgDB/FileUtils
include/osgDB/ImageOptions
@@ -197,9 +222,11 @@ include/osgDB/PluginQuery
include/osgDB/ReadFile
include/osgDB/ReaderWriter
include/osgDB/Registry
+include/osgDB/Serializer
include/osgDB/SharedStateManager
include/osgDB/Version
include/osgDB/WriteFile
+include/osgDB/fstream
include/osgFX/AnisotropicLighting
include/osgFX/BumpMapping
include/osgFX/Cartoon
@@ -213,6 +240,7 @@ include/osgFX/Technique
include/osgFX/Validator
include/osgFX/Version
include/osgGA/AnimationPathManipulator
+include/osgGA/CameraViewSwitchManipulator
include/osgGA/DriveManipulator
include/osgGA/EventQueue
include/osgGA/EventVisitor
@@ -291,16 +319,25 @@ include/osgParticle/SmokeTrailEffect
include/osgParticle/VariableRateCounter
include/osgParticle/Version
include/osgParticle/range
+include/osgShadow/ConvexPolyhedron
+include/osgShadow/DebugShadowMap
include/osgShadow/Export
+include/osgShadow/LightSpacePerspectiveShadowMap
+include/osgShadow/MinimalCullBoundsShadowMap
+include/osgShadow/MinimalDrawBoundsShadowMap
+include/osgShadow/MinimalShadowMap
include/osgShadow/OccluderGeometry
include/osgShadow/ParallelSplitShadowMap
+include/osgShadow/ProjectionShadowMap
include/osgShadow/ShadowMap
include/osgShadow/ShadowTechnique
include/osgShadow/ShadowTexture
include/osgShadow/ShadowVolume
include/osgShadow/ShadowedScene
include/osgShadow/SoftShadowMap
+include/osgShadow/StandardShadowMap
include/osgShadow/Version
+include/osgShadow/ViewDependentShadowTechnique
include/osgSim/BlinkSequence
include/osgSim/ColorRange
include/osgSim/DOFTransform
@@ -395,7 +432,18 @@ include/osgViewer/ViewerBase
include/osgViewer/ViewerEventHandlers
include/osgViewer/api/X11/GraphicsWindowX11
include/osgViewer/api/X11/PixelBufferX11
+include/osgVolume/Export
+include/osgVolume/FixedFunctionTechnique
+include/osgVolume/Layer
+include/osgVolume/Locator
+include/osgVolume/Property
+include/osgVolume/RayTracedTechnique
+include/osgVolume/Version
+include/osgVolume/Volume
+include/osgVolume/VolumeTechnique
+include/osgVolume/VolumeTile
include/osgWidget/Box
+include/osgWidget/Browser
include/osgWidget/Canvas
include/osgWidget/EventInterface
include/osgWidget/Export
@@ -403,6 +451,7 @@ include/osgWidget/Frame
include/osgWidget/Input
include/osgWidget/Label
include/osgWidget/Lua
+include/osgWidget/PdfReader
include/osgWidget/Python
include/osgWidget/ScriptEngine
include/osgWidget/StyleInterface
@@ -413,6 +462,7 @@ include/osgWidget/UIObjectParent
include/osgWidget/Util
include/osgWidget/Version
include/osgWidget/ViewerEventHandlers
+include/osgWidget/VncClient
include/osgWidget/Widget
include/osgWidget/Window
include/osgWidget/WindowManager
@@ -422,6 +472,9 @@ lib/libOpenThreads.so.%%OPENTHREADS_SHLIBVER%%
lib/libosg.so
lib/libosg.so.%%OSG_VERSION%%
lib/libosg.so.%%OSG_SHLIBVER%%
+lib/libosgAnimation.so
+lib/libosgAnimation.so.%%OSG_VERSION%%
+lib/libosgAnimation.so.%%OSG_SHLIBVER%%
lib/libosgDB.so
lib/libosgDB.so.%%OSG_VERSION%%
lib/libosgDB.so.%%OSG_SHLIBVER%%
@@ -455,6 +508,9 @@ lib/libosgUtil.so.%%OSG_SHLIBVER%%
lib/libosgViewer.so
lib/libosgViewer.so.%%OSG_VERSION%%
lib/libosgViewer.so.%%OSG_SHLIBVER%%
+lib/libosgVolume.so
+lib/libosgVolume.so.%%OSG_VERSION%%
+lib/libosgVolume.so.%%OSG_SHLIBVER%%
lib/libosgWidget.so
lib/libosgWidget.so.%%OSG_VERSION%%
lib/libosgWidget.so.%%OSG_SHLIBVER%%
@@ -462,16 +518,22 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_3dc.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_3ds.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_ac.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_bmp.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_bsp.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_bvh.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_cfg.so
%%CURL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_curl.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dds.so
+%%ITK%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_dicom.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_dot.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dw.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_dxf.so
+%%OPENEXR%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_exr.so
%%FREETYPE%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_freetype.so
%%GDAL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gdal.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_geo.so
%%GIF%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_gif.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_glsl.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_gz.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_hdr.so
%%INVENTOR%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_iv.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_ive.so
@@ -481,12 +543,14 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_logo.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_lwo.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_lws.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_md2.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_mdl.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_normals.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_obj.so
%%GDAL%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_ogr.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_openflight.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osg.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osga.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_osganimation.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgfx.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgparticle.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgshadow.so
@@ -495,7 +559,9 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgterrain.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgtext.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgtgz.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgviewer.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgvolume.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_osgwidget.so
+%%PDF%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_pdf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pic.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_png.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_pnm.so
@@ -511,12 +577,17 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_tiff.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_trans.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_txf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_txp.so
+%%VNC%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_vnc.so
%%OPENVRML%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_vrml.so
+lib/osgPlugins-%%OSG_VERSION%%/osgdb_vtf.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_x.so
%%XINE%%lib/osgPlugins-%%OSG_VERSION%%/osgdb_xine.so
lib/osgPlugins-%%OSG_VERSION%%/osgdb_zip.so
+libdata/pkgconfig/openscenegraph.pc
+libdata/pkgconfig/openthreads.pc
@dirrm lib/osgPlugins-%%OSG_VERSION%%
@dirrm include/osgWidget
+@dirrm include/osgVolume
@dirrm include/osgViewer/api/X11
@dirrm include/osgViewer/api
@dirrm include/osgViewer
@@ -530,5 +601,6 @@ lib/osgPlugins-%%OSG_VERSION%%/osgdb_zip.so
@dirrm include/osgGA
@dirrm include/osgFX
@dirrm include/osgDB
+@dirrm include/osgAnimation
@dirrm include/osg
@dirrm include/OpenThreads