aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Alien-Gimp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-11-04 18:56:26 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-11-04 18:56:26 +0000
commit31418856fac6052ee528f1a375a6703910ad3fe3 (patch)
treef566ebcdfbaec5a848f483ebc697ebcc10e504f4 /graphics/p5-Alien-Gimp
parent2ab2a7e8832e710be242d7517a76a29a04e7e170 (diff)
downloadports-31418856fac6052ee528f1a375a6703910ad3fe3.tar.gz
ports-31418856fac6052ee528f1a375a6703910ad3fe3.zip
Notes
Diffstat (limited to 'graphics/p5-Alien-Gimp')
-rw-r--r--graphics/p5-Alien-Gimp/Makefile11
-rw-r--r--graphics/p5-Alien-Gimp/files/patch-common.pl13
2 files changed, 18 insertions, 6 deletions
diff --git a/graphics/p5-Alien-Gimp/Makefile b/graphics/p5-Alien-Gimp/Makefile
index 5080ba49222b..edd5216e60dd 100644
--- a/graphics/p5-Alien-Gimp/Makefile
+++ b/graphics/p5-Alien-Gimp/Makefile
@@ -10,18 +10,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Encapsulate install info for GIMP
-BROKEN= fails to configure
-
-BUILD_DEPENDS= gimp-app>=0:graphics/gimp-app \
+BUILD_DEPENDS= ${RUN_DEPENDS} \
p5-ExtUtils-Depends>=0.402:devel/p5-ExtUtils-Depends \
p5-ExtUtils-PkgConfig>=0:devel/p5-ExtUtils-PkgConfig \
p5-IO-All>=0:devel/p5-IO-All
-RUN_DEPENDS= gimp-app>=0:graphics/gimp-app
+RUN_DEPENDS= gimp-app>=2.8.0:graphics/gimp-app
TEST_DEPENDS= p5-Inline-C>=0.67:devel/p5-Inline-C \
p5-Inline>=0.78:devel/p5-Inline
-NO_ARCH= yes
-USE_PERL5= configure
USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
.include <bsd.port.mk>
diff --git a/graphics/p5-Alien-Gimp/files/patch-common.pl b/graphics/p5-Alien-Gimp/files/patch-common.pl
new file mode 100644
index 000000000000..75b42c1684a6
--- /dev/null
+++ b/graphics/p5-Alien-Gimp/files/patch-common.pl
@@ -0,0 +1,13 @@
+--- common.pl.orig 2016-05-02 03:41:48 UTC
++++ common.pl
+@@ -10,8 +10,8 @@ my $gimptool = File::Spec->catfile($gimp
+ my ($plugindir, $pluginlibs) = split /\n/, `$gimptool --gimpplugindir --libs`;
+
+ my $gimpbinname = ExtUtils::PkgConfig->modversion("gimp-2.0");
+-$gimpbinname =~ s/^(\d\.\d).*/$1/; # strip off minor versions
+-die "Need GIMP version at least 2.8.0\n" unless $gimpbinname >= 2.8;
++$gimpbinname =~ s/^(\d+\.\d+\.\d+).*/$1/; # strip off minor versions
++die "Need GIMP version at least 2.8.0\n" unless $gimpbinname >= 2.8.0;
+
+ sub ag_getconfig {
+ my %cfg = (