aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-CAD-Drawing-Template/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-22 17:44:08 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-22 17:44:08 +0000
commit08367443576956fec7cc80a52f74f46df2edc206 (patch)
tree647531703f796d12e1897620418422f2a9f47f81 /graphics/p5-CAD-Drawing-Template/Makefile
parented9a86da78dba666b1563a832ece9813947ac26d (diff)
Notes
Diffstat (limited to 'graphics/p5-CAD-Drawing-Template/Makefile')
-rw-r--r--graphics/p5-CAD-Drawing-Template/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/p5-CAD-Drawing-Template/Makefile b/graphics/p5-CAD-Drawing-Template/Makefile
new file mode 100644
index 000000000000..ba35d27588ee
--- /dev/null
+++ b/graphics/p5-CAD-Drawing-Template/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: CAD-Drawing-Template
+# Date created: 22 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CAD-Drawing-Template
+PORTVERSION= 0.01
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CAD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Replace tags with text and geometry
+
+BUILD_DEPENDS= ${SITE_PERL}/CAD/Drawing.pm:${PORTSDIR}/graphics/p5-CAD-Drawing \
+ ${SITE_PERL}/CAD/Calc.pm:${PORTSDIR}/math/p5-CAD-Calc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= CAD::Drawing::Template.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>