aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Chart-PNGgraph
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-25 15:57:14 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-25 15:57:14 +0000
commit1d293a1d2c8033a07e81108207adf2f99b9d3c63 (patch)
treecc7aaac4613006d6d77e2e11281cac8817db17ec /graphics/p5-Chart-PNGgraph
parentaa3b6a0ab39c845a929ecc69125debcc720dd622 (diff)
downloadports-1d293a1d2c8033a07e81108207adf2f99b9d3c63.tar.gz
ports-1d293a1d2c8033a07e81108207adf2f99b9d3c63.zip
Notes
Diffstat (limited to 'graphics/p5-Chart-PNGgraph')
-rw-r--r--graphics/p5-Chart-PNGgraph/Makefile26
-rw-r--r--graphics/p5-Chart-PNGgraph/distinfo1
-rw-r--r--graphics/p5-Chart-PNGgraph/pkg-comment1
-rw-r--r--graphics/p5-Chart-PNGgraph/pkg-descr31
-rw-r--r--graphics/p5-Chart-PNGgraph/pkg-plist13
5 files changed, 72 insertions, 0 deletions
diff --git a/graphics/p5-Chart-PNGgraph/Makefile b/graphics/p5-Chart-PNGgraph/Makefile
new file mode 100644
index 000000000000..3fed7164b7e3
--- /dev/null
+++ b/graphics/p5-Chart-PNGgraph/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Chart-PNGgraph
+# Version required: 1.13
+# Date Created: 15 December 1999
+# Whom: Garrett Wollman <wollman@lcs.mit.edu>
+#
+# $FreeBSD$
+#
+
+DISTNAME= Chart-PNGgraph-1.13
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Chart
+
+MAINTAINER= ports@freebsd.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/i386-freebsd/GD.pm:${PORTSDIR}/graphics/p5-GD
+
+USE_PERL5= YES
+
+MAN3= Chart::PNGgraph.3 Chart::PNGgraph::colour.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Chart-PNGgraph/distinfo b/graphics/p5-Chart-PNGgraph/distinfo
new file mode 100644
index 000000000000..140eb68ad882
--- /dev/null
+++ b/graphics/p5-Chart-PNGgraph/distinfo
@@ -0,0 +1 @@
+MD5 (Chart-PNGgraph-1.13.tar.gz) = dbf22d8b60edd78f5a24e83febbe2dd6
diff --git a/graphics/p5-Chart-PNGgraph/pkg-comment b/graphics/p5-Chart-PNGgraph/pkg-comment
new file mode 100644
index 000000000000..4e8b570847a1
--- /dev/null
+++ b/graphics/p5-Chart-PNGgraph/pkg-comment
@@ -0,0 +1 @@
+A Perl module for generating presentation graphics (i.e., charts)
diff --git a/graphics/p5-Chart-PNGgraph/pkg-descr b/graphics/p5-Chart-PNGgraph/pkg-descr
new file mode 100644
index 000000000000..b1175180bd4c
--- /dev/null
+++ b/graphics/p5-Chart-PNGgraph/pkg-descr
@@ -0,0 +1,31 @@
+Chart::PNGgraph is a perl5 module to create and display
+PNG output for a graph. The following classes for graphs
+with axes are defined:
+
+Chart::PNGgraph::lines
+ Create a line chart.
+
+Chart::PNGgraph::bars
+ Create a bar chart.
+
+Chart::PNGgraph::points
+ Create an chart, displaying the data as points.
+
+Chart::PNGgraph::linespoints
+ Combination of lines and points.
+
+Chart::PNGgraph::area
+ Create a graph, representing the data as areas under a
+ line.
+
+Chart::PNGgraph::mixed
+ Create a mixed type graph, any combination of the
+ above. At the moment this is fairly limited. Some of
+ the options that can be used with some of the
+ individual graph types won't work very well. Multiple
+ bar graphs in a mixed graph won't display very nicely.
+
+Additional types:
+
+Chart::PNGgraph::pie
+ Create a pie chart.
diff --git a/graphics/p5-Chart-PNGgraph/pkg-plist b/graphics/p5-Chart-PNGgraph/pkg-plist
new file mode 100644
index 000000000000..a920b548f4ed
--- /dev/null
+++ b/graphics/p5-Chart-PNGgraph/pkg-plist
@@ -0,0 +1,13 @@
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph/linespoints.pm
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph/bars.pm
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph/area.pm
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph/lines.pm
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph/points.pm
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph/pie.pm
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph/utils.pm
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph/axestype.pm
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph/colour.pm
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph/mixed.pm
+lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Chart/PNGgraph
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Chart