aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Color-Library
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2009-04-12 17:09:35 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2009-04-12 17:09:35 +0000
commit4071a307f3732980d33b78b1afb860a9be51f886 (patch)
tree3387e1f1eea15bd0ce7adaf41636ddd70080242d /graphics/p5-Color-Library
parent625431c7a379911ea25dfcd1cf32b46d5059e740 (diff)
Notes
Diffstat (limited to 'graphics/p5-Color-Library')
-rw-r--r--graphics/p5-Color-Library/Makefile44
-rw-r--r--graphics/p5-Color-Library/distinfo3
-rw-r--r--graphics/p5-Color-Library/pkg-descr5
-rw-r--r--graphics/p5-Color-Library/pkg-plist32
4 files changed, 84 insertions, 0 deletions
diff --git a/graphics/p5-Color-Library/Makefile b/graphics/p5-Color-Library/Makefile
new file mode 100644
index 000000000000..db4356fd541b
--- /dev/null
+++ b/graphics/p5-Color-Library/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: graphics/p5-Color-Library
+# Date created: 2009/04/10
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Color-Library
+PORTVERSION= 0.02
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= An easy-to-use and comprehensive named-color library
+
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Color::Library.3 Color::Library::Color.3 Color::Library::Dictionary.3 \
+ Color::Library::Dictionary::HTML.3 Color::Library::Dictionary::IE.3 \
+ Color::Library::Dictionary::Mozilla.3 \
+ Color::Library::Dictionary::NBS_ISCC.3 \
+ Color::Library::Dictionary::NBS_ISCC::A.3 \
+ Color::Library::Dictionary::NBS_ISCC::B.3 \
+ Color::Library::Dictionary::NBS_ISCC::F.3 \
+ Color::Library::Dictionary::NBS_ISCC::H.3 \
+ Color::Library::Dictionary::NBS_ISCC::M.3 \
+ Color::Library::Dictionary::NBS_ISCC::P.3 \
+ Color::Library::Dictionary::NBS_ISCC::R.3 \
+ Color::Library::Dictionary::NBS_ISCC::RC.3 \
+ Color::Library::Dictionary::NBS_ISCC::S.3 \
+ Color::Library::Dictionary::NBS_ISCC::SC.3 \
+ Color::Library::Dictionary::NBS_ISCC::TC.3 \
+ Color::Library::Dictionary::Netscape.3 \
+ Color::Library::Dictionary::SVG.3 Color::Library::Dictionary::Tango.3 \
+ Color::Library::Dictionary::VACCC.3 Color::Library::Dictionary::WWW.3 \
+ Color::Library::Dictionary::Windows.3 Color::Library::Dictionary::X11.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Color-Library/distinfo b/graphics/p5-Color-Library/distinfo
new file mode 100644
index 000000000000..cfde2047a6cf
--- /dev/null
+++ b/graphics/p5-Color-Library/distinfo
@@ -0,0 +1,3 @@
+MD5 (Color-Library-0.02.tar.gz) = 3d9e519a836aa0a438076ab04c61e31f
+SHA256 (Color-Library-0.02.tar.gz) = 9b65e287e092727020e92611bd5581d4a54358b4727be7c001af58f7a2cdd9e0
+SIZE (Color-Library-0.02.tar.gz) = 352195
diff --git a/graphics/p5-Color-Library/pkg-descr b/graphics/p5-Color-Library/pkg-descr
new file mode 100644
index 000000000000..f98f5796b38c
--- /dev/null
+++ b/graphics/p5-Color-Library/pkg-descr
@@ -0,0 +1,5 @@
+Color::Library is an easy-to-use and comprehensive named-color dictionary.
+Currently provides coverage for www (svg, html, css) colors, x11 colors, and
+more.
+
+WWW: http://search.cpan.org/dist/Color-Library/
diff --git a/graphics/p5-Color-Library/pkg-plist b/graphics/p5-Color-Library/pkg-plist
new file mode 100644
index 000000000000..66f707b4cd97
--- /dev/null
+++ b/graphics/p5-Color-Library/pkg-plist
@@ -0,0 +1,32 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Color/Library/.packlist
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/P.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/R.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/A.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/TC.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/H.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/F.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/B.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/S.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/M.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/RC.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC/SC.pm
+%%SITE_PERL%%/Color/Library/Dictionary/X11.pm
+%%SITE_PERL%%/Color/Library/Dictionary/Mozilla.pm
+%%SITE_PERL%%/Color/Library/Dictionary/VACCC.pm
+%%SITE_PERL%%/Color/Library/Dictionary/SVG.pm
+%%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC.pm
+%%SITE_PERL%%/Color/Library/Dictionary/IE.pm
+%%SITE_PERL%%/Color/Library/Dictionary/Windows.pm
+%%SITE_PERL%%/Color/Library/Dictionary/Tango.pm
+%%SITE_PERL%%/Color/Library/Dictionary/WWW.pm
+%%SITE_PERL%%/Color/Library/Dictionary/Netscape.pm
+%%SITE_PERL%%/Color/Library/Dictionary/HTML.pm
+%%SITE_PERL%%/Color/Library/Dictionary.pm
+%%SITE_PERL%%/Color/Library/Color.pm
+%%SITE_PERL%%/Color/Library.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Color/Library
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Color
+@dirrmtry %%SITE_PERL%%/Color/Library/Dictionary/NBS_ISCC
+@dirrmtry %%SITE_PERL%%/Color/Library/Dictionary
+@dirrmtry %%SITE_PERL%%/Color/Library
+@dirrmtry %%SITE_PERL%%/Color