aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-GD-Barcode
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-05-28 12:50:24 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-05-28 12:50:24 +0000
commitbc4f1b78103f2bc22a8203bcf6d4406d1a97b757 (patch)
treed2c17a5504ef37ef261e603756f569cc72470759 /graphics/p5-GD-Barcode
parent4f30acd4124e608a359fb75567f10b236fd3a57e (diff)
downloadports-bc4f1b78103f2bc22a8203bcf6d4406d1a97b757.tar.gz
ports-bc4f1b78103f2bc22a8203bcf6d4406d1a97b757.zip
Notes
Diffstat (limited to 'graphics/p5-GD-Barcode')
-rw-r--r--graphics/p5-GD-Barcode/Makefile36
-rw-r--r--graphics/p5-GD-Barcode/distinfo1
-rw-r--r--graphics/p5-GD-Barcode/pkg-comment1
-rw-r--r--graphics/p5-GD-Barcode/pkg-descr2
-rw-r--r--graphics/p5-GD-Barcode/pkg-plist16
5 files changed, 56 insertions, 0 deletions
diff --git a/graphics/p5-GD-Barcode/Makefile b/graphics/p5-GD-Barcode/Makefile
new file mode 100644
index 000000000000..424a310ee0ec
--- /dev/null
+++ b/graphics/p5-GD-Barcode/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-GD-Barcode
+# Date created: May 28 2001
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= GD-Barcode
+PORTVERSION= 1.13
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= GD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${LOCALBASE}/lib/perl5/${PERL_VERSION}
+MAN3= GD::Barcode.3 \
+ GD::Barcode::COOP2of5.3 \
+ GD::Barcode::Code39.3 \
+ GD::Barcode::EAN13.3 \
+ GD::Barcode::EAN8.3 \
+ GD::Barcode::IATA2of5.3 \
+ GD::Barcode::ITF.3 \
+ GD::Barcode::Industrial2of5.3 \
+ GD::Barcode::Matrix2of5.3 \
+ GD::Barcode::NW7.3 \
+ GD::Barcode::UPCA.3 \
+ GD::Barcode::UPCE.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-GD-Barcode/distinfo b/graphics/p5-GD-Barcode/distinfo
new file mode 100644
index 000000000000..329bb8745bf7
--- /dev/null
+++ b/graphics/p5-GD-Barcode/distinfo
@@ -0,0 +1 @@
+MD5 (GD-Barcode-1.13.tar.gz) = 52589c35c555af4948d79b49781e7e0c
diff --git a/graphics/p5-GD-Barcode/pkg-comment b/graphics/p5-GD-Barcode/pkg-comment
new file mode 100644
index 000000000000..1f00afd3e09d
--- /dev/null
+++ b/graphics/p5-GD-Barcode/pkg-comment
@@ -0,0 +1 @@
+GD::Barcode - Create barcode image with GD
diff --git a/graphics/p5-GD-Barcode/pkg-descr b/graphics/p5-GD-Barcode/pkg-descr
new file mode 100644
index 000000000000..419dbfe33e9b
--- /dev/null
+++ b/graphics/p5-GD-Barcode/pkg-descr
@@ -0,0 +1,2 @@
+GD::Barcode is a subclass of GD and allows you to create barcode image with GD.
+This module based on "Generate Barcode Ver 1.02 By Shisei Hanai 97/08/22".
diff --git a/graphics/p5-GD-Barcode/pkg-plist b/graphics/p5-GD-Barcode/pkg-plist
new file mode 100644
index 000000000000..78a329ac6495
--- /dev/null
+++ b/graphics/p5-GD-Barcode/pkg-plist
@@ -0,0 +1,16 @@
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/COOP2of5.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/Code39.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/EAN13.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/EAN8.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/IATA2of5.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/ITF.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/Industrial2of5.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/Matrix2of5.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/NW7.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/UPCA.pm
+lib/perl5/site_perl/%%PERL_VER%%/GD/Barcode/UPCE.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/Barcode/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GD/Barcode
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Barcode 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/GD 2>/dev/null || true