aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-GD-SVG
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-11-26 00:03:17 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-11-26 00:03:17 +0000
commit9edb6f5e2e8dd0d83f7bbdab060119e04d86a111 (patch)
tree05133e9819e393f5c1cfee981e96b5dce1414a5a /graphics/p5-GD-SVG
parent3a248ed61ebeafe04c1fc59af7817db505f69170 (diff)
downloadports-9edb6f5e2e8dd0d83f7bbdab060119e04d86a111.tar.gz
ports-9edb6f5e2e8dd0d83f7bbdab060119e04d86a111.zip
Notes
Diffstat (limited to 'graphics/p5-GD-SVG')
-rw-r--r--graphics/p5-GD-SVG/Makefile27
-rw-r--r--graphics/p5-GD-SVG/distinfo2
-rw-r--r--graphics/p5-GD-SVG/pkg-descr5
-rw-r--r--graphics/p5-GD-SVG/pkg-plist5
4 files changed, 39 insertions, 0 deletions
diff --git a/graphics/p5-GD-SVG/Makefile b/graphics/p5-GD-SVG/Makefile
new file mode 100644
index 000000000000..e95fe67ed77a
--- /dev/null
+++ b/graphics/p5-GD-SVG/Makefile
@@ -0,0 +1,27 @@
+# vim:ts=8
+# New ports collection makefile for: p5-GD-SVG
+# Date created: 25 November 2004
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GD-SVG
+PORTVERSION= 0.25
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= GD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= Seamlessly enable SVG output from scripts written using GD
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
+ ${SITE_PERL}/SVG.pm:${PORTSDIR}/textproc/p5-SVG
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
+
+PERL_CONFIGURE= yes
+
+MAN3= GD::SVG.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-GD-SVG/distinfo b/graphics/p5-GD-SVG/distinfo
new file mode 100644
index 000000000000..863374a33d18
--- /dev/null
+++ b/graphics/p5-GD-SVG/distinfo
@@ -0,0 +1,2 @@
+MD5 (GD-SVG-0.25.tar.gz) = 47098a12f5bb4c339fac956318f65d6f
+SIZE (GD-SVG-0.25.tar.gz) = 42668
diff --git a/graphics/p5-GD-SVG/pkg-descr b/graphics/p5-GD-SVG/pkg-descr
new file mode 100644
index 000000000000..08ad15d15170
--- /dev/null
+++ b/graphics/p5-GD-SVG/pkg-descr
@@ -0,0 +1,5 @@
+GD::SVG seamlessly enables the scalable vector graphics (SVG) output
+from scripts written using GD. It accomplishes this by translating GD
+functions into SVG functions.
+
+WWW: http://www2.toddot.net:8081/projects/GD-SVG/
diff --git a/graphics/p5-GD-SVG/pkg-plist b/graphics/p5-GD-SVG/pkg-plist
new file mode 100644
index 000000000000..b0aa6a22e439
--- /dev/null
+++ b/graphics/p5-GD-SVG/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/SVG/.packlist
+%%SITE_PERL%%/GD/SVG.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/SVG
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/GD 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/GD 2>/dev/null || true