aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Geo-Proj4/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-11 02:34:36 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-11 02:34:36 +0000
commitdd0812beb6b04b4be03f1b0967f82e3f1c4bbc9f (patch)
tree8faece26346acf3424ddbe8b5568d6aae502c1d9 /graphics/p5-Geo-Proj4/Makefile
parente7a152f6122264906849b830c8b08e9d0ea1cd4d (diff)
downloadports-dd0812beb6b04b4be03f1b0967f82e3f1c4bbc9f.tar.gz
ports-dd0812beb6b04b4be03f1b0967f82e3f1c4bbc9f.zip
Notes
Diffstat (limited to 'graphics/p5-Geo-Proj4/Makefile')
-rw-r--r--graphics/p5-Geo-Proj4/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/p5-Geo-Proj4/Makefile b/graphics/p5-Geo-Proj4/Makefile
new file mode 100644
index 000000000000..efd0ce284d72
--- /dev/null
+++ b/graphics/p5-Geo-Proj4/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Geo-Proj4
+# Date created: 27 January 2006
+# Whom: Eric Stith
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Proj4
+PORTVERSION= 0.96
+CATEGORIES= graphics devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Geo
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= estith.freebsd.ports@thelunarempire.net
+COMMENT= Perl cartographic projections wrapper for Proj library
+
+LIB_DEPENDS= proj:${PORTSDIR}/graphics/proj
+
+MAN3= Geo::Proj4.3
+CFLAGS+= -I ${PREFIX}/include # XXX - This seems ugly
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>