aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Graph-Easy/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-10-22 09:22:07 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-10-22 09:22:07 +0000
commit0430befc504626556f6db7b7ef025a7204353d39 (patch)
treea8931e39878e59c7a605ab164ce13c6b4fc8c607 /graphics/p5-Graph-Easy/Makefile
parentec2444775c0b299365d797586ff05d4418c769c1 (diff)
downloadports-0430befc504626556f6db7b7ef025a7204353d39.tar.gz
ports-0430befc504626556f6db7b7ef025a7204353d39.zip
Notes
Diffstat (limited to 'graphics/p5-Graph-Easy/Makefile')
-rw-r--r--graphics/p5-Graph-Easy/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/graphics/p5-Graph-Easy/Makefile b/graphics/p5-Graph-Easy/Makefile
new file mode 100644
index 000000000000..69de63d07532
--- /dev/null
+++ b/graphics/p5-Graph-Easy/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: graphics/p5-Graph-Easy
+# Date created: 22 October 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Graph-Easy
+PORTVERSION= 0.30
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Graph
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Render graphs as ASCII, HTML, SVG or Graphviz
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ ${SITE_PERL}/Heap.pm:${PORTSDIR}/devel/p5-Heap
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Graph::Easy.3 \
+ Graph::Easy::As_ascii.3 \
+ Graph::Easy::As_graphviz.3 \
+ Graph::Easy::As_txt.3 \
+ Graph::Easy::Attributes.3 \
+ Graph::Easy::Edge.3 \
+ Graph::Easy::Edge::Cell.3 \
+ Graph::Easy::Group.3 \
+ Graph::Easy::Group::Cell.3 \
+ Graph::Easy::Layout.3 \
+ Graph::Easy::Layout::Path.3 \
+ Graph::Easy::Layout::Scout.3 \
+ Graph::Easy::Node.3 \
+ Graph::Easy::Node::Anon.3 \
+ Graph::Easy::Node::Cell.3 \
+ Graph::Easy::Node::Empty.3 \
+ Graph::Easy::Parser.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>