aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Graph-Writer-GraphViz
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-01 02:41:15 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-01 02:41:15 +0000
commitee67b6cdb7686918ee3bcdef7238ef30de0aca2b (patch)
tree62ae9f78a956fa5475ab1e8518ce47c70e493644 /graphics/p5-Graph-Writer-GraphViz
parent6cf374426f12597cd0a9c68a26808399cd868ac8 (diff)
downloadports-ee67b6cdb7686918ee3bcdef7238ef30de0aca2b.tar.gz
ports-ee67b6cdb7686918ee3bcdef7238ef30de0aca2b.zip
Notes
Diffstat (limited to 'graphics/p5-Graph-Writer-GraphViz')
-rw-r--r--graphics/p5-Graph-Writer-GraphViz/Makefile34
-rw-r--r--graphics/p5-Graph-Writer-GraphViz/distinfo3
-rw-r--r--graphics/p5-Graph-Writer-GraphViz/pkg-descr6
-rw-r--r--graphics/p5-Graph-Writer-GraphViz/pkg-plist7
4 files changed, 50 insertions, 0 deletions
diff --git a/graphics/p5-Graph-Writer-GraphViz/Makefile b/graphics/p5-Graph-Writer-GraphViz/Makefile
new file mode 100644
index 000000000000..1eb6bc910182
--- /dev/null
+++ b/graphics/p5-Graph-Writer-GraphViz/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Graph-Writer-GraphViz
+# Date created: 31 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Graph-Writer-GraphViz
+PORTVERSION= 0.10
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Graph
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= GraphViz Writer for Graph object
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/All.pm:${PORTSDIR}/devel/p5-IO-All \
+ ${SITE_PERL}/GraphViz.pm:${PORTSDIR}/graphics/p5-GraphViz \
+ ${SITE_PERL}/Graph.pm:${PORTSDIR}/math/p5-Graph \
+ ${SITE_PERL}/Graph/Writer.pm:${PORTSDIR}/graphics/p5-Graph-ReadWrite
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Graph::Writer::GraphViz.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= is currently broken under Perl <5.8.0. This will hopefully be fixed soon. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-Graph-Writer-GraphViz/distinfo b/graphics/p5-Graph-Writer-GraphViz/distinfo
new file mode 100644
index 000000000000..bda22c756287
--- /dev/null
+++ b/graphics/p5-Graph-Writer-GraphViz/distinfo
@@ -0,0 +1,3 @@
+MD5 (Graph-Writer-GraphViz-0.10.tar.gz) = 79447e6c364035e95abd407e66d3fc47
+SHA256 (Graph-Writer-GraphViz-0.10.tar.gz) = c8c0ce0de6ce5b08f3045d8965e81f65dfc4f16414c8026a8b42d3d45e55a381
+SIZE (Graph-Writer-GraphViz-0.10.tar.gz) = 9102
diff --git a/graphics/p5-Graph-Writer-GraphViz/pkg-descr b/graphics/p5-Graph-Writer-GraphViz/pkg-descr
new file mode 100644
index 000000000000..a4d5408fd2e3
--- /dev/null
+++ b/graphics/p5-Graph-Writer-GraphViz/pkg-descr
@@ -0,0 +1,6 @@
+Graph::Writer::GraphViz is a class for writing out a Graph object with
+GraphViz module. All GraphViz formats should be supported without a
+problem.
+
+WWW: http://search.cpan.org/dist/Graph-Writer-GraphViz
+Author: Kang-min Liu <gugod@gugod.org>
diff --git a/graphics/p5-Graph-Writer-GraphViz/pkg-plist b/graphics/p5-Graph-Writer-GraphViz/pkg-plist
new file mode 100644
index 000000000000..ec5b332708ea
--- /dev/null
+++ b/graphics/p5-Graph-Writer-GraphViz/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Graph/Writer/GraphViz.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph/Writer/GraphViz/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph/Writer/GraphViz
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph/Writer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Graph
+@dirrmtry %%SITE_PERL%%/Graph/Writer
+@dirrmtry %%SITE_PERL%%/Graph