aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-GraphViz/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-03-07 11:42:30 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-03-07 11:42:30 +0000
commitbfb4cef8d3354004e1d42ca9fdbdb1aca41a9d2f (patch)
tree6a9571cb0c73f7bd710e69b10a0921a2238cf5b9 /graphics/p5-GraphViz/Makefile
parent128176cd54d03dd07fc91551cfee329845e4fa1d (diff)
downloadports-bfb4cef8d3354004e1d42ca9fdbdb1aca41a9d2f.tar.gz
ports-bfb4cef8d3354004e1d42ca9fdbdb1aca41a9d2f.zip
Notes
Diffstat (limited to 'graphics/p5-GraphViz/Makefile')
-rw-r--r--graphics/p5-GraphViz/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/graphics/p5-GraphViz/Makefile b/graphics/p5-GraphViz/Makefile
index 01ce5406f38f..c95061d36fa8 100644
--- a/graphics/p5-GraphViz/Makefile
+++ b/graphics/p5-GraphViz/Makefile
@@ -7,6 +7,7 @@
PORTNAME= GraphViz
PORTVERSION= 2.03
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,10 +15,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= GraphViz - Perl interface to the GraphViz graphing tool
-BUILD_DEPENDS= ${SITE_PERL}/IPC/Run.pm:${PORTSDIR}/devel/p5-IPC-Run \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+RUN_DEPENDS= p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run \
+ p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent \
+ p5-XML-Twig>=0:${PORTSDIR}/textproc/p5-XML-Twig \
dot:${PORTSDIR}/graphics/graphviz
-RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -32,4 +33,10 @@ MAN3= Devel::GraphVizProf.3 \
GraphViz::Small.3 \
GraphViz::XML.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.include <bsd.port.post.mk>