aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-GraphViz2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-09 01:37:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-11-09 01:37:51 +0000
commit8d91c37fd7f7c90bffa0644f5c47144f16e1fe4c (patch)
treeaa3ce07d978bb5a2570b442f8d4c82a4368534d7 /graphics/p5-GraphViz2
parent30f8bdc0a0c2588567730e6ce0d836dbf5a88e6f (diff)
downloadports-8d91c37fd7f7c90bffa0644f5c47144f16e1fe4c.tar.gz
ports-8d91c37fd7f7c90bffa0644f5c47144f16e1fe4c.zip
Notes
Diffstat (limited to 'graphics/p5-GraphViz2')
-rw-r--r--graphics/p5-GraphViz2/Makefile79
-rw-r--r--graphics/p5-GraphViz2/distinfo2
-rw-r--r--graphics/p5-GraphViz2/pkg-descr24
-rw-r--r--graphics/p5-GraphViz2/pkg-plist17
4 files changed, 122 insertions, 0 deletions
diff --git a/graphics/p5-GraphViz2/Makefile b/graphics/p5-GraphViz2/Makefile
new file mode 100644
index 000000000000..c5a66d1723cf
--- /dev/null
+++ b/graphics/p5-GraphViz2/Makefile
@@ -0,0 +1,79 @@
+# New ports collection makefile for: p5-GraphViz2
+# Date created: 2011-07-21
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GraphViz2
+PORTVERSION= 1.11
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:RSAVAGE
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= A wrapper for AT&T Graphviz
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/dot:${PORTSDIR}/graphics/graphviz \
+ p5-Algorithm-Dependency>=1.110:${PORTSDIR}/devel/p5-Algorithm-Dependency \
+ p5-Capture-Tiny>=0.10:${PORTSDIR}/devel/p5-Capture-Tiny \
+ p5-DBI>=1.616:${PORTSDIR}/databases/p5-DBI \
+ p5-Data-Section-Simple>=0.02:${PORTSDIR}/devel/p5-Data-Section-Simple \
+ p5-File-Which>=1.09:${PORTSDIR}/sysutils/p5-File-Which \
+ p5-HTML-Entities-Interpolate>=1.04:${PORTSDIR}/textproc/p5-HTML-Entities-Interpolate \
+ p5-HTML-Tree>=4.2:${PORTSDIR}/www/p5-HTML-Tree \
+ p5-Hash-FieldHash>=0.10:${PORTSDIR}/devel/p5-Hash-FieldHash \
+ p5-Log-Handler>=0.71:${PORTSDIR}/devel/p5-Log-Handler \
+ p5-Parse-RecDescent>=1.965.001:${PORTSDIR}/devel/p5-Parse-RecDescent \
+ p5-Perl6-Slurp>=0.03:${PORTSDIR}/devel/p5-Perl6-Slurp \
+ p5-Set-Array>=0.23:${PORTSDIR}/devel/p5-Set-Array \
+ p5-Text-Xslate>=1.2000:${PORTSDIR}/textproc/p5-Text-Xslate \
+ p5-TimeDate>=1.20:${PORTSDIR}/devel/p5-TimeDate \
+ p5-Tree-DAG_Node>=1.06:${PORTSDIR}/devel/p5-Tree-DAG_Node \
+ p5-Try-Tiny>=0.09:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-XML-Bare>=0.45:${PORTSDIR}/textproc/p5-XML-Bare \
+ p5-XML-Tiny>=2.06:${PORTSDIR}/textproc/p5-XML-Tiny
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Pod>=1.44:${PORTSDIR}/devel/p5-Test-Pod
+
+PERL_CONFIGURE= yes
+
+MAN3= GraphViz2.3 \
+ GraphViz2::DBI.3 \
+ GraphViz2::Data::Grapher.3 \
+ GraphViz2::Parse::ISA.3 \
+ GraphViz2::Parse::Marpa.3 \
+ GraphViz2::Parse::RecDescent.3 \
+ GraphViz2::Parse::Regexp.3 \
+ GraphViz2::Parse::STT.3 \
+ GraphViz2::Parse::XML.3 \
+ GraphViz2::Parse::Yacc.3 \
+ GraphViz2::Parse::Yapp.3 \
+ GraphViz2::Utils.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+BUILD_DEPENDS+= p5-File-Temp>=0.22:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS+= p5-File-Temp>=0.22:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.if ${PERL_LEVEL} < 501200
+TEST_DEPENDS+= p5-Test-Simple>=0.94:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.if ${PERL_LEVEL} < 501400
+BUILD_DEPENDS+= p5-HTTP-Tiny>=0.012:${PORTSDIR}/www/p5-HTTP-Tiny \
+ p5-PathTools>=3.3300:${PORTSDIR}/devel/p5-PathTools \
+ p5-Pod-Simple>=3.16:${PORTSDIR}/textproc/p5-Pod-Simple \
+ p5-Scalar-List-Utils>=1.23:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS+= p5-HTTP-Tiny>=0.012:${PORTSDIR}/www/p5-HTTP-Tiny \
+ p5-PathTools>=3.3300:${PORTSDIR}/devel/p5-PathTools \
+ p5-Pod-Simple>=3.16:${PORTSDIR}/textproc/p5-Pod-Simple \
+ p5-Scalar-List-Utils>=1.23:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/p5-GraphViz2/distinfo b/graphics/p5-GraphViz2/distinfo
new file mode 100644
index 000000000000..56ff8f891ad2
--- /dev/null
+++ b/graphics/p5-GraphViz2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (GraphViz2-1.11.tgz) = 336a2d8d4cf59bfbe5fc4bd4fdf8bd0a878b5c753949f7b0dd637df2d402bedc
+SIZE (GraphViz2-1.11.tgz) = 182640
diff --git a/graphics/p5-GraphViz2/pkg-descr b/graphics/p5-GraphViz2/pkg-descr
new file mode 100644
index 000000000000..45ee6f726ce2
--- /dev/null
+++ b/graphics/p5-GraphViz2/pkg-descr
@@ -0,0 +1,24 @@
+This module provides a Perl interface to the amazing Graphviz, an open source
+graph visualization tool from AT&T.
+
+It is called GraphViz2 so that pre-existing code using (the Perl module)
+GraphViz continues to work.
+
+To avoid confusion, when I use GraphViz2 (note the capital V), I'm referring to
+this Perl module, and when I use Graphviz (lower-case v) I'm referring to the
+underlying tool (which is in fact a set of programs).
+
+This version of GraphViz2 targets Graphviz 2.23.6+.
+
+GraphViz2 1.x is a complete re-write, by Ron Savage, of GraphViz 2.x, which was
+written by Leon Brocard. The point of the re-write is to provide access to all
+the latest options available to users of Graphviz.
+
+GraphViz2 1.x is not backwards compatible with GraphViz 2.x, despite the
+considerable similarity. It was not possible to maintain compatibility while
+extending support to all the latest features of Graphviz.
+
+To ensure GraphViz2 is a light-weight module, Hash::FieldHash has been used to
+provide getters and setters, rather than Moose.
+
+WWW: http://search.cpan.org/dist/GraphViz2/
diff --git a/graphics/p5-GraphViz2/pkg-plist b/graphics/p5-GraphViz2/pkg-plist
new file mode 100644
index 000000000000..377f8e2e198e
--- /dev/null
+++ b/graphics/p5-GraphViz2/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/GraphViz2.pm
+%%SITE_PERL%%/GraphViz2/DBI.pm
+%%SITE_PERL%%/GraphViz2/Data/Grapher.pm
+%%SITE_PERL%%/GraphViz2/Parse/ISA.pm
+%%SITE_PERL%%/GraphViz2/Parse/Marpa.pm
+%%SITE_PERL%%/GraphViz2/Parse/RecDescent.pm
+%%SITE_PERL%%/GraphViz2/Parse/Regexp.pm
+%%SITE_PERL%%/GraphViz2/Parse/STT.pm
+%%SITE_PERL%%/GraphViz2/Parse/XML.pm
+%%SITE_PERL%%/GraphViz2/Parse/Yacc.pm
+%%SITE_PERL%%/GraphViz2/Parse/Yapp.pm
+%%SITE_PERL%%/GraphViz2/Utils.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GraphViz2/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GraphViz2
+@dirrm %%SITE_PERL%%/GraphViz2/Parse
+@dirrm %%SITE_PERL%%/GraphViz2/Data
+@dirrm %%SITE_PERL%%/GraphViz2