aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Image-Grab/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-10 20:16:05 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-10 20:16:05 +0000
commit676b866eecc802377587483fa81153dc2392035f (patch)
tree4d2473a1d0a5dfce0963bc7f193d9eb63909227d /graphics/p5-Image-Grab/Makefile
parent11d86ccd31a76d611a3c66d2ebf87ee38e4e33bf (diff)
downloadports-676b866eecc802377587483fa81153dc2392035f.tar.gz
ports-676b866eecc802377587483fa81153dc2392035f.zip
Notes
Diffstat (limited to 'graphics/p5-Image-Grab/Makefile')
-rw-r--r--graphics/p5-Image-Grab/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/p5-Image-Grab/Makefile b/graphics/p5-Image-Grab/Makefile
new file mode 100644
index 000000000000..60836144e69a
--- /dev/null
+++ b/graphics/p5-Image-Grab/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Image-Grab
+# Date created: 8 April 2001
+# Whom: Anatoliy Dmytriyev <tolid@plab.ku.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image-Grab
+PORTVERSION= 1.3
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Image
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tolid@plab.ku.dk
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/HTML/Tree.pm:${PORTSDIR}/www/p5-HTML-Tree \
+ ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+CONFIGURE_ENV= ${ECHO} "N" |
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Image::Grab.3
+
+.include <bsd.port.mk>