aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Image-IPTCInfo/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-14 07:52:55 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-14 07:52:55 +0000
commite6c12b5d61ace20e4917579235fe304eee8af7fe (patch)
tree5fa23b20ad8ffff895127e8263c7603c4c64d76a /graphics/p5-Image-IPTCInfo/Makefile
parent04e4da87590388d60f3e056ce5f86a0a4f7792a8 (diff)
downloadports-e6c12b5d61ace20e4917579235fe304eee8af7fe.tar.gz
ports-e6c12b5d61ace20e4917579235fe304eee8af7fe.zip
Notes
Diffstat (limited to 'graphics/p5-Image-IPTCInfo/Makefile')
-rw-r--r--graphics/p5-Image-IPTCInfo/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/p5-Image-IPTCInfo/Makefile b/graphics/p5-Image-IPTCInfo/Makefile
new file mode 100644
index 000000000000..ac71dbfe9076
--- /dev/null
+++ b/graphics/p5-Image-IPTCInfo/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Image-IPTCInfo
+# Date created: 2006-08-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Image-IPTCInfo
+PORTVERSION= 1.94
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Image
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl extension for extracting IPTC image meta-data
+
+PERL_CONFIGURE= yes
+
+MAN3= Image::IPTCInfo.3
+
+post-patch:
+ ${RM} -f ${WRKSRC}/._*
+ ${PERL} -pi -e 's,/usr/bin/perl,${PERL},' ${WRKSRC}/demo.pl
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/demo_images/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>