aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Imager
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-06 10:34:16 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-06 10:34:16 +0000
commitacc0cc54568bef4949728712cc28639851152ae4 (patch)
tree0c7b970547236fc552268cf262038483176ec791 /graphics/p5-Imager
parent67ededf90874e04ed7b743cffba29563d6a6f3a6 (diff)
downloadports-acc0cc54568bef4949728712cc28639851152ae4.tar.gz
ports-acc0cc54568bef4949728712cc28639851152ae4.zip
Notes
Diffstat (limited to 'graphics/p5-Imager')
-rw-r--r--graphics/p5-Imager/files/patch-GIF_LIB_VERSION27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/p5-Imager/files/patch-GIF_LIB_VERSION b/graphics/p5-Imager/files/patch-GIF_LIB_VERSION
new file mode 100644
index 000000000000..fdeb861f4599
--- /dev/null
+++ b/graphics/p5-Imager/files/patch-GIF_LIB_VERSION
@@ -0,0 +1,27 @@
+--- GIF/Makefile.PL 2012-03-18 15:35:09.000000000 +0400
++++ GIF/Makefile.PL 2012-06-06 14:14:57.076093500 +0400
+@@ -109,6 +109,11 @@
+
+ sub _gif_test_code {
+ return <<'CODE';
++
++#ifndef GIF_LIB_VERSION
++#define GIF_LIB_VERSION " Version 4.2, "
++#endif
++
+ /* TODO: test DGifOpen() and processing with callbacks */
+ GifFileType *gf;
+ const char vers[] = GIF_LIB_VERSION;
+--- GIF/imgif.c 2011-11-25 14:31:00.000000000 +0400
++++ GIF/imgif.c 2012-06-06 14:15:13.033980092 +0400
+@@ -10,6 +10,10 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+
++#ifndef GIF_LIB_VERSION
++#define GIF_LIB_VERSION " Version 4.2, "
++#endif
++
+ /*
+ =head1 NAME
+