aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Layout-Manager/Makefile
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-08-30 23:07:16 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-08-30 23:07:16 +0000
commit49a55a1f804d8b1749fbf97ebb6cbfdb70ae5183 (patch)
treef14470b63fa0aa24f929358837d9ae533c3f790b /graphics/p5-Layout-Manager/Makefile
parentb0c15d5384e37eac82ca5c783aa061b52d13cfda (diff)
downloadports-49a55a1f804d8b1749fbf97ebb6cbfdb70ae5183.tar.gz
ports-49a55a1f804d8b1749fbf97ebb6cbfdb70ae5183.zip
Notes
Diffstat (limited to 'graphics/p5-Layout-Manager/Makefile')
-rw-r--r--graphics/p5-Layout-Manager/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/graphics/p5-Layout-Manager/Makefile b/graphics/p5-Layout-Manager/Makefile
new file mode 100644
index 000000000000..90f54a4a8838
--- /dev/null
+++ b/graphics/p5-Layout-Manager/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: Layout-Manager
+# Date created: 2008/08/30
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Layout-Manager
+PORTVERSION= 0.16
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/G/GP/GPHAT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= 2D Layout Management
+
+BUILD_DEPENDS= p5-Moose>=0.25:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-AttributeHelpers>=0:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
+ p5-Module-Install>=0.64:${PORTSDIR}/devel/p5-Module-Install \
+ p5-Geometry-Primitive>=0:${PORTSDIR}/graphics/p5-Geometry-Primitive \
+ p5-Graphics-Primitive>=0:${PORTSDIR}/graphics/p5-Graphics-Primitive
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Layout::Manager.3 \
+ Layout::Manager::Absolute.3 \
+ Layout::Manager::Axis.3 \
+ Layout::Manager::Compass.3 \
+ Layout::Manager::Flow.3 \
+ Layout::Manager::Single.3
+
+.include <bsd.port.mk>