aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-SVG-DOM2/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-15 05:19:15 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-15 05:19:15 +0000
commit0e29681c02e1b30986e2b29346a2dc0db354be7a (patch)
tree48897688a6c2f6b02f0e2a674f542658d158f6c8 /graphics/p5-SVG-DOM2/Makefile
parent6f2a187950af7c3ddfab893fca70ce085cc84d60 (diff)
downloadports-0e29681c02e1b30986e2b29346a2dc0db354be7a.tar.gz
ports-0e29681c02e1b30986e2b29346a2dc0db354be7a.zip
Notes
Diffstat (limited to 'graphics/p5-SVG-DOM2/Makefile')
-rw-r--r--graphics/p5-SVG-DOM2/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/p5-SVG-DOM2/Makefile b/graphics/p5-SVG-DOM2/Makefile
new file mode 100644
index 000000000000..5e81b0a828e0
--- /dev/null
+++ b/graphics/p5-SVG-DOM2/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-SVG-DOM2
+# Date created: 2006-07-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVG-DOM2
+PORTVERSION= 1.00
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SVG
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= SVG extention to the popular XML::DOM2
+
+PERL_CONFIGURE= yes
+
+MAN3= SVG::DOM2.3 SVG::DOM2::Attribute::Transform.3 \
+ SVG::DOM2::Element::Document.3 SVG::DOM2::Element::Shape.3 \
+ SVG::DOM2::Element::Shape::Fill.3 \
+ SVG::DOM2::Element::Shape::Font.3 \
+ SVG::DOM2::Element::Shape::Stroke.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>