aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-SVG-Metadata/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-14 04:45:56 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-14 04:45:56 +0000
commit4e4478adb9e439c23f4b90ead569d5bfe3310ceb (patch)
tree5a669eda92ffe58b362c452d534c4279e50337f2 /graphics/p5-SVG-Metadata/Makefile
parent1b1bf89f0a0cd2e441c3da32de119dce16ba16a4 (diff)
downloadports-4e4478adb9e439c23f4b90ead569d5bfe3310ceb.tar.gz
ports-4e4478adb9e439c23f4b90ead569d5bfe3310ceb.zip
Notes
Diffstat (limited to 'graphics/p5-SVG-Metadata/Makefile')
-rw-r--r--graphics/p5-SVG-Metadata/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/graphics/p5-SVG-Metadata/Makefile b/graphics/p5-SVG-Metadata/Makefile
new file mode 100644
index 000000000000..c7688de2fd33
--- /dev/null
+++ b/graphics/p5-SVG-Metadata/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-SVG-Metadata
+# Date created: 2005-03-13
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVG-Metadata
+PORTVERSION= 0.21
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SVG
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= Perl module to capture metadata info about an SVG file
+
+BUILD_DEPENDS= xml_grep:${PORTSDIR}/textproc/p5-XML-Twig
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= svg_validate.1 svg_annotate.1
+MAN3= SVG::Metadata.3
+
+post-patch:
+ ${RM} -f ${WRKSRC}/lib/SVG/Metadata.pm.orig
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= This port requires perl 5.6.0 or later, Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>