aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-SWF-File/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-05-20 10:50:01 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-05-20 10:50:01 +0000
commit05dc097def15a05420c9a279f25673495c8629ca (patch)
tree62c8e17efb5b14cab412d7b529da66308d2705c8 /graphics/p5-SWF-File/Makefile
parent9bd89d3ca4b9c4d1dbeec7f633268a3e2e8db3dc (diff)
Notes
Diffstat (limited to 'graphics/p5-SWF-File/Makefile')
-rw-r--r--graphics/p5-SWF-File/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/graphics/p5-SWF-File/Makefile b/graphics/p5-SWF-File/Makefile
new file mode 100644
index 000000000000..5e968b77f8f8
--- /dev/null
+++ b/graphics/p5-SWF-File/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: SWF-File
+# Date created: 20 May 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SWF-File
+PORTVERSION= 0.22
+CATEGORIES= graphics www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/Y/YS/YSAS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Manipulating Flash movie (SWF) files
+
+BUILD_DEPENDS= ${SITE_PERL}/Data/TemporaryBag.pm:${PORTSDIR}/devel/p5-Data-TemporaryBag
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SWF::BinStream.3 SWF::BinStream::Codec.3 \
+ SWF::BinStream::Codec::Zlib.3 SWF::BinStream::File.3 \
+ SWF::Element.3 SWF::File.3 SWF::Parser.3
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f |\
+ ${XARGS} ${PERL} -pi -e 's/\x0d(?=\x0a)//'
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>